%global _empty_manifest_terminate_build 0
Name: python-jsonlib
Version: 1.6.1
Release: 1
Summary: JSON serializer/deserializer for Python
License: GPL
URL: https://launchpad.net/jsonlib
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7c/55/19c29fd79dfb5d42f4568feedc5a286d01d0683a372c1e19024531576508/jsonlib-1.6.1.tar.gz
BuildArch: noarch
%description
`JSON `_ is a lightweight data-interchange format. It
is often used for exchanging data between a web server and user agent.
This module aims to produce a library for serializing and deserializing
JSON that conforms strictly to RFC 4627.
For the Python 3 version of jsonlib, see `jsonlib-python3
`_.
Other JSON implementations of interest include `simplejson
`_ (available in the standard library as
of Python 2.6) and `demjson `_.
%package -n python3-jsonlib
Summary: JSON serializer/deserializer for Python
Provides: python-jsonlib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jsonlib
`JSON `_ is a lightweight data-interchange format. It
is often used for exchanging data between a web server and user agent.
This module aims to produce a library for serializing and deserializing
JSON that conforms strictly to RFC 4627.
For the Python 3 version of jsonlib, see `jsonlib-python3
`_.
Other JSON implementations of interest include `simplejson
`_ (available in the standard library as
of Python 2.6) and `demjson `_.
%package help
Summary: Development documents and examples for jsonlib
Provides: python3-jsonlib-doc
%description help
`JSON `_ is a lightweight data-interchange format. It
is often used for exchanging data between a web server and user agent.
This module aims to produce a library for serializing and deserializing
JSON that conforms strictly to RFC 4627.
For the Python 3 version of jsonlib, see `jsonlib-python3
`_.
Other JSON implementations of interest include `simplejson
`_ (available in the standard library as
of Python 2.6) and `demjson `_.
%prep
%autosetup -n jsonlib-1.6.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jsonlib -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.6.1-1
- Package Spec generated