%global _empty_manifest_terminate_build 0
Name:		python-adafruit-io
Version:	2.7.0
Release:	1
Summary:	Python client library for Adafruit IO (http://io.adafruit.com/).
License:	MIT
URL:		https://github.com/adafruit/Adafruit_IO_Python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/44/d0/7b8e112dfb593f2622dc43edbbea5a1007062ad2d75f330dec135faf6b98/adafruit-io-2.7.0.tar.gz
BuildArch:	noarch


%description
A Python library and examples for use with `io.adafruit.com <https://io.adafruit.com>`_. 
Compatible with Python Versions 3.4+

%package -n python3-adafruit-io
Summary:	Python client library for Adafruit IO (http://io.adafruit.com/).
Provides:	python-adafruit-io
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-adafruit-io
A Python library and examples for use with `io.adafruit.com <https://io.adafruit.com>`_. 
Compatible with Python Versions 3.4+

%package help
Summary:	Development documents and examples for adafruit-io
Provides:	python3-adafruit-io-doc
%description help
A Python library and examples for use with `io.adafruit.com <https://io.adafruit.com>`_. 
Compatible with Python Versions 3.4+

%prep
%autosetup -n adafruit-io-2.7.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-adafruit-io -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.7.0-1
- Package Spec generated