%global _empty_manifest_terminate_build 0
Name: python-brain-isotopic-distribution
Version: 1.5.11
Release: 1
Summary: Fast and efficient theoretical isotopic profile generation
License: Apache Software License
URL: https://github.com/mobiusklein/brainpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/78/ac/867b73270391841ceec40fa890e4968fc9d3bc8b820e5177d707f961dd56/brain-isotopic-distribution-1.5.11.tar.gz
%description
of that implementation, and a pure C implementation that releases the :title-reference:`GIL`.
To install from a package index, you will need to have a C compiler appropriate to your Python
version to build these extension modules. Additionally, there are prebuilt wheels for Windows
available on `PyPI `_:
$ pip install brain-isotopic-distribution
To build from source, in addition to a C compiler you will also need to install a recent version
of `Cython `_ to transpile C code.
%package -n python3-brain-isotopic-distribution
Summary: Fast and efficient theoretical isotopic profile generation
Provides: python-brain-isotopic-distribution
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-brain-isotopic-distribution
of that implementation, and a pure C implementation that releases the :title-reference:`GIL`.
To install from a package index, you will need to have a C compiler appropriate to your Python
version to build these extension modules. Additionally, there are prebuilt wheels for Windows
available on `PyPI `_:
$ pip install brain-isotopic-distribution
To build from source, in addition to a C compiler you will also need to install a recent version
of `Cython `_ to transpile C code.
%package help
Summary: Development documents and examples for brain-isotopic-distribution
Provides: python3-brain-isotopic-distribution-doc
%description help
of that implementation, and a pure C implementation that releases the :title-reference:`GIL`.
To install from a package index, you will need to have a C compiler appropriate to your Python
version to build these extension modules. Additionally, there are prebuilt wheels for Windows
available on `PyPI `_:
$ pip install brain-isotopic-distribution
To build from source, in addition to a C compiler you will also need to install a recent version
of `Cython `_ to transpile C code.
%prep
%autosetup -n brain-isotopic-distribution-1.5.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-brain-isotopic-distribution -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.5.11-1
- Package Spec generated