%global _empty_manifest_terminate_build 0
Name: python-maec
Version: 4.1.0.17
Release: 1
Summary: An API for parsing and creating MAEC content.
License: BSD
URL: https://maecproject.github.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b9/7c/858bc5344b35c3555b66abede328f1891d9ab06956e567cff23bc06ba68e/maec-4.1.0.17.tar.gz
BuildArch: noarch
Requires: python3-mixbox
Requires: python3-cybox
Requires: python3-lxml
Requires: python3-lxml
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-nose
Requires: python3-tox
%description
A Python library for parsing, manipulating, and generating `Malware Attribute Enumeration and Characterization (MAEC™) `_ v4.1 content.
|travis badge| |landscape.io badge| |version badge| |downloads badge|
%package -n python3-maec
Summary: An API for parsing and creating MAEC content.
Provides: python-maec
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-maec
A Python library for parsing, manipulating, and generating `Malware Attribute Enumeration and Characterization (MAEC™) `_ v4.1 content.
|travis badge| |landscape.io badge| |version badge| |downloads badge|
%package help
Summary: Development documents and examples for maec
Provides: python3-maec-doc
%description help
A Python library for parsing, manipulating, and generating `Malware Attribute Enumeration and Characterization (MAEC™) `_ v4.1 content.
|travis badge| |landscape.io badge| |version badge| |downloads badge|
%prep
%autosetup -n maec-4.1.0.17
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-maec -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 4.1.0.17-1
- Package Spec generated