%global _empty_manifest_terminate_build 0
Name: python-django-manifest-loader
Version: 1.0.0
Release: 1
Summary: A Django app to load webpack assets.
License: BSD-3-Clause
URL: https://www.github.com/shonin/django-manifest-loader
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9d/8a/beee999d51293668bf349ad688df066a77b822f94403a5f03237cbd0a164/django-manifest-loader-1.0.0.tar.gz
BuildArch: noarch
Requires: python3-django
%description
# Django Manifest Loader
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/main?label=stable%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/dev?label=development%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat-square)](#)
Reads a manifest file to import your assets into a Django template. Find
the URL for a single asset or the URLs for multiple assets by using
pattern matching against the file names. Path resolution handled using
Django's built-in `staticfiles` app. Minimal configuraton,
cache-busting, split chunks.
## [Documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
## About
**Turns this**
```djangotemplate
{% load manifest %}
```
**Into this**
```djangotemplate
```
* [Official documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
* For an in-depth look at this package, check out [this blog post here](https://medium.com/@shonin/django-and-webpack-now-work-together-seamlessly-a90cffdbab8e)
* [Quick start blog post](https://medium.com/@shonin/django-and-webpack-in-4-short-steps-b39bd3380c71)
## Quick reference:
### Manifest tag
```djangotemplate
{% load manifest %}
```
turns into
```html
```
### Manifest match tag
```djangotemplate
{% load manifest %}
{% manifest_match '*.js' '' %}
```
turns into
```html
```
### License
Django Manifest Loader is distributed under the [3-clause BSD license](https://opensource.org/licenses/BSD-3-Clause).
This is an open source license granting broad permissions to modify and redistribute the software.
%package -n python3-django-manifest-loader
Summary: A Django app to load webpack assets.
Provides: python-django-manifest-loader
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-manifest-loader
# Django Manifest Loader
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/main?label=stable%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/dev?label=development%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat-square)](#)
Reads a manifest file to import your assets into a Django template. Find
the URL for a single asset or the URLs for multiple assets by using
pattern matching against the file names. Path resolution handled using
Django's built-in `staticfiles` app. Minimal configuraton,
cache-busting, split chunks.
## [Documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
## About
**Turns this**
```djangotemplate
{% load manifest %}
```
**Into this**
```djangotemplate
```
* [Official documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
* For an in-depth look at this package, check out [this blog post here](https://medium.com/@shonin/django-and-webpack-now-work-together-seamlessly-a90cffdbab8e)
* [Quick start blog post](https://medium.com/@shonin/django-and-webpack-in-4-short-steps-b39bd3380c71)
## Quick reference:
### Manifest tag
```djangotemplate
{% load manifest %}
```
turns into
```html
```
### Manifest match tag
```djangotemplate
{% load manifest %}
{% manifest_match '*.js' '' %}
```
turns into
```html
```
### License
Django Manifest Loader is distributed under the [3-clause BSD license](https://opensource.org/licenses/BSD-3-Clause).
This is an open source license granting broad permissions to modify and redistribute the software.
%package help
Summary: Development documents and examples for django-manifest-loader
Provides: python3-django-manifest-loader-doc
%description help
# Django Manifest Loader
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/main?label=stable%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![Build Status](https://img.shields.io/travis/shonin/django-manifest-loader/dev?label=development%20branch&style=flat-square
)](https://travis-ci.org/shonin/django-manifest-loader)
[![contributions welcome](https://img.shields.io/badge/contributions-welcome-brightgreen.svg?style=flat-square)](#)
Reads a manifest file to import your assets into a Django template. Find
the URL for a single asset or the URLs for multiple assets by using
pattern matching against the file names. Path resolution handled using
Django's built-in `staticfiles` app. Minimal configuraton,
cache-busting, split chunks.
## [Documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
## About
**Turns this**
```djangotemplate
{% load manifest %}
```
**Into this**
```djangotemplate
```
* [Official documentation](https://django-manifest-loader.readthedocs.io/en/latest/index.html)
* For an in-depth look at this package, check out [this blog post here](https://medium.com/@shonin/django-and-webpack-now-work-together-seamlessly-a90cffdbab8e)
* [Quick start blog post](https://medium.com/@shonin/django-and-webpack-in-4-short-steps-b39bd3380c71)
## Quick reference:
### Manifest tag
```djangotemplate
{% load manifest %}
```
turns into
```html
```
### Manifest match tag
```djangotemplate
{% load manifest %}
{% manifest_match '*.js' '' %}
```
turns into
```html
```
### License
Django Manifest Loader is distributed under the [3-clause BSD license](https://opensource.org/licenses/BSD-3-Clause).
This is an open source license granting broad permissions to modify and redistribute the software.
%prep
%autosetup -n django-manifest-loader-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-manifest-loader -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.0-1
- Package Spec generated