%global _empty_manifest_terminate_build 0
Name: python-bigmcl
Version: 0.2b2
Release: 1
Summary: Large scale Markov clustering (MCL) via subgraph extraction
License: BSD License
URL: https://gitlab.com/xonq/bigmcl
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/74/5b/17291f8a5b15f9d0b4b531174adee9a2d379a8ec7d23e8ec4f35327c8f1c/bigmcl-0.2b2.tar.gz
BuildArch: noarch
%description
# bigmcl
## Large scale Markov clustering (MCL) via subgraph extraction
`bigmcl` will isolate disconnected subgraphs from a large graph file and execute
MCL on the subgraphs. bigmcl enables MCL on large, highly disconnected graphs,
such as those used in orthogroup inference. Not recommended for graphs that are
manageable with typical MCL.
Important to note that the inflation parameter is affected by this approach -
I have noted clusters are more granular if anything. In the future, I plan on
implementing a systematic approach option for identifying ideal inflations for
each subgraph.
Please cite this git repository and MCL when this software contributes to your analysis.
## DISCLAIMER
`bigmcl` is currently in a beta state, and while I appreciate bringing issues to
my attention, I am currently focused on getting things working well for my own
research, so I cannot guarantee timely issue resolution. My hope is `bigmcl` will
be in a longterm stable state by publication 2022.
## INSTALL
```
pip install bigmcl
```
Clone `mcl` [from here](https://github.com/micans/mcl), compile, and add to your path.
## USE
Input and go:
```
bigmcl -i -I 1.5
```
More elaborate options:
```
usage: bigmcl.py [-h] -i INPUT -I INFLATION [-s] [-r ROW_FILE] [-m] [-o OUTPUT] [-c CORES]
[-v]
Isolates disconnected graphs and runs MCL on the subgraphs. Input data must be numerical.
optional arguments:
-h, --help show this help message and exit
-i INPUT, --input INPUT
MCL graph file in imx format
-I INFLATION, --inflation INFLATION
-s, --symmetric Matrix is symmetric (throughput increase)
-r ROW_FILE, --row_file ROW_FILE
Continue from finished row.txt
-m, --mcl_format Output clusters in MCL format
-o OUTPUT, --output OUTPUT
Alternative output directory
-c CORES, --cores CORES
-v, --verbose
```
%package -n python3-bigmcl
Summary: Large scale Markov clustering (MCL) via subgraph extraction
Provides: python-bigmcl
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bigmcl
# bigmcl
## Large scale Markov clustering (MCL) via subgraph extraction
`bigmcl` will isolate disconnected subgraphs from a large graph file and execute
MCL on the subgraphs. bigmcl enables MCL on large, highly disconnected graphs,
such as those used in orthogroup inference. Not recommended for graphs that are
manageable with typical MCL.
Important to note that the inflation parameter is affected by this approach -
I have noted clusters are more granular if anything. In the future, I plan on
implementing a systematic approach option for identifying ideal inflations for
each subgraph.
Please cite this git repository and MCL when this software contributes to your analysis.
## DISCLAIMER
`bigmcl` is currently in a beta state, and while I appreciate bringing issues to
my attention, I am currently focused on getting things working well for my own
research, so I cannot guarantee timely issue resolution. My hope is `bigmcl` will
be in a longterm stable state by publication 2022.
## INSTALL
```
pip install bigmcl
```
Clone `mcl` [from here](https://github.com/micans/mcl), compile, and add to your path.
## USE
Input and go:
```
bigmcl -i -I 1.5
```
More elaborate options:
```
usage: bigmcl.py [-h] -i INPUT -I INFLATION [-s] [-r ROW_FILE] [-m] [-o OUTPUT] [-c CORES]
[-v]
Isolates disconnected graphs and runs MCL on the subgraphs. Input data must be numerical.
optional arguments:
-h, --help show this help message and exit
-i INPUT, --input INPUT
MCL graph file in imx format
-I INFLATION, --inflation INFLATION
-s, --symmetric Matrix is symmetric (throughput increase)
-r ROW_FILE, --row_file ROW_FILE
Continue from finished row.txt
-m, --mcl_format Output clusters in MCL format
-o OUTPUT, --output OUTPUT
Alternative output directory
-c CORES, --cores CORES
-v, --verbose
```
%package help
Summary: Development documents and examples for bigmcl
Provides: python3-bigmcl-doc
%description help
# bigmcl
## Large scale Markov clustering (MCL) via subgraph extraction
`bigmcl` will isolate disconnected subgraphs from a large graph file and execute
MCL on the subgraphs. bigmcl enables MCL on large, highly disconnected graphs,
such as those used in orthogroup inference. Not recommended for graphs that are
manageable with typical MCL.
Important to note that the inflation parameter is affected by this approach -
I have noted clusters are more granular if anything. In the future, I plan on
implementing a systematic approach option for identifying ideal inflations for
each subgraph.
Please cite this git repository and MCL when this software contributes to your analysis.
## DISCLAIMER
`bigmcl` is currently in a beta state, and while I appreciate bringing issues to
my attention, I am currently focused on getting things working well for my own
research, so I cannot guarantee timely issue resolution. My hope is `bigmcl` will
be in a longterm stable state by publication 2022.
## INSTALL
```
pip install bigmcl
```
Clone `mcl` [from here](https://github.com/micans/mcl), compile, and add to your path.
## USE
Input and go:
```
bigmcl -i -I 1.5
```
More elaborate options:
```
usage: bigmcl.py [-h] -i INPUT -I INFLATION [-s] [-r ROW_FILE] [-m] [-o OUTPUT] [-c CORES]
[-v]
Isolates disconnected graphs and runs MCL on the subgraphs. Input data must be numerical.
optional arguments:
-h, --help show this help message and exit
-i INPUT, --input INPUT
MCL graph file in imx format
-I INFLATION, --inflation INFLATION
-s, --symmetric Matrix is symmetric (throughput increase)
-r ROW_FILE, --row_file ROW_FILE
Continue from finished row.txt
-m, --mcl_format Output clusters in MCL format
-o OUTPUT, --output OUTPUT
Alternative output directory
-c CORES, --cores CORES
-v, --verbose
```
%prep
%autosetup -n bigmcl-0.2b2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bigmcl -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.2b2-1
- Package Spec generated