%global _empty_manifest_terminate_build 0
Name: python-cdk8s-plus-17
Version: 0.33.0
Release: 1
Summary: High level abstractions on top of cdk8s
License: Apache-2.0
URL: https://github.com/awslabs/cdk8s.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5c/30/e1b7734ef318c34225d35f59dd406c4748e6da3e4125c4b4f9212d1d4bb6/cdk8s-plus-17-0.33.0.tar.gz
BuildArch: noarch
Requires: python3-cdk8s
Requires: python3-constructs
Requires: python3-jsii
Requires: python3-publication
%description
# cdk8s+ (cdk8s-plus)
> 
> This library is in very early stages of development, as such, and in correspondence with a `0.x` semantic major version line, its `API` is
> likely to rapidly change in breaking ways. It is therefore not recommended to use library for production workloads.
**cdk8s+** is a software development framework that provides high level abstractions for authoring Kubernetes applications.
Built on top of the auto generated building blocks provided by [cdk8s](../cdk8s), this library includes a hand crafted *construct*
for each native kubernetes object, exposing richer API's with reduced complexity.
## Documentation
See [cdk8s.io](https://cdk8s.io/docs/latest/plus).
## License
This project is distributed under the [Apache License, Version 2.0](./LICENSE).
This module is part of the [cdk8s project](https://github.com/awslabs/cdk8s).
%package -n python3-cdk8s-plus-17
Summary: High level abstractions on top of cdk8s
Provides: python-cdk8s-plus-17
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-cdk8s-plus-17
# cdk8s+ (cdk8s-plus)
> 
> This library is in very early stages of development, as such, and in correspondence with a `0.x` semantic major version line, its `API` is
> likely to rapidly change in breaking ways. It is therefore not recommended to use library for production workloads.
**cdk8s+** is a software development framework that provides high level abstractions for authoring Kubernetes applications.
Built on top of the auto generated building blocks provided by [cdk8s](../cdk8s), this library includes a hand crafted *construct*
for each native kubernetes object, exposing richer API's with reduced complexity.
## Documentation
See [cdk8s.io](https://cdk8s.io/docs/latest/plus).
## License
This project is distributed under the [Apache License, Version 2.0](./LICENSE).
This module is part of the [cdk8s project](https://github.com/awslabs/cdk8s).
%package help
Summary: Development documents and examples for cdk8s-plus-17
Provides: python3-cdk8s-plus-17-doc
%description help
# cdk8s+ (cdk8s-plus)
> 
> This library is in very early stages of development, as such, and in correspondence with a `0.x` semantic major version line, its `API` is
> likely to rapidly change in breaking ways. It is therefore not recommended to use library for production workloads.
**cdk8s+** is a software development framework that provides high level abstractions for authoring Kubernetes applications.
Built on top of the auto generated building blocks provided by [cdk8s](../cdk8s), this library includes a hand crafted *construct*
for each native kubernetes object, exposing richer API's with reduced complexity.
## Documentation
See [cdk8s.io](https://cdk8s.io/docs/latest/plus).
## License
This project is distributed under the [Apache License, Version 2.0](./LICENSE).
This module is part of the [cdk8s project](https://github.com/awslabs/cdk8s).
%prep
%autosetup -n cdk8s-plus-17-0.33.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cdk8s-plus-17 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.33.0-1
- Package Spec generated