%global _empty_manifest_terminate_build 0
Name:		python-execute-517
Version:	0.3.0
Release:	1
Summary:	Run a command in a PEP 517 env
License:	BSD 3-Clause
URL:		https://pypi.org/project/execute-517/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/46/eb/55bc21ec5c66700ba96292d025efec72cb8666e357be2c06ea0293918046/execute_517-0.3.0.tar.gz
BuildArch:	noarch


%description
This package allows you to run any Python command inside the build environment specified by the ``pyproject.toml`` file. This may be useful for executing specific ``setup.py`` commands inside an env where all the dependencies are available.
For example to get the version of a package run the following command in the root of the repository::
  $ execute-517 "setup.py --version"

%package -n python3-execute-517
Summary:	Run a command in a PEP 517 env
Provides:	python-execute-517
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-execute-517
This package allows you to run any Python command inside the build environment specified by the ``pyproject.toml`` file. This may be useful for executing specific ``setup.py`` commands inside an env where all the dependencies are available.
For example to get the version of a package run the following command in the root of the repository::
  $ execute-517 "setup.py --version"

%package help
Summary:	Development documents and examples for execute-517
Provides:	python3-execute-517-doc
%description help
This package allows you to run any Python command inside the build environment specified by the ``pyproject.toml`` file. This may be useful for executing specific ``setup.py`` commands inside an env where all the dependencies are available.
For example to get the version of a package run the following command in the root of the repository::
  $ execute-517 "setup.py --version"

%prep
%autosetup -n execute-517-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-execute-517 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated