%global _empty_manifest_terminate_build 0
Name: python-pyuploadcare
Version: 4.0.0
Release: 1
Summary: Python library for Uploadcare.com
License: MIT License
URL: https://uploadcare.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/62/7b/d8f73a7ffa0301014149ba34158849c84136c01ce4f5a154261e72e00f2f/pyuploadcare-4.0.0.tar.gz
BuildArch: noarch
Requires: python3-httpx
Requires: python3-httpx
Requires: python3-pydantic[email]
Requires: python3-dateutil
Requires: python3-pytz
Requires: python3-typing-extensions
Requires: python3-typing-extensions
Requires: python3-Django
%description
|
PyUploadcare: a Python library for Uploadcare
|
Uploadcare Python & Django integrations handle uploads and further operations
with files by wrapping Upload and REST APIs.
Simple file uploads for the web are of most importance for us. Today, everyone
is used to the routine of allowing users to upload their pics or attach resumes.
The routine covers it all: installing image processing libraries, adjusting
permissions, ensuring servers never go down, and enabling CDN.
This library consists of the Uploadcare API interface and a couple of Django
goodies.
Simple as that, Uploadcare `ImageField` can be added to an
existing Django project in just a couple of [simple steps](https://pyuploadcare.readthedocs.org/en/latest/quickstart.html).
This will enable your users to see the upload progress, pick files
from Google Drive or Instagram, and edit a form while files are
being uploaded asynchronously.
You can find an example project [here](https://github.com/uploadcare/pyuploadcare-example).
```python
from django import forms
from django.db import models
from pyuploadcare.dj.models import ImageField
from pyuploadcare.dj.forms import FileWidget, ImageField as ImageFormField
class Candidate(models.Model):
photo = ImageField(blank=True, manual_crop="")
# optional. provide advanced widget options: https://uploadcare.com/docs/uploads/widget/config/#options
class CandidateForm(forms.Form):
photo = ImageFormField(widget=FileWidget(attrs={
'data-cdn-base': 'https://cdn.super-candidates.com',
'data-image-shrink': '1024x1024',
}))
```

## Documentation
Detailed documentation is available [on RTD](https://pyuploadcare.readthedocs.io/en/latest/).
## Feedback
Issues and PRs are welcome. You can provide your feedback or drop us a support
request at [hello@uploadcare.com](hello@uploadcare.com).
%package -n python3-pyuploadcare
Summary: Python library for Uploadcare.com
Provides: python-pyuploadcare
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyuploadcare
|
PyUploadcare: a Python library for Uploadcare
|
Uploadcare Python & Django integrations handle uploads and further operations
with files by wrapping Upload and REST APIs.
Simple file uploads for the web are of most importance for us. Today, everyone
is used to the routine of allowing users to upload their pics or attach resumes.
The routine covers it all: installing image processing libraries, adjusting
permissions, ensuring servers never go down, and enabling CDN.
This library consists of the Uploadcare API interface and a couple of Django
goodies.
Simple as that, Uploadcare `ImageField` can be added to an
existing Django project in just a couple of [simple steps](https://pyuploadcare.readthedocs.org/en/latest/quickstart.html).
This will enable your users to see the upload progress, pick files
from Google Drive or Instagram, and edit a form while files are
being uploaded asynchronously.
You can find an example project [here](https://github.com/uploadcare/pyuploadcare-example).
```python
from django import forms
from django.db import models
from pyuploadcare.dj.models import ImageField
from pyuploadcare.dj.forms import FileWidget, ImageField as ImageFormField
class Candidate(models.Model):
photo = ImageField(blank=True, manual_crop="")
# optional. provide advanced widget options: https://uploadcare.com/docs/uploads/widget/config/#options
class CandidateForm(forms.Form):
photo = ImageFormField(widget=FileWidget(attrs={
'data-cdn-base': 'https://cdn.super-candidates.com',
'data-image-shrink': '1024x1024',
}))
```

## Documentation
Detailed documentation is available [on RTD](https://pyuploadcare.readthedocs.io/en/latest/).
## Feedback
Issues and PRs are welcome. You can provide your feedback or drop us a support
request at [hello@uploadcare.com](hello@uploadcare.com).
%package help
Summary: Development documents and examples for pyuploadcare
Provides: python3-pyuploadcare-doc
%description help
|
PyUploadcare: a Python library for Uploadcare
|
Uploadcare Python & Django integrations handle uploads and further operations
with files by wrapping Upload and REST APIs.
Simple file uploads for the web are of most importance for us. Today, everyone
is used to the routine of allowing users to upload their pics or attach resumes.
The routine covers it all: installing image processing libraries, adjusting
permissions, ensuring servers never go down, and enabling CDN.
This library consists of the Uploadcare API interface and a couple of Django
goodies.
Simple as that, Uploadcare `ImageField` can be added to an
existing Django project in just a couple of [simple steps](https://pyuploadcare.readthedocs.org/en/latest/quickstart.html).
This will enable your users to see the upload progress, pick files
from Google Drive or Instagram, and edit a form while files are
being uploaded asynchronously.
You can find an example project [here](https://github.com/uploadcare/pyuploadcare-example).
```python
from django import forms
from django.db import models
from pyuploadcare.dj.models import ImageField
from pyuploadcare.dj.forms import FileWidget, ImageField as ImageFormField
class Candidate(models.Model):
photo = ImageField(blank=True, manual_crop="")
# optional. provide advanced widget options: https://uploadcare.com/docs/uploads/widget/config/#options
class CandidateForm(forms.Form):
photo = ImageFormField(widget=FileWidget(attrs={
'data-cdn-base': 'https://cdn.super-candidates.com',
'data-image-shrink': '1024x1024',
}))
```

## Documentation
Detailed documentation is available [on RTD](https://pyuploadcare.readthedocs.io/en/latest/).
## Feedback
Issues and PRs are welcome. You can provide your feedback or drop us a support
request at [hello@uploadcare.com](hello@uploadcare.com).
%prep
%autosetup -n pyuploadcare-4.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyuploadcare -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 4.0.0-1
- Package Spec generated