%global _empty_manifest_terminate_build 0
Name:		python-cats-python
Version:	4.5.12
Release:	1
Summary:	Cifrazia Action Transport System for Python
License:	MIT
URL:		https://adambrianbright.github.io/cats-python/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3d/8a/38c7c0b899e2717060136dd6b7963a8fa423d575fb3cdd541f49a86e6d20/cats_python-4.5.12.tar.gz
BuildArch:	noarch

Requires:	python3-richerr
Requires:	python3-struct-model-python
Requires:	python3-pytz
Requires:	python3-tornado
Requires:	python3-PyYAML
Requires:	python3-toml
Requires:	python3-msgpack
Requires:	python3-Django
Requires:	python3-djangorestframework
Requires:	python3-pydantic
Requires:	python3-djantic
Requires:	python3-rollbar
Requires:	python3-ujson

%description
# Welcome

[![PyPI version](https://badge.fury.io/py/cats-python.svg)](https://badge.fury.io/py/cats-python) [![codecov](https://codecov.io/gh/Cifrazia/cats-python/branch/master/graph/badge.svg?token=MMDPS40REC)](https://codecov.io/gh/Cifrazia/cats-python) [![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=shield)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_shield)

## Cifrazia Action Transport System

CATS - is a TCP based byte protocol for persistence package exchanging. This so-called protocol is designed specifically
for internal use in [Cifrazia](https://cifrazia.com).

[Learn more about protocol](./protocol)

## Features

+ One action at a time
+ Up-to 4GB payload in single [plain Action](protocol/2.0.md#0x00-action)
+ Unlimited and delayed payload in [Streaming Actions](protocol/2.0.md#0x01-streamaction)
+ Chained [inputs](protocol/2.0.md#inputs)
+ [Broadcasts](protocol/2.0.md#broadcast)
+ Multiple [data formats](protocol/2.0.md#data-types)
+ Custom [handshakes](protocol/2.0.md#handshake)
+ ~~Local and global encryption~~

[!ref](get-started.md)

## Requirements

+ Python `^3.9`
+ Tornado `^6.1`
+ Sentry SDK `^1.1.0`
+ uJSON `^4.0.2`
+ PyTZ `^2021.1`

[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_large)

%package -n python3-cats-python
Summary:	Cifrazia Action Transport System for Python
Provides:	python-cats-python
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cats-python
# Welcome

[![PyPI version](https://badge.fury.io/py/cats-python.svg)](https://badge.fury.io/py/cats-python) [![codecov](https://codecov.io/gh/Cifrazia/cats-python/branch/master/graph/badge.svg?token=MMDPS40REC)](https://codecov.io/gh/Cifrazia/cats-python) [![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=shield)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_shield)

## Cifrazia Action Transport System

CATS - is a TCP based byte protocol for persistence package exchanging. This so-called protocol is designed specifically
for internal use in [Cifrazia](https://cifrazia.com).

[Learn more about protocol](./protocol)

## Features

+ One action at a time
+ Up-to 4GB payload in single [plain Action](protocol/2.0.md#0x00-action)
+ Unlimited and delayed payload in [Streaming Actions](protocol/2.0.md#0x01-streamaction)
+ Chained [inputs](protocol/2.0.md#inputs)
+ [Broadcasts](protocol/2.0.md#broadcast)
+ Multiple [data formats](protocol/2.0.md#data-types)
+ Custom [handshakes](protocol/2.0.md#handshake)
+ ~~Local and global encryption~~

[!ref](get-started.md)

## Requirements

+ Python `^3.9`
+ Tornado `^6.1`
+ Sentry SDK `^1.1.0`
+ uJSON `^4.0.2`
+ PyTZ `^2021.1`

[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_large)

%package help
Summary:	Development documents and examples for cats-python
Provides:	python3-cats-python-doc
%description help
# Welcome

[![PyPI version](https://badge.fury.io/py/cats-python.svg)](https://badge.fury.io/py/cats-python) [![codecov](https://codecov.io/gh/Cifrazia/cats-python/branch/master/graph/badge.svg?token=MMDPS40REC)](https://codecov.io/gh/Cifrazia/cats-python) [![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=shield)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_shield)

## Cifrazia Action Transport System

CATS - is a TCP based byte protocol for persistence package exchanging. This so-called protocol is designed specifically
for internal use in [Cifrazia](https://cifrazia.com).

[Learn more about protocol](./protocol)

## Features

+ One action at a time
+ Up-to 4GB payload in single [plain Action](protocol/2.0.md#0x00-action)
+ Unlimited and delayed payload in [Streaming Actions](protocol/2.0.md#0x01-streamaction)
+ Chained [inputs](protocol/2.0.md#inputs)
+ [Broadcasts](protocol/2.0.md#broadcast)
+ Multiple [data formats](protocol/2.0.md#data-types)
+ Custom [handshakes](protocol/2.0.md#handshake)
+ ~~Local and global encryption~~

[!ref](get-started.md)

## Requirements

+ Python `^3.9`
+ Tornado `^6.1`
+ Sentry SDK `^1.1.0`
+ uJSON `^4.0.2`
+ PyTZ `^2021.1`

[![FOSSA Status](https://app.fossa.com/api/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python.svg?type=large)](https://app.fossa.com/projects/git%2Bgithub.com%2FCifrazia%2Fcats-python?ref=badge_large)

%prep
%autosetup -n cats-python-4.5.12

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cats-python -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 4.5.12-1
- Package Spec generated