%global _empty_manifest_terminate_build 0
Name:		python-upbge-stubs
Version:	0.3.0.27
Release:	1
Summary:	API stubs for Blender and UPBGE generated with bpystubgen.
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://github.com/mysticfall/bpystubgen
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3a/65/8cc2cfe180029b6b206475fb6d29dc9571c38637d3894f1138d886205c76/upbge-stubs-0.3.0.27.tar.gz
BuildArch:	noarch


%description
This module provides type information for [Blender](https://www.blender.org) and 
[UPBGE](https://upbge.org)'s Python API, following the 
[PEP-561](https://www.python.org/dev/peps/pep-0561/) standard.
It was generated using [BPY Stub Generator](https://github.com/mysticfall/bpystubgen) which 
is also available on [PyPI](https://pypi.org/project/bpystubgen) as a separate module.
## Screenshots ##
Auto-completion at work in PyCharm:
![Screenshot in PyCharm](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-pycharm.png?raw=true "Screenshot in PyCharm")
Pop-up documentation support in VSCode:
![Screenshot in VSCode](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-vscode.png?raw=true "Screenshot in VSCode")
## Installation ##
There are two variants of the API stubs, one for Blender and the other for UPBGE. For Blender, 
you can install `blender-stubs` module with appropriate version qualifier as follows: 
```bash
$ pip install blender-stubs==3.1.26
```
This will install the latest module for Blender 2.93, and for now stubs are provided for Blender 
2.80 and onwards. You can also specify the next unreleased version as `3.1.*` to get the latest 
snapshot of the module:
```bash
$ pip install blender-stubs==3.2.*
```
A stub module for UPBGE 0.3, as well as pre-release versions for the master branch are also 
available on PyPI repository. For the stable version, you can install it as follows:  
```bash
$ pip install upbge-stubs==0.3.0.26
```
And for the latest snapshot, 
```bash
$ pip install upbge-stubs==0.3.1.*
```
You can also install the module using `Pipenv`. Note that it is required to set `allow_preleases` option 
in case you want to install a snapshot release (e.g. UPBGE 0.3.1.*).
You can use the following content as a template for your `Pipfile`:
```toml
[[source]]
name = "pypi"
url = "https://pypi.org/simple"
verify_ssl = true
[packages]
"upbge-stubs" = "==0.3.1.*"
[requires]
python_version = "3.10"
[pipenv]
allow_prereleases = true
```
You may want to use `[dev-packages]` instead of `[packages]` as it's more appropriate to do so, 
in which case you can install or update the stubs using the `-d` flag like `pipenv update -d`.  
## License ##
This project is provided under the terms of 
[GNU General Public License v3 (GPL3)](https://github.com/mysticfall/bpystubgen/blob/main/LICENSE).

%package -n python3-upbge-stubs
Summary:	API stubs for Blender and UPBGE generated with bpystubgen.
Provides:	python-upbge-stubs
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-upbge-stubs
This module provides type information for [Blender](https://www.blender.org) and 
[UPBGE](https://upbge.org)'s Python API, following the 
[PEP-561](https://www.python.org/dev/peps/pep-0561/) standard.
It was generated using [BPY Stub Generator](https://github.com/mysticfall/bpystubgen) which 
is also available on [PyPI](https://pypi.org/project/bpystubgen) as a separate module.
## Screenshots ##
Auto-completion at work in PyCharm:
![Screenshot in PyCharm](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-pycharm.png?raw=true "Screenshot in PyCharm")
Pop-up documentation support in VSCode:
![Screenshot in VSCode](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-vscode.png?raw=true "Screenshot in VSCode")
## Installation ##
There are two variants of the API stubs, one for Blender and the other for UPBGE. For Blender, 
you can install `blender-stubs` module with appropriate version qualifier as follows: 
```bash
$ pip install blender-stubs==3.1.26
```
This will install the latest module for Blender 2.93, and for now stubs are provided for Blender 
2.80 and onwards. You can also specify the next unreleased version as `3.1.*` to get the latest 
snapshot of the module:
```bash
$ pip install blender-stubs==3.2.*
```
A stub module for UPBGE 0.3, as well as pre-release versions for the master branch are also 
available on PyPI repository. For the stable version, you can install it as follows:  
```bash
$ pip install upbge-stubs==0.3.0.26
```
And for the latest snapshot, 
```bash
$ pip install upbge-stubs==0.3.1.*
```
You can also install the module using `Pipenv`. Note that it is required to set `allow_preleases` option 
in case you want to install a snapshot release (e.g. UPBGE 0.3.1.*).
You can use the following content as a template for your `Pipfile`:
```toml
[[source]]
name = "pypi"
url = "https://pypi.org/simple"
verify_ssl = true
[packages]
"upbge-stubs" = "==0.3.1.*"
[requires]
python_version = "3.10"
[pipenv]
allow_prereleases = true
```
You may want to use `[dev-packages]` instead of `[packages]` as it's more appropriate to do so, 
in which case you can install or update the stubs using the `-d` flag like `pipenv update -d`.  
## License ##
This project is provided under the terms of 
[GNU General Public License v3 (GPL3)](https://github.com/mysticfall/bpystubgen/blob/main/LICENSE).

%package help
Summary:	Development documents and examples for upbge-stubs
Provides:	python3-upbge-stubs-doc
%description help
This module provides type information for [Blender](https://www.blender.org) and 
[UPBGE](https://upbge.org)'s Python API, following the 
[PEP-561](https://www.python.org/dev/peps/pep-0561/) standard.
It was generated using [BPY Stub Generator](https://github.com/mysticfall/bpystubgen) which 
is also available on [PyPI](https://pypi.org/project/bpystubgen) as a separate module.
## Screenshots ##
Auto-completion at work in PyCharm:
![Screenshot in PyCharm](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-pycharm.png?raw=true "Screenshot in PyCharm")
Pop-up documentation support in VSCode:
![Screenshot in VSCode](https://github.com/mysticfall/bpystubgen/raw/main/images/screenshot-vscode.png?raw=true "Screenshot in VSCode")
## Installation ##
There are two variants of the API stubs, one for Blender and the other for UPBGE. For Blender, 
you can install `blender-stubs` module with appropriate version qualifier as follows: 
```bash
$ pip install blender-stubs==3.1.26
```
This will install the latest module for Blender 2.93, and for now stubs are provided for Blender 
2.80 and onwards. You can also specify the next unreleased version as `3.1.*` to get the latest 
snapshot of the module:
```bash
$ pip install blender-stubs==3.2.*
```
A stub module for UPBGE 0.3, as well as pre-release versions for the master branch are also 
available on PyPI repository. For the stable version, you can install it as follows:  
```bash
$ pip install upbge-stubs==0.3.0.26
```
And for the latest snapshot, 
```bash
$ pip install upbge-stubs==0.3.1.*
```
You can also install the module using `Pipenv`. Note that it is required to set `allow_preleases` option 
in case you want to install a snapshot release (e.g. UPBGE 0.3.1.*).
You can use the following content as a template for your `Pipfile`:
```toml
[[source]]
name = "pypi"
url = "https://pypi.org/simple"
verify_ssl = true
[packages]
"upbge-stubs" = "==0.3.1.*"
[requires]
python_version = "3.10"
[pipenv]
allow_prereleases = true
```
You may want to use `[dev-packages]` instead of `[packages]` as it's more appropriate to do so, 
in which case you can install or update the stubs using the `-d` flag like `pipenv update -d`.  
## License ##
This project is provided under the terms of 
[GNU General Public License v3 (GPL3)](https://github.com/mysticfall/bpystubgen/blob/main/LICENSE).

%prep
%autosetup -n upbge-stubs-0.3.0.27

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-upbge-stubs -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0.27-1
- Package Spec generated