%global _empty_manifest_terminate_build 0
Name: python-bipartitepandas
Version: 1.1.4
Release: 1
Summary: Python tools for bipartite labor data
License: MIT License
URL: https://github.com/tlamadon/bipartitepandas/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c6/b8/f91aabd13643f4b278a10d187733a01505e4d2a907185f165339d85d1ed7/bipartitepandas-1.1.4.tar.gz
BuildArch: noarch
Requires: python3-paramsdict
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scipy
Requires: python3-scikit-learn
Requires: python3-statsmodels
Requires: python3-igraph
Requires: python3-tqdm
%description
`BipartitePandas` is a Python package for handling bipartite labor data.
If you want to give it a try, you can start the example notebook here: |binder|. This starts a fully interactive notebook with a simple example that generates data and demonstrates some useful functions.
BipartitePandas is used in `PyTwoWay `_.
The package provides a Python interface. Installation is handled by `pip` or `Conda`. The source of the package is available on GitHub at `BipartitePandas `_. The online documentation is hosted `here `_.
%package -n python3-bipartitepandas
Summary: Python tools for bipartite labor data
Provides: python-bipartitepandas
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-bipartitepandas
`BipartitePandas` is a Python package for handling bipartite labor data.
If you want to give it a try, you can start the example notebook here: |binder|. This starts a fully interactive notebook with a simple example that generates data and demonstrates some useful functions.
BipartitePandas is used in `PyTwoWay `_.
The package provides a Python interface. Installation is handled by `pip` or `Conda`. The source of the package is available on GitHub at `BipartitePandas `_. The online documentation is hosted `here `_.
%package help
Summary: Development documents and examples for bipartitepandas
Provides: python3-bipartitepandas-doc
%description help
`BipartitePandas` is a Python package for handling bipartite labor data.
If you want to give it a try, you can start the example notebook here: |binder|. This starts a fully interactive notebook with a simple example that generates data and demonstrates some useful functions.
BipartitePandas is used in `PyTwoWay `_.
The package provides a Python interface. Installation is handled by `pip` or `Conda`. The source of the package is available on GitHub at `BipartitePandas `_. The online documentation is hosted `here `_.
%prep
%autosetup -n bipartitepandas-1.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-bipartitepandas -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.1.4-1
- Package Spec generated