%global _empty_manifest_terminate_build 0
Name: python-d8s-uuids
Version: 0.6.0
Release: 1
Summary: Democritus functions for working with uuids.
License: GNU Lesser General Public License v3
URL: https://github.com/democritus-project/d8s-uuids
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c4/da/b10b5ce30cf9da9db1bbef89f3f320a4b94ad0ca4fa8aac81cc9cc84afa4/d8s_uuids-0.6.0.tar.gz
BuildArch: noarch
Requires: python3-d8s-hypothesis
Requires: python3-hypothesis
Requires: python3-importlib-metadata
%description
# Democritus Uuids
[![PyPI](https://img.shields.io/pypi/v/d8s-uuids.svg)](https://pypi.python.org/pypi/d8s-uuids)
[![CI](https://github.com/democritus-project/d8s-uuids/workflows/CI/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![Lint](https://github.com/democritus-project/d8s-uuids/workflows/Lint/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![codecov](https://codecov.io/gh/democritus-project/d8s-uuids/branch/main/graph/badge.svg?token=V0WOIXRGMM)](https://codecov.io/gh/democritus-project/d8s-uuids)
[![The Democritus Project uses semver version 2.0.0](https://img.shields.io/badge/-semver%20v2.0.0-22bfda)](https://semver.org/spec/v2.0.0.html)
[![The Democritus Project uses black to format code](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![License: LGPL v3](https://img.shields.io/badge/License-LGPL%20v3-blue.svg)](https://choosealicense.com/licenses/lgpl-3.0/)
Democritus functions[1] for working with uuids.
[1] Democritus functions are simple, effective, modular, well-tested, and well-documented Python functions.
We use `d8s` (pronounced "dee-eights") as an abbreviation for `democritus` (you can read more about this [here](https://github.com/democritus-project/roadmap#what-is-d8s)).
## Installation
```
pip install d8s-uuids
```
## Usage
You import the library like:
```python
from d8s_uuids import *
```
Once imported, you can use any of the functions listed below.
## Functions
- ```python
def uuid4_examples(n: int = 10, *, uuids_as_strings: bool = True) -> Union[List[str], List[uuid.UUID]]:
"""Create n uuids."""
```
- ```python
def uuid4() -> str:
"""Create a random UUID."""
```
- ```python
def uuid3(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def uuid5(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def is_uuid(possible_uuid: Union[str, uuid.UUID], *, version: Optional[int] = None) -> bool:
"""Return whether or not the possible_uuid is a uuid."""
```
## Development
๐ If you want to get involved in this project, we have some short, helpful guides below:
- [contribute to this project ๐ฅ][contributing]
- [test it ๐งช][local-dev]
- [lint it ๐งน][local-dev]
- [explore it ๐ญ][local-dev]
If you have any questions or there is anything we did not cover, please raise an issue and we'll be happy to help.
## Credits
This package was created with [Cookiecutter](https://github.com/audreyr/cookiecutter) and Floyd Hightower's [Python project template](https://github.com/fhightower-templates/python-project-template).
[contributing]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#contributing-a-pr-
[local-dev]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#local-development-
%package -n python3-d8s-uuids
Summary: Democritus functions for working with uuids.
Provides: python-d8s-uuids
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-d8s-uuids
# Democritus Uuids
[![PyPI](https://img.shields.io/pypi/v/d8s-uuids.svg)](https://pypi.python.org/pypi/d8s-uuids)
[![CI](https://github.com/democritus-project/d8s-uuids/workflows/CI/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![Lint](https://github.com/democritus-project/d8s-uuids/workflows/Lint/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![codecov](https://codecov.io/gh/democritus-project/d8s-uuids/branch/main/graph/badge.svg?token=V0WOIXRGMM)](https://codecov.io/gh/democritus-project/d8s-uuids)
[![The Democritus Project uses semver version 2.0.0](https://img.shields.io/badge/-semver%20v2.0.0-22bfda)](https://semver.org/spec/v2.0.0.html)
[![The Democritus Project uses black to format code](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![License: LGPL v3](https://img.shields.io/badge/License-LGPL%20v3-blue.svg)](https://choosealicense.com/licenses/lgpl-3.0/)
Democritus functions[1] for working with uuids.
[1] Democritus functions are simple, effective, modular, well-tested, and well-documented Python functions.
We use `d8s` (pronounced "dee-eights") as an abbreviation for `democritus` (you can read more about this [here](https://github.com/democritus-project/roadmap#what-is-d8s)).
## Installation
```
pip install d8s-uuids
```
## Usage
You import the library like:
```python
from d8s_uuids import *
```
Once imported, you can use any of the functions listed below.
## Functions
- ```python
def uuid4_examples(n: int = 10, *, uuids_as_strings: bool = True) -> Union[List[str], List[uuid.UUID]]:
"""Create n uuids."""
```
- ```python
def uuid4() -> str:
"""Create a random UUID."""
```
- ```python
def uuid3(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def uuid5(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def is_uuid(possible_uuid: Union[str, uuid.UUID], *, version: Optional[int] = None) -> bool:
"""Return whether or not the possible_uuid is a uuid."""
```
## Development
๐ If you want to get involved in this project, we have some short, helpful guides below:
- [contribute to this project ๐ฅ][contributing]
- [test it ๐งช][local-dev]
- [lint it ๐งน][local-dev]
- [explore it ๐ญ][local-dev]
If you have any questions or there is anything we did not cover, please raise an issue and we'll be happy to help.
## Credits
This package was created with [Cookiecutter](https://github.com/audreyr/cookiecutter) and Floyd Hightower's [Python project template](https://github.com/fhightower-templates/python-project-template).
[contributing]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#contributing-a-pr-
[local-dev]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#local-development-
%package help
Summary: Development documents and examples for d8s-uuids
Provides: python3-d8s-uuids-doc
%description help
# Democritus Uuids
[![PyPI](https://img.shields.io/pypi/v/d8s-uuids.svg)](https://pypi.python.org/pypi/d8s-uuids)
[![CI](https://github.com/democritus-project/d8s-uuids/workflows/CI/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![Lint](https://github.com/democritus-project/d8s-uuids/workflows/Lint/badge.svg)](https://github.com/democritus-project/d8s-uuids/actions)
[![codecov](https://codecov.io/gh/democritus-project/d8s-uuids/branch/main/graph/badge.svg?token=V0WOIXRGMM)](https://codecov.io/gh/democritus-project/d8s-uuids)
[![The Democritus Project uses semver version 2.0.0](https://img.shields.io/badge/-semver%20v2.0.0-22bfda)](https://semver.org/spec/v2.0.0.html)
[![The Democritus Project uses black to format code](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
[![License: LGPL v3](https://img.shields.io/badge/License-LGPL%20v3-blue.svg)](https://choosealicense.com/licenses/lgpl-3.0/)
Democritus functions[1] for working with uuids.
[1] Democritus functions are simple, effective, modular, well-tested, and well-documented Python functions.
We use `d8s` (pronounced "dee-eights") as an abbreviation for `democritus` (you can read more about this [here](https://github.com/democritus-project/roadmap#what-is-d8s)).
## Installation
```
pip install d8s-uuids
```
## Usage
You import the library like:
```python
from d8s_uuids import *
```
Once imported, you can use any of the functions listed below.
## Functions
- ```python
def uuid4_examples(n: int = 10, *, uuids_as_strings: bool = True) -> Union[List[str], List[uuid.UUID]]:
"""Create n uuids."""
```
- ```python
def uuid4() -> str:
"""Create a random UUID."""
```
- ```python
def uuid3(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def uuid5(name: str, *, namespace: Optional[uuid.UUID] = None) -> str:
"""Create a random uuid based on the given name."""
```
- ```python
def is_uuid(possible_uuid: Union[str, uuid.UUID], *, version: Optional[int] = None) -> bool:
"""Return whether or not the possible_uuid is a uuid."""
```
## Development
๐ If you want to get involved in this project, we have some short, helpful guides below:
- [contribute to this project ๐ฅ][contributing]
- [test it ๐งช][local-dev]
- [lint it ๐งน][local-dev]
- [explore it ๐ญ][local-dev]
If you have any questions or there is anything we did not cover, please raise an issue and we'll be happy to help.
## Credits
This package was created with [Cookiecutter](https://github.com/audreyr/cookiecutter) and Floyd Hightower's [Python project template](https://github.com/fhightower-templates/python-project-template).
[contributing]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#contributing-a-pr-
[local-dev]: https://github.com/democritus-project/.github/blob/main/CONTRIBUTING.md#local-development-
%prep
%autosetup -n d8s-uuids-0.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-d8s-uuids -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.6.0-1
- Package Spec generated