%global _empty_manifest_terminate_build 0
Name:		python-invocations
Version:	3.1.0
Release:	1
Summary:	Common/best-practice Invoke tasks and collections
License:	BSD
URL:		https://invocations.readthedocs.io
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f4/0f/59b68596eac7d1a28c730fdf0a7b7b5dc05a4d7e7718b00bebb1d827ba15/invocations-3.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-invoke
Requires:	python3-blessings
Requires:	python3-releases
Requires:	python3-semantic-version
Requires:	python3-tabulate
Requires:	python3-tqdm
Requires:	python3-twine
Requires:	python3-wheel

%description
Invocations is a collection of reusable `Invoke <http://pyinvoke.org>`_ tasks,
task collections and helper functions. Originally sourced from the Invoke
project's own project-management tasks file, they are now highly configurable
and used across a number of projects, with the intent to become a clearinghouse
for implementing common best practices.
Currently implemented topics include (but are not limited to):
- management of Sphinx documentation trees
- Python project release lifecycles
- dependency vendoring
- running test suites (unit, integration, coverage-oriented, etc)
- console utilities such as confirmation prompts
and more.

%package -n python3-invocations
Summary:	Common/best-practice Invoke tasks and collections
Provides:	python-invocations
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-invocations
Invocations is a collection of reusable `Invoke <http://pyinvoke.org>`_ tasks,
task collections and helper functions. Originally sourced from the Invoke
project's own project-management tasks file, they are now highly configurable
and used across a number of projects, with the intent to become a clearinghouse
for implementing common best practices.
Currently implemented topics include (but are not limited to):
- management of Sphinx documentation trees
- Python project release lifecycles
- dependency vendoring
- running test suites (unit, integration, coverage-oriented, etc)
- console utilities such as confirmation prompts
and more.

%package help
Summary:	Development documents and examples for invocations
Provides:	python3-invocations-doc
%description help
Invocations is a collection of reusable `Invoke <http://pyinvoke.org>`_ tasks,
task collections and helper functions. Originally sourced from the Invoke
project's own project-management tasks file, they are now highly configurable
and used across a number of projects, with the intent to become a clearinghouse
for implementing common best practices.
Currently implemented topics include (but are not limited to):
- management of Sphinx documentation trees
- Python project release lifecycles
- dependency vendoring
- running test suites (unit, integration, coverage-oriented, etc)
- console utilities such as confirmation prompts
and more.

%prep
%autosetup -n invocations-3.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-invocations -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
- Package Spec generated