%global _empty_manifest_terminate_build 0
Name: python-porder
Version: 0.8.7
Release: 1
Summary: Simple CLI for Planet Orders v2
License: Apache 2.0
URL: https://github.com/samapriya/porder
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/fa/6cae92c54ab18edb6d8b898c766b5481dd20c70e8cfe229326e59e2dd6ef/porder-0.8.7.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-planet
Requires: python3-retrying
Requires: python3-progressbar2
Requires: python3-visvalingamwyatt
Requires: python3-DateTimeRange
Requires: python3-beautifulsoup4
Requires: python3-logzero
Requires: python3-PyJWT
Requires: python3-clipboard
Requires: python3-pyyaml
Requires: python3-prettytable
Requires: python3-pyproj
Requires: python3-shapely
Requires: python3-fiona
Requires: python3-geopandas
Requires: python3-pySmartDL
Requires: python3-pySmartDL
%description
clip | Clip imagery can handle single and multi polygon verify or create geojson.io
toar | Top of Atmosphere Reflectance imagery generated for imagery
harmonize| Harmonize Dove R (instrument type PS2.SD) data to classic dove (instrument type PS)
composite | Composite number of images in a given order
zip | Zip bundles together and creates downloads (each asset has a single bundle so multiple zip files)
zipall | Create a single zip file containing all assets
compression | Use image compression
projection | Reproject before downloading image
aws | Option called to specify delivery to AWS
azure | Option called to specify delivery to AZURE
gcs | Option called to specify delivery to GCS
email | Email notification to your planet registered email
anchor | Anchor image id for coregistration
format | Delivery format choose from COG/PL_NITF to use for the format tool
gee | provide gee-project,gee-collection
You can now add some predefined indices for PlanetScope 4 band items with a maximum of 5 indices for a single setup . This is experimental. The list of indices include
%package -n python3-porder
Summary: Simple CLI for Planet Orders v2
Provides: python-porder
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-porder
clip | Clip imagery can handle single and multi polygon verify or create geojson.io
toar | Top of Atmosphere Reflectance imagery generated for imagery
harmonize| Harmonize Dove R (instrument type PS2.SD) data to classic dove (instrument type PS)
composite | Composite number of images in a given order
zip | Zip bundles together and creates downloads (each asset has a single bundle so multiple zip files)
zipall | Create a single zip file containing all assets
compression | Use image compression
projection | Reproject before downloading image
aws | Option called to specify delivery to AWS
azure | Option called to specify delivery to AZURE
gcs | Option called to specify delivery to GCS
email | Email notification to your planet registered email
anchor | Anchor image id for coregistration
format | Delivery format choose from COG/PL_NITF to use for the format tool
gee | provide gee-project,gee-collection
You can now add some predefined indices for PlanetScope 4 band items with a maximum of 5 indices for a single setup . This is experimental. The list of indices include
%package help
Summary: Development documents and examples for porder
Provides: python3-porder-doc
%description help
clip | Clip imagery can handle single and multi polygon verify or create geojson.io
toar | Top of Atmosphere Reflectance imagery generated for imagery
harmonize| Harmonize Dove R (instrument type PS2.SD) data to classic dove (instrument type PS)
composite | Composite number of images in a given order
zip | Zip bundles together and creates downloads (each asset has a single bundle so multiple zip files)
zipall | Create a single zip file containing all assets
compression | Use image compression
projection | Reproject before downloading image
aws | Option called to specify delivery to AWS
azure | Option called to specify delivery to AZURE
gcs | Option called to specify delivery to GCS
email | Email notification to your planet registered email
anchor | Anchor image id for coregistration
format | Delivery format choose from COG/PL_NITF to use for the format tool
gee | provide gee-project,gee-collection
You can now add some predefined indices for PlanetScope 4 band items with a maximum of 5 indices for a single setup . This is experimental. The list of indices include
%prep
%autosetup -n porder-0.8.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-porder -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.8.7-1
- Package Spec generated