%global _empty_manifest_terminate_build 0
Name:		python-Diofant
Version:	0.14.0
Release:	1
Summary:	Computer algebra system (CAS) in Python
License:	BSD
URL:		https://diofant.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5e/b0/11628bf2b5a405336516f70649b3eb34fde08b83053ea6faae6d2a788ba4/Diofant-0.14.0.tar.gz
BuildArch:	noarch

Requires:	python3-mpmath
Requires:	python3-diofant[tests]
Requires:	python3-flake518
Requires:	python3-flake8-docstrings
Requires:	python3-pep8-naming
Requires:	python3-flake8-comprehensions
Requires:	python3-flake8-isort
Requires:	python3-flake8-quotes
Requires:	python3-flake8-sfs
Requires:	python3-pytest-xdist
Requires:	python3-pytest-cov
Requires:	python3-pylint
Requires:	python3-coverage[toml]
Requires:	python3-coverage-enable-subprocess
Requires:	python3-mypy
Requires:	python3-build
Requires:	python3-flake8-pytest-style
Requires:	python3-sphinx
Requires:	python3-sphinxcontrib-bibtex
Requires:	python3-sphinxcontrib-autoprogram
Requires:	python3-sphinx-rtd-theme
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-cython
Requires:	python3-gmpy2
Requires:	python3-ipykernel
Requires:	python3-diofant[develop]
Requires:	python3-pytest
Requires:	python3-hypothesis
Requires:	python3-pytest-timeout
Requires:	python3-pexpect

%description
A `Python`_ library for symbolic mathematics.
For `installation instructions`_ and usage information,
see the `online documentation`_.
`New BSD License`_ covers all files in `this repository`_
unless stated otherwise.

%package -n python3-Diofant
Summary:	Computer algebra system (CAS) in Python
Provides:	python-Diofant
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Diofant
A `Python`_ library for symbolic mathematics.
For `installation instructions`_ and usage information,
see the `online documentation`_.
`New BSD License`_ covers all files in `this repository`_
unless stated otherwise.

%package help
Summary:	Development documents and examples for Diofant
Provides:	python3-Diofant-doc
%description help
A `Python`_ library for symbolic mathematics.
For `installation instructions`_ and usage information,
see the `online documentation`_.
`New BSD License`_ covers all files in `this repository`_
unless stated otherwise.

%prep
%autosetup -n Diofant-0.14.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Diofant -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.0-1
- Package Spec generated