%global _empty_manifest_terminate_build 0
Name: python-andes
Version: 1.8.8
Release: 1
Summary: Python software for symbolic power system modeling and numerical analysis.
License: GNU Public License v3
URL: https://github.com/cuihantao/andes
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/78/8a/283fb08aaf0a400a80151ee2944a7190b087482cf88273695cf181aefbcb/andes-1.8.8.tar.gz
BuildArch: noarch
%description
# LTB ANDES
Python software for symbolic power system modeling and numerical analysis, serving as the core simulation engine for the [CURENT Largescale Testbed][LTB Repository].
| | Latest | Stable |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------------------------------|
| Documentation | [](https://andes.readthedocs.io/en/latest/?badge=latest) | [](https://andes.readthedocs.io/en/stable/?badge=stable) |
| Badges | | |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Downloads | [](https://pypi.python.org/pypi/andes) | [](https://anaconda.org/conda-forge/andes) |
| Try on Binder | [](https://mybinder.org/v2/gh/cuihantao/andes/master) | |
| Code Quality | [](https://app.codacy.com/app/cuihantao/andes?utm_source=github.com&utm_medium=referral&utm_content=cuihantao/andes&utm_campaign=Badge_Grade_Dashboard) | [](https://codecov.io/gh/cuihantao/andes) |
| Build Status | [](https://github.com/cuihantao/andes/actions) | [](https://dev.azure.com/hcui7/hcui7/_build/latest?definitionId=1&branchName=master) |
# Why ANDES
This software could be of interest to you if you are working on
DAE modeling, simulation, and control for power systems.
It has features that may be useful if you are applying
deep (reinforcement) learning to such systems.
ANDES is by far easier to use for developing differential-algebraic
equation (DAE) based models for power system dynamic simulation
than other tools such as
[PSAT](http://faraday1.ucd.ie/psat.html),
[Dome](http://faraday1.ucd.ie/dome.html) and
[PST](https://www.ecse.rpi.edu/~chowj/),
while maintaining high numerical efficiency.
ANDES comes with a rich set of commercial-grade dynamic models
with all details implemented, including limiters, saturation,
and zeroing out time constants.
ANDES produces credible simulation results. The following table
shows that
1. For the Northeast Power Coordinating Council (NPCC) 140-bus system
(with GENROU, GENCLS, TGOV1 and IEEEX1),
ANDES results match perfectly with that from TSAT.
2. For the Western Electricity Coordinating Council (WECC) 179-bus
system (with GENROU, IEEEG1, EXST1, ESST3A, ESDC2A, IEEEST and
ST2CUT), ANDES results match closely with those from TSAT and PSS/E.
Note that TSAT and PSS/E results are not identical, either.
| NPCC Case Study | WECC Case Study |
| --------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------- |
|  |  |
ANDES provides a descriptive modeling framework in a scripting environment.
Modeling DAE-based devices is as simple as describing the mathematical equations.
Numerical code will be automatically generated for fast simulation.
| Controller Model and Equation | ANDES Code |
| ----------------------------- | ---------- |
| Diagram:

Write into DAEs:
 |  |
In ANDES, what you simulate is what you document.
ANDES automatically generates model documentation, and the docs always stay up to date.
The screenshot below is the generated documentation for the implemented IEEEG1 model.

In addition, ANDES features
* a rich library of transfer functions and discontinuous components (including limiters, deadbands, and
saturation functions) available for model prototyping and system analysis.
* industry-grade second-generation renewable models (solar PV, type 3 and type 4 wind),
distributed PV and energy storage model.
* routines including Newton method for power flow calculation, implicit trapezoidal method for time-domain
simulation, and full eigenvalue analysis.
* developed with performance in mind. While written in Python, ANDES can
finish a 20-second transient simulation of a 2000-bus system in a few seconds on a typical desktop computer.
* out-of-the-box PSS/E raw and dyr data support for available models. Once a model is developed, inputs from a
dyr file can be immediately supported.
ANDES is currently under active development.
Use the following resources to get involved.
+ Start from the [documentation][readthedocs] for installation and tutorial.
+ Check out examples in the [examples folder][examples]
+ Read the model verification results in the [examples/verification folder][verification]
+ Try in Jupyter Notebook on [Binder][Binder]
+ Ask a question in the [GitHub Discussions][Github Discussions]
+ Report bugs or issues by submitting a [GitHub issue][GitHub issues]
+ Submit contributions using [pull requests][GitHub pull requests]
+ Read release notes highlighted [here][release notes]
+ Check out and and cite our [paper][arxiv paper]
# Citing ANDES
If you use ANDES for research or consulting, please cite the following paper in your publication that uses
ANDES
```
H. Cui, F. Li and K. Tomsovic, "Hybrid Symbolic-Numeric Framework for Power System Modeling and Analysis," in IEEE Transactions on Power Systems, vol. 36, no. 2, pp. 1373-1384, March 2021, doi: 10.1109/TPWRS.2020.3017019.
```
# Who is Using ANDES?
Please let us know if you are using ANDES for research or projects.
We kindly request you to cite our [paper][arxiv paper] if you find ANDES useful.





# Sponsors and Contributors
This work was supported in part by the Engineering Research Center
Program of the National Science Foundation and the Department of Energy
under NSF Award Number EEC-1041877 and the CURENT Industry Partnership
Program.
This work was supported in part by the Advanced Grid Research and Development Program
in the Office of Electricity at the U.S. Department of Energy.
See [GitHub contributors][GitHub contributors] for the contributor list.
# License
ANDES is licensed under the [GPL v3 License](./LICENSE).
* * *
[GitHub releases]: https://github.com/CURENT/andes/releases
[GitHub issues]: https://github.com/CURENT/andes/issues
[Github Discussions]: https://github.com/CURENT/andes/discussions
[GitHub insights]: https://github.com/CURENT/andes/pulse
[GitHub pull requests]: https://github.com/CURENT/andes/pulls
[GitHub contributors]: https://github.com/CURENT/andes/graphs/contributors
[readthedocs]: https://andes.readthedocs.io
[release notes]: https://andes.readthedocs.io/en/latest/release-notes.html
[arxiv paper]: https://arxiv.org/abs/2002.09455
[tutorial]: https://andes.readthedocs.io/en/latest/tutorial.html#interactive-usage
[examples]: https://github.com/CURENT/andes/tree/master/examples
[verification]: https://github.com/CURENT/andes/tree/master/examples/verification
[Binder]: https://mybinder.org/v2/gh/cuihantao/andes/master
[LTB Repository]: https://github.com/CURENT
%package -n python3-andes
Summary: Python software for symbolic power system modeling and numerical analysis.
Provides: python-andes
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-andes
# LTB ANDES
Python software for symbolic power system modeling and numerical analysis, serving as the core simulation engine for the [CURENT Largescale Testbed][LTB Repository].
| | Latest | Stable |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------------------------------|
| Documentation | [](https://andes.readthedocs.io/en/latest/?badge=latest) | [](https://andes.readthedocs.io/en/stable/?badge=stable) |
| Badges | | |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Downloads | [](https://pypi.python.org/pypi/andes) | [](https://anaconda.org/conda-forge/andes) |
| Try on Binder | [](https://mybinder.org/v2/gh/cuihantao/andes/master) | |
| Code Quality | [](https://app.codacy.com/app/cuihantao/andes?utm_source=github.com&utm_medium=referral&utm_content=cuihantao/andes&utm_campaign=Badge_Grade_Dashboard) | [](https://codecov.io/gh/cuihantao/andes) |
| Build Status | [](https://github.com/cuihantao/andes/actions) | [](https://dev.azure.com/hcui7/hcui7/_build/latest?definitionId=1&branchName=master) |
# Why ANDES
This software could be of interest to you if you are working on
DAE modeling, simulation, and control for power systems.
It has features that may be useful if you are applying
deep (reinforcement) learning to such systems.
ANDES is by far easier to use for developing differential-algebraic
equation (DAE) based models for power system dynamic simulation
than other tools such as
[PSAT](http://faraday1.ucd.ie/psat.html),
[Dome](http://faraday1.ucd.ie/dome.html) and
[PST](https://www.ecse.rpi.edu/~chowj/),
while maintaining high numerical efficiency.
ANDES comes with a rich set of commercial-grade dynamic models
with all details implemented, including limiters, saturation,
and zeroing out time constants.
ANDES produces credible simulation results. The following table
shows that
1. For the Northeast Power Coordinating Council (NPCC) 140-bus system
(with GENROU, GENCLS, TGOV1 and IEEEX1),
ANDES results match perfectly with that from TSAT.
2. For the Western Electricity Coordinating Council (WECC) 179-bus
system (with GENROU, IEEEG1, EXST1, ESST3A, ESDC2A, IEEEST and
ST2CUT), ANDES results match closely with those from TSAT and PSS/E.
Note that TSAT and PSS/E results are not identical, either.
| NPCC Case Study | WECC Case Study |
| --------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------- |
|  |  |
ANDES provides a descriptive modeling framework in a scripting environment.
Modeling DAE-based devices is as simple as describing the mathematical equations.
Numerical code will be automatically generated for fast simulation.
| Controller Model and Equation | ANDES Code |
| ----------------------------- | ---------- |
| Diagram:

Write into DAEs:
 |  |
In ANDES, what you simulate is what you document.
ANDES automatically generates model documentation, and the docs always stay up to date.
The screenshot below is the generated documentation for the implemented IEEEG1 model.

In addition, ANDES features
* a rich library of transfer functions and discontinuous components (including limiters, deadbands, and
saturation functions) available for model prototyping and system analysis.
* industry-grade second-generation renewable models (solar PV, type 3 and type 4 wind),
distributed PV and energy storage model.
* routines including Newton method for power flow calculation, implicit trapezoidal method for time-domain
simulation, and full eigenvalue analysis.
* developed with performance in mind. While written in Python, ANDES can
finish a 20-second transient simulation of a 2000-bus system in a few seconds on a typical desktop computer.
* out-of-the-box PSS/E raw and dyr data support for available models. Once a model is developed, inputs from a
dyr file can be immediately supported.
ANDES is currently under active development.
Use the following resources to get involved.
+ Start from the [documentation][readthedocs] for installation and tutorial.
+ Check out examples in the [examples folder][examples]
+ Read the model verification results in the [examples/verification folder][verification]
+ Try in Jupyter Notebook on [Binder][Binder]
+ Ask a question in the [GitHub Discussions][Github Discussions]
+ Report bugs or issues by submitting a [GitHub issue][GitHub issues]
+ Submit contributions using [pull requests][GitHub pull requests]
+ Read release notes highlighted [here][release notes]
+ Check out and and cite our [paper][arxiv paper]
# Citing ANDES
If you use ANDES for research or consulting, please cite the following paper in your publication that uses
ANDES
```
H. Cui, F. Li and K. Tomsovic, "Hybrid Symbolic-Numeric Framework for Power System Modeling and Analysis," in IEEE Transactions on Power Systems, vol. 36, no. 2, pp. 1373-1384, March 2021, doi: 10.1109/TPWRS.2020.3017019.
```
# Who is Using ANDES?
Please let us know if you are using ANDES for research or projects.
We kindly request you to cite our [paper][arxiv paper] if you find ANDES useful.





# Sponsors and Contributors
This work was supported in part by the Engineering Research Center
Program of the National Science Foundation and the Department of Energy
under NSF Award Number EEC-1041877 and the CURENT Industry Partnership
Program.
This work was supported in part by the Advanced Grid Research and Development Program
in the Office of Electricity at the U.S. Department of Energy.
See [GitHub contributors][GitHub contributors] for the contributor list.
# License
ANDES is licensed under the [GPL v3 License](./LICENSE).
* * *
[GitHub releases]: https://github.com/CURENT/andes/releases
[GitHub issues]: https://github.com/CURENT/andes/issues
[Github Discussions]: https://github.com/CURENT/andes/discussions
[GitHub insights]: https://github.com/CURENT/andes/pulse
[GitHub pull requests]: https://github.com/CURENT/andes/pulls
[GitHub contributors]: https://github.com/CURENT/andes/graphs/contributors
[readthedocs]: https://andes.readthedocs.io
[release notes]: https://andes.readthedocs.io/en/latest/release-notes.html
[arxiv paper]: https://arxiv.org/abs/2002.09455
[tutorial]: https://andes.readthedocs.io/en/latest/tutorial.html#interactive-usage
[examples]: https://github.com/CURENT/andes/tree/master/examples
[verification]: https://github.com/CURENT/andes/tree/master/examples/verification
[Binder]: https://mybinder.org/v2/gh/cuihantao/andes/master
[LTB Repository]: https://github.com/CURENT
%package help
Summary: Development documents and examples for andes
Provides: python3-andes-doc
%description help
# LTB ANDES
Python software for symbolic power system modeling and numerical analysis, serving as the core simulation engine for the [CURENT Largescale Testbed][LTB Repository].
| | Latest | Stable |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------|-----------------------------------------------------------------------------------------------------------------------------------------------|
| Documentation | [](https://andes.readthedocs.io/en/latest/?badge=latest) | [](https://andes.readthedocs.io/en/stable/?badge=stable) |
| Badges | | |
|---------------|-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| Downloads | [](https://pypi.python.org/pypi/andes) | [](https://anaconda.org/conda-forge/andes) |
| Try on Binder | [](https://mybinder.org/v2/gh/cuihantao/andes/master) | |
| Code Quality | [](https://app.codacy.com/app/cuihantao/andes?utm_source=github.com&utm_medium=referral&utm_content=cuihantao/andes&utm_campaign=Badge_Grade_Dashboard) | [](https://codecov.io/gh/cuihantao/andes) |
| Build Status | [](https://github.com/cuihantao/andes/actions) | [](https://dev.azure.com/hcui7/hcui7/_build/latest?definitionId=1&branchName=master) |
# Why ANDES
This software could be of interest to you if you are working on
DAE modeling, simulation, and control for power systems.
It has features that may be useful if you are applying
deep (reinforcement) learning to such systems.
ANDES is by far easier to use for developing differential-algebraic
equation (DAE) based models for power system dynamic simulation
than other tools such as
[PSAT](http://faraday1.ucd.ie/psat.html),
[Dome](http://faraday1.ucd.ie/dome.html) and
[PST](https://www.ecse.rpi.edu/~chowj/),
while maintaining high numerical efficiency.
ANDES comes with a rich set of commercial-grade dynamic models
with all details implemented, including limiters, saturation,
and zeroing out time constants.
ANDES produces credible simulation results. The following table
shows that
1. For the Northeast Power Coordinating Council (NPCC) 140-bus system
(with GENROU, GENCLS, TGOV1 and IEEEX1),
ANDES results match perfectly with that from TSAT.
2. For the Western Electricity Coordinating Council (WECC) 179-bus
system (with GENROU, IEEEG1, EXST1, ESST3A, ESDC2A, IEEEST and
ST2CUT), ANDES results match closely with those from TSAT and PSS/E.
Note that TSAT and PSS/E results are not identical, either.
| NPCC Case Study | WECC Case Study |
| --------------------------------------------------------------------------------------------------------- | ------------------------------------------------------------------------------------------------------- |
|  |  |
ANDES provides a descriptive modeling framework in a scripting environment.
Modeling DAE-based devices is as simple as describing the mathematical equations.
Numerical code will be automatically generated for fast simulation.
| Controller Model and Equation | ANDES Code |
| ----------------------------- | ---------- |
| Diagram:

Write into DAEs:
 |  |
In ANDES, what you simulate is what you document.
ANDES automatically generates model documentation, and the docs always stay up to date.
The screenshot below is the generated documentation for the implemented IEEEG1 model.

In addition, ANDES features
* a rich library of transfer functions and discontinuous components (including limiters, deadbands, and
saturation functions) available for model prototyping and system analysis.
* industry-grade second-generation renewable models (solar PV, type 3 and type 4 wind),
distributed PV and energy storage model.
* routines including Newton method for power flow calculation, implicit trapezoidal method for time-domain
simulation, and full eigenvalue analysis.
* developed with performance in mind. While written in Python, ANDES can
finish a 20-second transient simulation of a 2000-bus system in a few seconds on a typical desktop computer.
* out-of-the-box PSS/E raw and dyr data support for available models. Once a model is developed, inputs from a
dyr file can be immediately supported.
ANDES is currently under active development.
Use the following resources to get involved.
+ Start from the [documentation][readthedocs] for installation and tutorial.
+ Check out examples in the [examples folder][examples]
+ Read the model verification results in the [examples/verification folder][verification]
+ Try in Jupyter Notebook on [Binder][Binder]
+ Ask a question in the [GitHub Discussions][Github Discussions]
+ Report bugs or issues by submitting a [GitHub issue][GitHub issues]
+ Submit contributions using [pull requests][GitHub pull requests]
+ Read release notes highlighted [here][release notes]
+ Check out and and cite our [paper][arxiv paper]
# Citing ANDES
If you use ANDES for research or consulting, please cite the following paper in your publication that uses
ANDES
```
H. Cui, F. Li and K. Tomsovic, "Hybrid Symbolic-Numeric Framework for Power System Modeling and Analysis," in IEEE Transactions on Power Systems, vol. 36, no. 2, pp. 1373-1384, March 2021, doi: 10.1109/TPWRS.2020.3017019.
```
# Who is Using ANDES?
Please let us know if you are using ANDES for research or projects.
We kindly request you to cite our [paper][arxiv paper] if you find ANDES useful.





# Sponsors and Contributors
This work was supported in part by the Engineering Research Center
Program of the National Science Foundation and the Department of Energy
under NSF Award Number EEC-1041877 and the CURENT Industry Partnership
Program.
This work was supported in part by the Advanced Grid Research and Development Program
in the Office of Electricity at the U.S. Department of Energy.
See [GitHub contributors][GitHub contributors] for the contributor list.
# License
ANDES is licensed under the [GPL v3 License](./LICENSE).
* * *
[GitHub releases]: https://github.com/CURENT/andes/releases
[GitHub issues]: https://github.com/CURENT/andes/issues
[Github Discussions]: https://github.com/CURENT/andes/discussions
[GitHub insights]: https://github.com/CURENT/andes/pulse
[GitHub pull requests]: https://github.com/CURENT/andes/pulls
[GitHub contributors]: https://github.com/CURENT/andes/graphs/contributors
[readthedocs]: https://andes.readthedocs.io
[release notes]: https://andes.readthedocs.io/en/latest/release-notes.html
[arxiv paper]: https://arxiv.org/abs/2002.09455
[tutorial]: https://andes.readthedocs.io/en/latest/tutorial.html#interactive-usage
[examples]: https://github.com/CURENT/andes/tree/master/examples
[verification]: https://github.com/CURENT/andes/tree/master/examples/verification
[Binder]: https://mybinder.org/v2/gh/cuihantao/andes/master
[LTB Repository]: https://github.com/CURENT
%prep
%autosetup -n andes-1.8.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-andes -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.8.8-1
- Package Spec generated