%global _empty_manifest_terminate_build 0
Name: python-belvo-python
Version: 0.37.0
Release: 1
Summary: Belvo Python SDK
License: Apache Software License
URL: https://github.com/belvo-finance/belvo-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/fd/cb4d6c1b3126cfbef05d1c645912ab8e99324f96e637a338e5b5f61b513f/belvo-python-0.37.0.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
Belvo Python SDK
## 📕 Documentation
How to use `belvo-python`: https://belvo-finance.github.io/belvo-python/
If you want to check the full documentation about Belvo API: https://docs.belvo.com
Or if you want to more information about:
* [Getting Belvo API keys](https://developers.belvo.com/docs/get-your-belvo-api-keys)
* [Using Connect Widget](https://developers.belvo.com/docs/connect-widget)
* [Testing in sandbox](https://developers.belvo.com/docs/test-in-sandbox)
* [Using webhooks and recurrent links](https://developers.belvo.com/docs/webhooks)
## 📋 Requirements
* Python 3.6+
## 🚀 Getting started
Install using `pip`:
```
$ pip install belvo-python
```
## Usage (create link via widget)
When your user successfully links their account using the [Connect Widget](https://developers.belvo.com/docs/connect-widget), your implemented callback funciton will return the `link_id` required to make further API to retrieve information.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Get the link_id from the result of your widget callback function
link_id = result_from_callback_function.id
# Get all accounts
client.Accounts.create(link=link_id)
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Usage (create link via SDK)
You can also manually create the link using the SDK. However, for security purposes, we highly recommend, that you use the [Connect Widget](https://developers.belvo.com/docs/connect-widget) to create the link and follow the **Usage (create link via widget)** example.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Register a link
link = client.Links.create(
institution="erebor_mx_retail",
username="johndoe",
password="supersecret",
access_mode=AccessMode.SINGLE
)
# Get all accounts
client.Accounts.create(link=link["id"])
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Errors and exceptions
By default, when you use our SDK, we automatically return the [error](https://developers.belvo.com/docs/integration-overview#error-handling). However, if you prefer to receive the exception, you need to set the `raise_exception` optional parameter to `True`.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
from belvo.exceptions import RequestError
# Login to Belvo API
client = Client("my-secret-key-id", "my-secret-key", "sandbox")
try:
# Register a link
link = client.Links.create(
access_mode=AccessMode.SINGLE,
institution="erebor_mx_retail",
username="",
password="",
raise_exception=True, # Set this optional paramter
)
except RequestError as e:
# do something with the error
pprint(e)
else:
# do something with the link
pprint(link)
```
## 🐍 Development
To release a new version of the SDK to PyPI:
- Create a new branch from master.
- Use `make new-version major|minor|patch` to bump a new version.
- Create a new pull request for the new version.
- Once the new version is merged in `master`, create a `tag` matching the new version.
## 👥 Contributing
**Anyone** can do something to make `belvo-python` better, so contributors are always welcome!
If you wish to submit a pull request, please be sure check the items on this list:
- [ ] Tests related to the changed code were executed
- [ ] The source code has been coded following the OWASP security best practices (https://owasp.org/www-pdf-archive/OWASP_SCP_Quick_Reference_Guide_v2.pdf).
- [ ] Commit message properly labeled
- [ ] There is a ticket associated to each PR.
For more details about contributing to this project, please take a look to our [guidelines](CONTRIBUTING.md).
%package -n python3-belvo-python
Summary: Belvo Python SDK
Provides: python-belvo-python
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-belvo-python
Belvo Python SDK
## 📕 Documentation
How to use `belvo-python`: https://belvo-finance.github.io/belvo-python/
If you want to check the full documentation about Belvo API: https://docs.belvo.com
Or if you want to more information about:
* [Getting Belvo API keys](https://developers.belvo.com/docs/get-your-belvo-api-keys)
* [Using Connect Widget](https://developers.belvo.com/docs/connect-widget)
* [Testing in sandbox](https://developers.belvo.com/docs/test-in-sandbox)
* [Using webhooks and recurrent links](https://developers.belvo.com/docs/webhooks)
## 📋 Requirements
* Python 3.6+
## 🚀 Getting started
Install using `pip`:
```
$ pip install belvo-python
```
## Usage (create link via widget)
When your user successfully links their account using the [Connect Widget](https://developers.belvo.com/docs/connect-widget), your implemented callback funciton will return the `link_id` required to make further API to retrieve information.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Get the link_id from the result of your widget callback function
link_id = result_from_callback_function.id
# Get all accounts
client.Accounts.create(link=link_id)
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Usage (create link via SDK)
You can also manually create the link using the SDK. However, for security purposes, we highly recommend, that you use the [Connect Widget](https://developers.belvo.com/docs/connect-widget) to create the link and follow the **Usage (create link via widget)** example.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Register a link
link = client.Links.create(
institution="erebor_mx_retail",
username="johndoe",
password="supersecret",
access_mode=AccessMode.SINGLE
)
# Get all accounts
client.Accounts.create(link=link["id"])
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Errors and exceptions
By default, when you use our SDK, we automatically return the [error](https://developers.belvo.com/docs/integration-overview#error-handling). However, if you prefer to receive the exception, you need to set the `raise_exception` optional parameter to `True`.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
from belvo.exceptions import RequestError
# Login to Belvo API
client = Client("my-secret-key-id", "my-secret-key", "sandbox")
try:
# Register a link
link = client.Links.create(
access_mode=AccessMode.SINGLE,
institution="erebor_mx_retail",
username="",
password="",
raise_exception=True, # Set this optional paramter
)
except RequestError as e:
# do something with the error
pprint(e)
else:
# do something with the link
pprint(link)
```
## 🐍 Development
To release a new version of the SDK to PyPI:
- Create a new branch from master.
- Use `make new-version major|minor|patch` to bump a new version.
- Create a new pull request for the new version.
- Once the new version is merged in `master`, create a `tag` matching the new version.
## 👥 Contributing
**Anyone** can do something to make `belvo-python` better, so contributors are always welcome!
If you wish to submit a pull request, please be sure check the items on this list:
- [ ] Tests related to the changed code were executed
- [ ] The source code has been coded following the OWASP security best practices (https://owasp.org/www-pdf-archive/OWASP_SCP_Quick_Reference_Guide_v2.pdf).
- [ ] Commit message properly labeled
- [ ] There is a ticket associated to each PR.
For more details about contributing to this project, please take a look to our [guidelines](CONTRIBUTING.md).
%package help
Summary: Development documents and examples for belvo-python
Provides: python3-belvo-python-doc
%description help
Belvo Python SDK
## 📕 Documentation
How to use `belvo-python`: https://belvo-finance.github.io/belvo-python/
If you want to check the full documentation about Belvo API: https://docs.belvo.com
Or if you want to more information about:
* [Getting Belvo API keys](https://developers.belvo.com/docs/get-your-belvo-api-keys)
* [Using Connect Widget](https://developers.belvo.com/docs/connect-widget)
* [Testing in sandbox](https://developers.belvo.com/docs/test-in-sandbox)
* [Using webhooks and recurrent links](https://developers.belvo.com/docs/webhooks)
## 📋 Requirements
* Python 3.6+
## 🚀 Getting started
Install using `pip`:
```
$ pip install belvo-python
```
## Usage (create link via widget)
When your user successfully links their account using the [Connect Widget](https://developers.belvo.com/docs/connect-widget), your implemented callback funciton will return the `link_id` required to make further API to retrieve information.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Get the link_id from the result of your widget callback function
link_id = result_from_callback_function.id
# Get all accounts
client.Accounts.create(link=link_id)
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Usage (create link via SDK)
You can also manually create the link using the SDK. However, for security purposes, we highly recommend, that you use the [Connect Widget](https://developers.belvo.com/docs/connect-widget) to create the link and follow the **Usage (create link via widget)** example.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
# Login to Belvo API
client = Client("your-secret-key-id", "your-secret-key", "sandbox")
# Register a link
link = client.Links.create(
institution="erebor_mx_retail",
username="johndoe",
password="supersecret",
access_mode=AccessMode.SINGLE
)
# Get all accounts
client.Accounts.create(link=link["id"])
# Pretty print all checking accounts
for account in client.Accounts.list(type="checking"):
pprint(account)
```
## Errors and exceptions
By default, when you use our SDK, we automatically return the [error](https://developers.belvo.com/docs/integration-overview#error-handling). However, if you prefer to receive the exception, you need to set the `raise_exception` optional parameter to `True`.
```python
from pprint import pprint
from belvo.client import Client
from belvo.enums import AccessMode
from belvo.exceptions import RequestError
# Login to Belvo API
client = Client("my-secret-key-id", "my-secret-key", "sandbox")
try:
# Register a link
link = client.Links.create(
access_mode=AccessMode.SINGLE,
institution="erebor_mx_retail",
username="",
password="",
raise_exception=True, # Set this optional paramter
)
except RequestError as e:
# do something with the error
pprint(e)
else:
# do something with the link
pprint(link)
```
## 🐍 Development
To release a new version of the SDK to PyPI:
- Create a new branch from master.
- Use `make new-version major|minor|patch` to bump a new version.
- Create a new pull request for the new version.
- Once the new version is merged in `master`, create a `tag` matching the new version.
## 👥 Contributing
**Anyone** can do something to make `belvo-python` better, so contributors are always welcome!
If you wish to submit a pull request, please be sure check the items on this list:
- [ ] Tests related to the changed code were executed
- [ ] The source code has been coded following the OWASP security best practices (https://owasp.org/www-pdf-archive/OWASP_SCP_Quick_Reference_Guide_v2.pdf).
- [ ] Commit message properly labeled
- [ ] There is a ticket associated to each PR.
For more details about contributing to this project, please take a look to our [guidelines](CONTRIBUTING.md).
%prep
%autosetup -n belvo-python-0.37.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-belvo-python -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.37.0-1
- Package Spec generated