%global _empty_manifest_terminate_build 0 Name: python-whacc Version: 1.3.26 Release: 1 Summary: Automatic and customizable pipeline for creating a CNN + light GBM model to predict whiskers contacting objects License: MIT URL: https://github.com/hireslab/whacc Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d9/71/8a836dca5f1c0f486a8921bdc7f0004d55dd88e12e9aec6740013ef9e282/whacc-1.3.26.tar.gz BuildArch: noarch Requires: python3-natsort %description ![](./pictures/whacc-logo-v1.png)
WhACC is a tool for automated touched image classification. Many neuroscience labs (e.g. [Hires Lab](https://www.hireslab.org/)) use tasks that involve whisker active touch against thin movable poles to study diverse questions of sensory and motor coding. Since neurons operate at temporal resolutions of milliseconds, determining precise whisker contact periods is essential. Yet, accurately classifying the precise moment of touch is time-consuming and labor intensive. ## [Walkthrough: Google CoLab](https://colab.research.google.com/drive/1HqkzE-Wih89DKwrOWplp58UrbNMP1KPS?usp=sharing) ![](./pictures/trial_animation.gif)
*Single example trial lasting 4 seconds. Example video (left) along with whisker traces, decomposed components, and spikes recorded from L5 (right). How do we identify the precise millisecond frame when touch occurs?* ![](./pictures/ResNetV2_2048_features_clustered.gif)
*Original 2048 output features extracted from the penultimate layer of the initial ResNet50 V2 model, clustered for emphasize* ## Flow diagram of WhACC video pre-processing and design implementation ![](./pictures/WhACC_figure_1.png)
## Touch frame scoring and variation in human curation ![](./pictures/WhACC_figure_2.png)
## Data selection and model performance ![](./pictures/WhACC_figure_3.png)
## Feature engineering and selection ![](./pictures/WhACC_figure_5.png)
## WhACC shows expert human level performance ![](./pictures/WhACC_figure_4.png)
## WhACC can be retrained on a small subset to account for data drift over time or different datasets (see GUI below) ![](./pictures/WhACC_figure_6.png)
## WhACC GUI: used to curate automatically selected subset of data for optimal performance ![](./pictures/WhACC_GUI_Curator.png)
## Use left and right arrows to move through images, use up to label as touch (green) and down to label as not-touch (red) ![](./pictures/curation_GUI.gif)
## Code contributors: WhACC code and software was originally developed by Phillip Maire and Jonathan Cheung in the laboratory of [Samuel Andrew Hires](https://www.hireslab.org/). %package -n python3-whacc Summary: Automatic and customizable pipeline for creating a CNN + light GBM model to predict whiskers contacting objects Provides: python-whacc BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-whacc ![](./pictures/whacc-logo-v1.png)
WhACC is a tool for automated touched image classification. Many neuroscience labs (e.g. [Hires Lab](https://www.hireslab.org/)) use tasks that involve whisker active touch against thin movable poles to study diverse questions of sensory and motor coding. Since neurons operate at temporal resolutions of milliseconds, determining precise whisker contact periods is essential. Yet, accurately classifying the precise moment of touch is time-consuming and labor intensive. ## [Walkthrough: Google CoLab](https://colab.research.google.com/drive/1HqkzE-Wih89DKwrOWplp58UrbNMP1KPS?usp=sharing) ![](./pictures/trial_animation.gif)
*Single example trial lasting 4 seconds. Example video (left) along with whisker traces, decomposed components, and spikes recorded from L5 (right). How do we identify the precise millisecond frame when touch occurs?* ![](./pictures/ResNetV2_2048_features_clustered.gif)
*Original 2048 output features extracted from the penultimate layer of the initial ResNet50 V2 model, clustered for emphasize* ## Flow diagram of WhACC video pre-processing and design implementation ![](./pictures/WhACC_figure_1.png)
## Touch frame scoring and variation in human curation ![](./pictures/WhACC_figure_2.png)
## Data selection and model performance ![](./pictures/WhACC_figure_3.png)
## Feature engineering and selection ![](./pictures/WhACC_figure_5.png)
## WhACC shows expert human level performance ![](./pictures/WhACC_figure_4.png)
## WhACC can be retrained on a small subset to account for data drift over time or different datasets (see GUI below) ![](./pictures/WhACC_figure_6.png)
## WhACC GUI: used to curate automatically selected subset of data for optimal performance ![](./pictures/WhACC_GUI_Curator.png)
## Use left and right arrows to move through images, use up to label as touch (green) and down to label as not-touch (red) ![](./pictures/curation_GUI.gif)
## Code contributors: WhACC code and software was originally developed by Phillip Maire and Jonathan Cheung in the laboratory of [Samuel Andrew Hires](https://www.hireslab.org/). %package help Summary: Development documents and examples for whacc Provides: python3-whacc-doc %description help ![](./pictures/whacc-logo-v1.png)
WhACC is a tool for automated touched image classification. Many neuroscience labs (e.g. [Hires Lab](https://www.hireslab.org/)) use tasks that involve whisker active touch against thin movable poles to study diverse questions of sensory and motor coding. Since neurons operate at temporal resolutions of milliseconds, determining precise whisker contact periods is essential. Yet, accurately classifying the precise moment of touch is time-consuming and labor intensive. ## [Walkthrough: Google CoLab](https://colab.research.google.com/drive/1HqkzE-Wih89DKwrOWplp58UrbNMP1KPS?usp=sharing) ![](./pictures/trial_animation.gif)
*Single example trial lasting 4 seconds. Example video (left) along with whisker traces, decomposed components, and spikes recorded from L5 (right). How do we identify the precise millisecond frame when touch occurs?* ![](./pictures/ResNetV2_2048_features_clustered.gif)
*Original 2048 output features extracted from the penultimate layer of the initial ResNet50 V2 model, clustered for emphasize* ## Flow diagram of WhACC video pre-processing and design implementation ![](./pictures/WhACC_figure_1.png)
## Touch frame scoring and variation in human curation ![](./pictures/WhACC_figure_2.png)
## Data selection and model performance ![](./pictures/WhACC_figure_3.png)
## Feature engineering and selection ![](./pictures/WhACC_figure_5.png)
## WhACC shows expert human level performance ![](./pictures/WhACC_figure_4.png)
## WhACC can be retrained on a small subset to account for data drift over time or different datasets (see GUI below) ![](./pictures/WhACC_figure_6.png)
## WhACC GUI: used to curate automatically selected subset of data for optimal performance ![](./pictures/WhACC_GUI_Curator.png)
## Use left and right arrows to move through images, use up to label as touch (green) and down to label as not-touch (red) ![](./pictures/curation_GUI.gif)
## Code contributors: WhACC code and software was originally developed by Phillip Maire and Jonathan Cheung in the laboratory of [Samuel Andrew Hires](https://www.hireslab.org/). %prep %autosetup -n whacc-1.3.26 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-whacc -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 1.3.26-1 - Package Spec generated