%global _empty_manifest_terminate_build 0
Name:		python-flask-mailman
Version:	0.3.0
Release:	1
Summary:	Porting Django's email implementation to your Flask applications.
License:	BSD-3-Clause
URL:		https://github.com/waynerv/flask-mailman
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fa/8f/c7315765b909ad6d7e416dd77a3f226eff8c752565e0349b10d738c784c3/Flask-Mailman-0.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-black
Requires:	python3-bump2version
Requires:	python3-flake8
Requires:	python3-flask
Requires:	python3-isort
Requires:	python3-mkdocs
Requires:	python3-mkdocs-autorefs
Requires:	python3-mkdocs-include-markdown-plugin
Requires:	python3-mkdocs-material
Requires:	python3-mkdocs-material-extensions
Requires:	python3-mkdocstrings
Requires:	python3-pip
Requires:	python3-pre-commit
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-toml
Requires:	python3-tox
Requires:	python3-twine
Requires:	python3-virtualenv

%description
# Flask-Mailman

![PyPI](https://img.shields.io/pypi/v/flask-mailman?color=blue)
![PyPI - Downloads](https://img.shields.io/pypi/dm/flask-mailman?color=brightgreen)
[![dev workflow](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml/badge.svg?branch=master)](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml)
![GitHub commits since latest release (by SemVer)](https://img.shields.io/github/commits-since/waynerv/flask-mailman/latest?color=cyan)
![PyPI - License](https://img.shields.io/pypi/l/flask-mailman?color=blue)

Flask-Mailman is a Flask extension providing simple email sending capabilities.

It was meant to replace unmaintained Flask-Mail with a better warranty and more features.

## Usage

Flask-Mail ported Django's email implementation to your Flask applications, which may be the best mail sending implementation that's available for python.

The way of using this extension is almost the same as Django.

Documentation: https://waynerv.github.io/flask-mailman.

**Note: A few breaking changes have been made in v0.2.0 version** to ensure that API of this extension is basically the same as Django.
Users migrating from Flask-Mail should upgrade with caution.

## Credits

Thanks to [Jetbrains](https://jb.gg/OpenSource) for providing an Open Source license for this project.

[![Jetbrains Logo](docs/img/jetbrains-variant-4.png)](www.jetbrains.com)

Build tools and workflows of this project was inspired by [waynerv/cookiecutter-pypackage](https://github.com/waynerv/cookiecutter-pypackage) project template.



%package -n python3-flask-mailman
Summary:	Porting Django's email implementation to your Flask applications.
Provides:	python-flask-mailman
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-flask-mailman
# Flask-Mailman

![PyPI](https://img.shields.io/pypi/v/flask-mailman?color=blue)
![PyPI - Downloads](https://img.shields.io/pypi/dm/flask-mailman?color=brightgreen)
[![dev workflow](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml/badge.svg?branch=master)](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml)
![GitHub commits since latest release (by SemVer)](https://img.shields.io/github/commits-since/waynerv/flask-mailman/latest?color=cyan)
![PyPI - License](https://img.shields.io/pypi/l/flask-mailman?color=blue)

Flask-Mailman is a Flask extension providing simple email sending capabilities.

It was meant to replace unmaintained Flask-Mail with a better warranty and more features.

## Usage

Flask-Mail ported Django's email implementation to your Flask applications, which may be the best mail sending implementation that's available for python.

The way of using this extension is almost the same as Django.

Documentation: https://waynerv.github.io/flask-mailman.

**Note: A few breaking changes have been made in v0.2.0 version** to ensure that API of this extension is basically the same as Django.
Users migrating from Flask-Mail should upgrade with caution.

## Credits

Thanks to [Jetbrains](https://jb.gg/OpenSource) for providing an Open Source license for this project.

[![Jetbrains Logo](docs/img/jetbrains-variant-4.png)](www.jetbrains.com)

Build tools and workflows of this project was inspired by [waynerv/cookiecutter-pypackage](https://github.com/waynerv/cookiecutter-pypackage) project template.



%package help
Summary:	Development documents and examples for flask-mailman
Provides:	python3-flask-mailman-doc
%description help
# Flask-Mailman

![PyPI](https://img.shields.io/pypi/v/flask-mailman?color=blue)
![PyPI - Downloads](https://img.shields.io/pypi/dm/flask-mailman?color=brightgreen)
[![dev workflow](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml/badge.svg?branch=master)](https://github.com/waynerv/flask-mailman/actions/workflows/dev.yml)
![GitHub commits since latest release (by SemVer)](https://img.shields.io/github/commits-since/waynerv/flask-mailman/latest?color=cyan)
![PyPI - License](https://img.shields.io/pypi/l/flask-mailman?color=blue)

Flask-Mailman is a Flask extension providing simple email sending capabilities.

It was meant to replace unmaintained Flask-Mail with a better warranty and more features.

## Usage

Flask-Mail ported Django's email implementation to your Flask applications, which may be the best mail sending implementation that's available for python.

The way of using this extension is almost the same as Django.

Documentation: https://waynerv.github.io/flask-mailman.

**Note: A few breaking changes have been made in v0.2.0 version** to ensure that API of this extension is basically the same as Django.
Users migrating from Flask-Mail should upgrade with caution.

## Credits

Thanks to [Jetbrains](https://jb.gg/OpenSource) for providing an Open Source license for this project.

[![Jetbrains Logo](docs/img/jetbrains-variant-4.png)](www.jetbrains.com)

Build tools and workflows of this project was inspired by [waynerv/cookiecutter-pypackage](https://github.com/waynerv/cookiecutter-pypackage) project template.



%prep
%autosetup -n flask-mailman-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-flask-mailman -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated