%global _empty_manifest_terminate_build 0
Name: python-etebase
Version: 0.31.5
Release: 1
Summary: Python client library for Etebase
License: BSD-3-Clause
URL: https://github.com/etesync/etebase-py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/c6/0f33ab4b82acf71d133c074ab10a89debc6ebbe96b05bda1e74459d47d8a/etebase-0.31.5.tar.gz
Requires: python3-msgpack
%description
Etebase - Encrypt Everything
A Python library for Etebase
This package is implemented in Rust and exposes a Python API for people to use.

[](https://pypi.python.org/pypi/etebase/)
[](https://github.com/etesync/etebase-py/actions/)
[](https://www.etebase.com/community-chat/)
# Documentation
In addition to the API documentation, there are docs available at https://docs.etebase.com
# Build
## Install deps
```
pip install wheel setuptools setuptools-rust
```
## Build
```
python setup.py bdist_wheel
```
%package -n python3-etebase
Summary: Python client library for Etebase
Provides: python-etebase
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-etebase
Etebase - Encrypt Everything
A Python library for Etebase
This package is implemented in Rust and exposes a Python API for people to use.

[](https://pypi.python.org/pypi/etebase/)
[](https://github.com/etesync/etebase-py/actions/)
[](https://www.etebase.com/community-chat/)
# Documentation
In addition to the API documentation, there are docs available at https://docs.etebase.com
# Build
## Install deps
```
pip install wheel setuptools setuptools-rust
```
## Build
```
python setup.py bdist_wheel
```
%package help
Summary: Development documents and examples for etebase
Provides: python3-etebase-doc
%description help
Etebase - Encrypt Everything
A Python library for Etebase
This package is implemented in Rust and exposes a Python API for people to use.

[](https://pypi.python.org/pypi/etebase/)
[](https://github.com/etesync/etebase-py/actions/)
[](https://www.etebase.com/community-chat/)
# Documentation
In addition to the API documentation, there are docs available at https://docs.etebase.com
# Build
## Install deps
```
pip install wheel setuptools setuptools-rust
```
## Build
```
python setup.py bdist_wheel
```
%prep
%autosetup -n etebase-0.31.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-etebase -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.31.5-1
- Package Spec generated