%global _empty_manifest_terminate_build 0
Name: python-blankly
Version: 1.18.24b0
Release: 1
Summary: Rapidly build, backtest & deploy trading bots
License: lgpl-3.0
URL: https://github.com/Blankly-Finance/Blankly
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/36/8a/ab8945cd1f99ea642157edcf20178cfcc5da2efe04507fbb8c276fa478a0/blankly-1.18.24b0.tar.gz
BuildArch: noarch
Requires: python3-questionary
Requires: python3-yaspin
Requires: python3-alpaca-trade-api
Requires: python3-bokeh
Requires: python3-dateparser
Requires: python3-newnewtulipy
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-binance
Requires: python3-requests
Requires: python3-websocket-client
%description
## Why Blankly?
Blankly is an ecosystem for algotraders enabling anyone to build, monetize and scale their trading algorithms for stocks, crypto, futures or forex. The same code can be backtested, paper traded, sandbox tested and run live by simply changing a single line. Develop locally then deploy, iterate and share using the blankly platform.
The blankly package is designed to be **extremely precise** in both simulation and live trading. **The engineering considerations for highly accurate simulation are described [here](blankly/BACKTESTING_ENGINEERING.md)**
Getting started is easy - just `pip install blankly` and `blankly init`.
Check out our [website](https://blankly.finance) and our [docs](https://docs.blankly.finance).

%package -n python3-blankly
Summary: Rapidly build, backtest & deploy trading bots
Provides: python-blankly
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-blankly
## Why Blankly?
Blankly is an ecosystem for algotraders enabling anyone to build, monetize and scale their trading algorithms for stocks, crypto, futures or forex. The same code can be backtested, paper traded, sandbox tested and run live by simply changing a single line. Develop locally then deploy, iterate and share using the blankly platform.
The blankly package is designed to be **extremely precise** in both simulation and live trading. **The engineering considerations for highly accurate simulation are described [here](blankly/BACKTESTING_ENGINEERING.md)**
Getting started is easy - just `pip install blankly` and `blankly init`.
Check out our [website](https://blankly.finance) and our [docs](https://docs.blankly.finance).

%package help
Summary: Development documents and examples for blankly
Provides: python3-blankly-doc
%description help
## Why Blankly?
Blankly is an ecosystem for algotraders enabling anyone to build, monetize and scale their trading algorithms for stocks, crypto, futures or forex. The same code can be backtested, paper traded, sandbox tested and run live by simply changing a single line. Develop locally then deploy, iterate and share using the blankly platform.
The blankly package is designed to be **extremely precise** in both simulation and live trading. **The engineering considerations for highly accurate simulation are described [here](blankly/BACKTESTING_ENGINEERING.md)**
Getting started is easy - just `pip install blankly` and `blankly init`.
Check out our [website](https://blankly.finance) and our [docs](https://docs.blankly.finance).

%prep
%autosetup -n blankly-1.18.24b0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-blankly -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot
- 1.18.24b0-1
- Package Spec generated