%global _empty_manifest_terminate_build 0
Name: python-pact-test
Version: 1.0.4
Release: 1
Summary: Python implementation for Pact (http://pact.io/)
License: LICENSE
URL: https://github.com/Kalimaha/pact-test/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/28/14/a598404a3b64f90a6cbe6a217240c6aa6b84f25b99dbd7b25089e140f19a/pact-test-1.0.4.tar.gz
BuildArch: noarch
Requires: python3-requests
%description
This repository contains a Python implementation for `Pact `_. Pact is a specification for
Consumer Driven Contracts Testing. For further information about Pact project, contracts testing, pros and cons and
useful resources please refer to the `Pact website `_.
There are two phases in Consumer Driven Contracts Testing: a Consumer sets up a contract (*it's consumer driven
after all!*), and a Provider honours it. But, before that...
Installation
~~~~~~~~~~~~
Pact Test is distributed through `PyPi `_ so it can be easily included in the
$ pip install pact-test
%package -n python3-pact-test
Summary: Python implementation for Pact (http://pact.io/)
Provides: python-pact-test
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pact-test
This repository contains a Python implementation for `Pact `_. Pact is a specification for
Consumer Driven Contracts Testing. For further information about Pact project, contracts testing, pros and cons and
useful resources please refer to the `Pact website `_.
There are two phases in Consumer Driven Contracts Testing: a Consumer sets up a contract (*it's consumer driven
after all!*), and a Provider honours it. But, before that...
Installation
~~~~~~~~~~~~
Pact Test is distributed through `PyPi `_ so it can be easily included in the
$ pip install pact-test
%package help
Summary: Development documents and examples for pact-test
Provides: python3-pact-test-doc
%description help
This repository contains a Python implementation for `Pact `_. Pact is a specification for
Consumer Driven Contracts Testing. For further information about Pact project, contracts testing, pros and cons and
useful resources please refer to the `Pact website `_.
There are two phases in Consumer Driven Contracts Testing: a Consumer sets up a contract (*it's consumer driven
after all!*), and a Provider honours it. But, before that...
Installation
~~~~~~~~~~~~
Pact Test is distributed through `PyPi `_ so it can be easily included in the
$ pip install pact-test
%prep
%autosetup -n pact-test-1.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pact-test -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.4-1
- Package Spec generated