%global _empty_manifest_terminate_build 0
Name:		python-pytest-databricks
Version:	0.0.8
Release:	1
Summary:	Pytest plugin for remote Databricks notebooks testing
License:	MIT License
URL:		https://github.com/ivangeorgiev/pytest-databricks
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/cf/6a/91402be4df41932d523375212377057a61e293eb26e5589490c0264e8fef/pytest-databricks-0.0.8.tar.gz
BuildArch:	noarch

Requires:	python3-pydbr
Requires:	python3-pytest

%description
# pytest-databricks
Pytest plugin for testing Databricks notebooks




## Release Notes

### 0.0.8
- fixed typo

### 0.0.7
- dbr_connection fixture raises exception of token, url or cluster id not specified
- added run_unittest and run_unittest_testcase helpers
- new test client auto_save and dir_auto_save properties




%package -n python3-pytest-databricks
Summary:	Pytest plugin for remote Databricks notebooks testing
Provides:	python-pytest-databricks
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-databricks
# pytest-databricks
Pytest plugin for testing Databricks notebooks




## Release Notes

### 0.0.8
- fixed typo

### 0.0.7
- dbr_connection fixture raises exception of token, url or cluster id not specified
- added run_unittest and run_unittest_testcase helpers
- new test client auto_save and dir_auto_save properties




%package help
Summary:	Development documents and examples for pytest-databricks
Provides:	python3-pytest-databricks-doc
%description help
# pytest-databricks
Pytest plugin for testing Databricks notebooks




## Release Notes

### 0.0.8
- fixed typo

### 0.0.7
- dbr_connection fixture raises exception of token, url or cluster id not specified
- added run_unittest and run_unittest_testcase helpers
- new test client auto_save and dir_auto_save properties




%prep
%autosetup -n pytest-databricks-0.0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-databricks -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.8-1
- Package Spec generated