%global _empty_manifest_terminate_build 0
Name:		python-admin-extra-urls
Version:	2.2.0
Release:	1
Summary:	Django mixin to easily add urls to any ModelAdmin
License:	BSD License
URL:		https://github.com/saxix/django-admin-extra-urls
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4c/11/61818521006f710c038f457302f12c99a27027d85b5e0dfbe977defbe107/admin-extra-urls-2.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-autopep8
Requires:	python3-check-manifest
Requires:	python3-flake8
Requires:	python3-pep8
Requires:	python3-readme
Requires:	python3-wheel
Requires:	python3-coverage
Requires:	python3-factory-boy
Requires:	python3-django-webtest
Requires:	python3-pdbpp
Requires:	python3-pyquery
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-django
Requires:	python3-pytest-echo
Requires:	python3-pytest-pythonpath
Requires:	python3-tox
Requires:	python3-coverage
Requires:	python3-factory-boy
Requires:	python3-django-webtest
Requires:	python3-pdbpp
Requires:	python3-pyquery
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-django
Requires:	python3-pytest-echo
Requires:	python3-pytest-pythonpath
Requires:	python3-tox
Requires:	python3-wheel

%description
pluggable django application that offers one single mixin class ``ExtraUrlMixin``
to easily add new url (and related buttons on the screen) to any ModelAdmin.
It provides two decorators ``link()`` and ``action()``.
- ``link()`` is intended to be used for multiple records. It will produce a button in the change list view.
- ``action()`` works on a single record. It will produce a button in the change form view.

%package -n python3-admin-extra-urls
Summary:	Django mixin to easily add urls to any ModelAdmin
Provides:	python-admin-extra-urls
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-admin-extra-urls
pluggable django application that offers one single mixin class ``ExtraUrlMixin``
to easily add new url (and related buttons on the screen) to any ModelAdmin.
It provides two decorators ``link()`` and ``action()``.
- ``link()`` is intended to be used for multiple records. It will produce a button in the change list view.
- ``action()`` works on a single record. It will produce a button in the change form view.

%package help
Summary:	Development documents and examples for admin-extra-urls
Provides:	python3-admin-extra-urls-doc
%description help
pluggable django application that offers one single mixin class ``ExtraUrlMixin``
to easily add new url (and related buttons on the screen) to any ModelAdmin.
It provides two decorators ``link()`` and ``action()``.
- ``link()`` is intended to be used for multiple records. It will produce a button in the change list view.
- ``action()`` works on a single record. It will produce a button in the change form view.

%prep
%autosetup -n admin-extra-urls-2.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-admin-extra-urls -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.0-1
- Package Spec generated