%global _empty_manifest_terminate_build 0
Name:		python-awkward0
Version:	0.15.5
Release:	1
Summary:	Manipulate arrays of complex data structures as easily as Numpy.
License:	BSD 3-clause
URL:		https://github.com/scikit-hep/awkward-0.x
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/24/b1/dfffd68d87ef85e0898a1be32acff473d6dc841fd61b31131a271db5c3cf/awkward0-0.15.5.tar.gz
BuildArch:	noarch

Requires:	python3-numpy

%description
Install Awkward Array like any other Python package:
    pip install awkward0                      # maybe with sudo or --user, or in virtualenv
The base ``awkward0`` package requires only `Numpy <https://scipy.org/install.html>`__  (1.13.1+).

%package -n python3-awkward0
Summary:	Manipulate arrays of complex data structures as easily as Numpy.
Provides:	python-awkward0
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-awkward0
Install Awkward Array like any other Python package:
    pip install awkward0                      # maybe with sudo or --user, or in virtualenv
The base ``awkward0`` package requires only `Numpy <https://scipy.org/install.html>`__  (1.13.1+).

%package help
Summary:	Development documents and examples for awkward0
Provides:	python3-awkward0-doc
%description help
Install Awkward Array like any other Python package:
    pip install awkward0                      # maybe with sudo or --user, or in virtualenv
The base ``awkward0`` package requires only `Numpy <https://scipy.org/install.html>`__  (1.13.1+).

%prep
%autosetup -n awkward0-0.15.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-awkward0 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.15.5-1
- Package Spec generated