%global _empty_manifest_terminate_build 0
Name: python-pymfy
Version: 0.11.0
Release: 1
Summary: A Somfy Open API library
License: GPL-3.0-only
URL: https://github.com/tetienne/somfy-open-api
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/55/3869851dcc74c1af445425c40fa4afff9215678f70349609fbd71812463f/pymfy-0.11.0.tar.gz
BuildArch: noarch
Requires: python3-requests-oauthlib
%description
This library is an attempt to implement the entire Somfy API in Python 3.
Documentation for the Somfy API can be found [here](https://developer.somfy.com/somfy-open-api/apis).
## Get developer credentials
1. Vist https://developer.somfy.com
2. Create an account
3. Open the _My Apps_ menu
4. Add a new App (for testing, redirect url can be anything in https)
5. Plug in your details into the test script below.
## Supported devices
Somfy currently exposes the following type of devices:
- [Blinds](https://developer.somfy.com/products/blinds-interior-and-exterior)
- [Rolling shutters](https://developer.somfy.com/products/rolling-shutters)
- [Cameras](https://developer.somfy.com/products/cameras)
- [Connected Thermostat](https://developer.somfy.com/products/connected-thermostat)
If you find on this [page](https://developer.somfy.com/products-services-informations) devices not yet handle by this
repository, don't hesitate to open an issue.
## Installation
```
pip install pymfy
```
## Limitation
Somfy support sent the following message to third party applications using their API.
```
Dear customer,
As you might have noticed, we have updated the quota policy of the Somfy Open API, in an ongoing effort to provide the best services to our users.
We are contacting you today to inform you about the new rules we are now applying to the API:
- First of all, no limitation will be applied on the POST /device/{deviceId}/exec endpoint as we want to provide you a total freedom on controlling your devices.
- On the other hand, polling frequency on the GET /site and child endpoints will now have to be under 1 call per minute.
To preserve an efficient and available service to any of our users, we want to keep the usage of the Open API to a usable but reasonable level to everybody. As we will keep monitoring the generated traffic and the potential impacts, be aware that we do reserve the rights to modify the authorized polling frequency or take any additional measure at any time as stated in our General Terms of Use.
Thank you for your understanding.
```
## Example usage
Print all covers position.
```python
import os
import json
from urllib.parse import urlparse, parse_qs
from pymfy.api.devices.roller_shutter import RollerShutter
from pymfy.api.somfy_api import SomfyApi
from pymfy.api.devices.category import Category
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
def get_token():
try:
with open(cache_path, "r") as cache:
return json.loads(cache.read())
except IOError:
pass
def set_token(token) -> None:
with open(cache_path, "w") as cache:
cache.write(json.dumps(token))
cache_path = "/optional/cache/path"
api = SomfyApi(client_id, secret, redir_url, token=get_token(), token_updater=set_token)
if not os.path.isfile(cache_path):
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
set_token(api.request_token(code=code))
site_ids = api.get_sites()
devices = api.get_devices(site_ids[0], category=Category.ROLLER_SHUTTER)
covers = [RollerShutter(d, api) for d in devices]
for cover in covers:
print(
"Cover {} has the following position: {}".format(
cover.device.name, cover.get_position()
)
)
```
## Contribute
The current [documentation](https://developer.somfy.com/products-services-informations) does not give enough information to implement all the devices.
If you want to contribute to this repository adding new devices, you can create an issue with the output of this script:
```python
import json
import re
from urllib.parse import urlparse, parse_qs
from pymfy.api.somfy_api import SomfyApi
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
api = SomfyApi(client_id, secret, redir_url)
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
api.request_token(code=code)
site_ids = [s.id for s in api.get_sites()]
devices = [api.get("/site/" + s_id + "/device").json() for s_id in site_ids]
# Remove personal information
dumps = json.dumps(devices, sort_keys=True, indent=4, separators=(",", ": "))
dumps = re.sub('".*id.*": ".*",\n', "", dumps)
print(dumps)
```
%package -n python3-pymfy
Summary: A Somfy Open API library
Provides: python-pymfy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pymfy
This library is an attempt to implement the entire Somfy API in Python 3.
Documentation for the Somfy API can be found [here](https://developer.somfy.com/somfy-open-api/apis).
## Get developer credentials
1. Vist https://developer.somfy.com
2. Create an account
3. Open the _My Apps_ menu
4. Add a new App (for testing, redirect url can be anything in https)
5. Plug in your details into the test script below.
## Supported devices
Somfy currently exposes the following type of devices:
- [Blinds](https://developer.somfy.com/products/blinds-interior-and-exterior)
- [Rolling shutters](https://developer.somfy.com/products/rolling-shutters)
- [Cameras](https://developer.somfy.com/products/cameras)
- [Connected Thermostat](https://developer.somfy.com/products/connected-thermostat)
If you find on this [page](https://developer.somfy.com/products-services-informations) devices not yet handle by this
repository, don't hesitate to open an issue.
## Installation
```
pip install pymfy
```
## Limitation
Somfy support sent the following message to third party applications using their API.
```
Dear customer,
As you might have noticed, we have updated the quota policy of the Somfy Open API, in an ongoing effort to provide the best services to our users.
We are contacting you today to inform you about the new rules we are now applying to the API:
- First of all, no limitation will be applied on the POST /device/{deviceId}/exec endpoint as we want to provide you a total freedom on controlling your devices.
- On the other hand, polling frequency on the GET /site and child endpoints will now have to be under 1 call per minute.
To preserve an efficient and available service to any of our users, we want to keep the usage of the Open API to a usable but reasonable level to everybody. As we will keep monitoring the generated traffic and the potential impacts, be aware that we do reserve the rights to modify the authorized polling frequency or take any additional measure at any time as stated in our General Terms of Use.
Thank you for your understanding.
```
## Example usage
Print all covers position.
```python
import os
import json
from urllib.parse import urlparse, parse_qs
from pymfy.api.devices.roller_shutter import RollerShutter
from pymfy.api.somfy_api import SomfyApi
from pymfy.api.devices.category import Category
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
def get_token():
try:
with open(cache_path, "r") as cache:
return json.loads(cache.read())
except IOError:
pass
def set_token(token) -> None:
with open(cache_path, "w") as cache:
cache.write(json.dumps(token))
cache_path = "/optional/cache/path"
api = SomfyApi(client_id, secret, redir_url, token=get_token(), token_updater=set_token)
if not os.path.isfile(cache_path):
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
set_token(api.request_token(code=code))
site_ids = api.get_sites()
devices = api.get_devices(site_ids[0], category=Category.ROLLER_SHUTTER)
covers = [RollerShutter(d, api) for d in devices]
for cover in covers:
print(
"Cover {} has the following position: {}".format(
cover.device.name, cover.get_position()
)
)
```
## Contribute
The current [documentation](https://developer.somfy.com/products-services-informations) does not give enough information to implement all the devices.
If you want to contribute to this repository adding new devices, you can create an issue with the output of this script:
```python
import json
import re
from urllib.parse import urlparse, parse_qs
from pymfy.api.somfy_api import SomfyApi
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
api = SomfyApi(client_id, secret, redir_url)
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
api.request_token(code=code)
site_ids = [s.id for s in api.get_sites()]
devices = [api.get("/site/" + s_id + "/device").json() for s_id in site_ids]
# Remove personal information
dumps = json.dumps(devices, sort_keys=True, indent=4, separators=(",", ": "))
dumps = re.sub('".*id.*": ".*",\n', "", dumps)
print(dumps)
```
%package help
Summary: Development documents and examples for pymfy
Provides: python3-pymfy-doc
%description help
This library is an attempt to implement the entire Somfy API in Python 3.
Documentation for the Somfy API can be found [here](https://developer.somfy.com/somfy-open-api/apis).
## Get developer credentials
1. Vist https://developer.somfy.com
2. Create an account
3. Open the _My Apps_ menu
4. Add a new App (for testing, redirect url can be anything in https)
5. Plug in your details into the test script below.
## Supported devices
Somfy currently exposes the following type of devices:
- [Blinds](https://developer.somfy.com/products/blinds-interior-and-exterior)
- [Rolling shutters](https://developer.somfy.com/products/rolling-shutters)
- [Cameras](https://developer.somfy.com/products/cameras)
- [Connected Thermostat](https://developer.somfy.com/products/connected-thermostat)
If you find on this [page](https://developer.somfy.com/products-services-informations) devices not yet handle by this
repository, don't hesitate to open an issue.
## Installation
```
pip install pymfy
```
## Limitation
Somfy support sent the following message to third party applications using their API.
```
Dear customer,
As you might have noticed, we have updated the quota policy of the Somfy Open API, in an ongoing effort to provide the best services to our users.
We are contacting you today to inform you about the new rules we are now applying to the API:
- First of all, no limitation will be applied on the POST /device/{deviceId}/exec endpoint as we want to provide you a total freedom on controlling your devices.
- On the other hand, polling frequency on the GET /site and child endpoints will now have to be under 1 call per minute.
To preserve an efficient and available service to any of our users, we want to keep the usage of the Open API to a usable but reasonable level to everybody. As we will keep monitoring the generated traffic and the potential impacts, be aware that we do reserve the rights to modify the authorized polling frequency or take any additional measure at any time as stated in our General Terms of Use.
Thank you for your understanding.
```
## Example usage
Print all covers position.
```python
import os
import json
from urllib.parse import urlparse, parse_qs
from pymfy.api.devices.roller_shutter import RollerShutter
from pymfy.api.somfy_api import SomfyApi
from pymfy.api.devices.category import Category
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
def get_token():
try:
with open(cache_path, "r") as cache:
return json.loads(cache.read())
except IOError:
pass
def set_token(token) -> None:
with open(cache_path, "w") as cache:
cache.write(json.dumps(token))
cache_path = "/optional/cache/path"
api = SomfyApi(client_id, secret, redir_url, token=get_token(), token_updater=set_token)
if not os.path.isfile(cache_path):
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
set_token(api.request_token(code=code))
site_ids = api.get_sites()
devices = api.get_devices(site_ids[0], category=Category.ROLLER_SHUTTER)
covers = [RollerShutter(d, api) for d in devices]
for cover in covers:
print(
"Cover {} has the following position: {}".format(
cover.device.name, cover.get_position()
)
)
```
## Contribute
The current [documentation](https://developer.somfy.com/products-services-informations) does not give enough information to implement all the devices.
If you want to contribute to this repository adding new devices, you can create an issue with the output of this script:
```python
import json
import re
from urllib.parse import urlparse, parse_qs
from pymfy.api.somfy_api import SomfyApi
client_id = r"" # Consumer Key
redir_url = "" # Callback URL (for testing, can be anything)
secret = r"" # Consumer Secret
api = SomfyApi(client_id, secret, redir_url)
authorization_url, _ = api.get_authorization_url()
print("Please go to {} and authorize access.".format(authorization_url))
authorization_response = input("Enter the full callback URL")
code = parse_qs(urlparse(authorization_response).query)["code"][0]
api.request_token(code=code)
site_ids = [s.id for s in api.get_sites()]
devices = [api.get("/site/" + s_id + "/device").json() for s_id in site_ids]
# Remove personal information
dumps = json.dumps(devices, sort_keys=True, indent=4, separators=(",", ": "))
dumps = re.sub('".*id.*": ".*",\n', "", dumps)
print(dumps)
```
%prep
%autosetup -n pymfy-0.11.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymfy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.11.0-1
- Package Spec generated