%global _empty_manifest_terminate_build 0
Name: python-crc64iso
Version: 0.0.2
Release: 1
Summary: CRC-64 checksum generator
License: MIT License
URL: https://pypi.org/project/crc64iso/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d0/cc/e8899ae3ff67cfc555959e00bdcd90744a2b3ce49628ce0d9b61b7d1407b/crc64iso-0.0.2.tar.gz
BuildArch: noarch
%description
# CRC64ISO
Package for calculating checksums using __64-bit cyclic redundancy checks (CRC)__ according to the __ISO 3309__ standard.
Generator polynomial: x64 + x4 + x3 + x + 1
Reference:
_W. H. Press, S. A. Teukolsky, W. T. Vetterling, and B. P. Flannery, "Numerical recipes in C", 2nd ed.,
Cambridge University Press. Pages 896ff._
### Requirements
- python 3.x
### Examples
- Calculate 64-bit checksum from a string:
```
from crc64iso.crc64iso import crc64
checksum = crc64iso.crc64("ILOVEMATH")
```
- Calculate 64-bit checksum from incremental (bytes) data:
```
from crc64iso.crc64iso import crc64_pair, format_crc64_pair
crc_pair_1 = crc64_pair("ILOVE".encode())
crc_pair_2 = crc64_pair("MATH".encode(), crc_pair_1)
checksum = format_crc64_pair(crc_pair_2)
```
%package -n python3-crc64iso
Summary: CRC-64 checksum generator
Provides: python-crc64iso
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-crc64iso
# CRC64ISO
Package for calculating checksums using __64-bit cyclic redundancy checks (CRC)__ according to the __ISO 3309__ standard.
Generator polynomial: x64 + x4 + x3 + x + 1
Reference:
_W. H. Press, S. A. Teukolsky, W. T. Vetterling, and B. P. Flannery, "Numerical recipes in C", 2nd ed.,
Cambridge University Press. Pages 896ff._
### Requirements
- python 3.x
### Examples
- Calculate 64-bit checksum from a string:
```
from crc64iso.crc64iso import crc64
checksum = crc64iso.crc64("ILOVEMATH")
```
- Calculate 64-bit checksum from incremental (bytes) data:
```
from crc64iso.crc64iso import crc64_pair, format_crc64_pair
crc_pair_1 = crc64_pair("ILOVE".encode())
crc_pair_2 = crc64_pair("MATH".encode(), crc_pair_1)
checksum = format_crc64_pair(crc_pair_2)
```
%package help
Summary: Development documents and examples for crc64iso
Provides: python3-crc64iso-doc
%description help
# CRC64ISO
Package for calculating checksums using __64-bit cyclic redundancy checks (CRC)__ according to the __ISO 3309__ standard.
Generator polynomial: x64 + x4 + x3 + x + 1
Reference:
_W. H. Press, S. A. Teukolsky, W. T. Vetterling, and B. P. Flannery, "Numerical recipes in C", 2nd ed.,
Cambridge University Press. Pages 896ff._
### Requirements
- python 3.x
### Examples
- Calculate 64-bit checksum from a string:
```
from crc64iso.crc64iso import crc64
checksum = crc64iso.crc64("ILOVEMATH")
```
- Calculate 64-bit checksum from incremental (bytes) data:
```
from crc64iso.crc64iso import crc64_pair, format_crc64_pair
crc_pair_1 = crc64_pair("ILOVE".encode())
crc_pair_2 = crc64_pair("MATH".encode(), crc_pair_1)
checksum = format_crc64_pair(crc_pair_2)
```
%prep
%autosetup -n crc64iso-0.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-crc64iso -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.0.2-1
- Package Spec generated