%global _empty_manifest_terminate_build 0
Name: python-trie-nathaniel
Version: 1.0.0
Release: 1
Summary: Calls commands to the trie server that can modify its state
License: MIT
URL: https://github.com/Nathaniel-github/CombinedServerClientRepo
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c6/b6/54372567f4931251ae052be2b0c362f6e7e28ebd2e04fb9b1fbadd892637/trie_nathaniel-1.0.0.tar.gz
BuildArch: noarch
Requires: python3-inquirer
Requires: python3-click
%description
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
Table of Contents
-
-
Getting Started
- Usage
- Contributing
- License
### Built With
* [inquirer.py](https://pypi.org/project/inquirer/)
* [click.py](https://pypi.org/project/click/)
(back to top)
## Getting Started
Install the CLI to get started!. Take a look at the Installation section for the command to install.
### Prerequisites
Requires python>=3.6 and pip
```sh
sudo apt-get update
sudo apt-get install python3.6
```
NOTE: As it currently stands python 3.10 is not supported due to how inquirer's requirements are built in terms of blessed (it is using the wrong version)
### Installation
Run the following to install:
```python
pip install trie-nathaniel
```
(back to top)
## Usage
For clean user interface use:
```
triecli ui
```
For direct cli calls use:
```
triecli {option} {arg}
```
where `{option}` is replaced with the type of operation you would like to perform and `{arg}` is added if the option you are calling requires an argument
Possible options include `add`, `delete`, `deleteall`, `search`, `complete`, `view`, and `viewfast`
For `add`, `delete`, `search`, `complete` an additional `arg` parameter is required that includes the value you would like to add to the trie
LIMITATIONS:
The virtual machine this is running on only has 100GB of disk space and 4GB of memory so if the string is too long or the number of operations is too many there are chances that something will fail on the GCP side. Since this is being hosted using their free tier these are some of the limiations included
_For explanations, please refer to the [Documentation](https://trieclient.readthedocs.io/en/latest/index.html)_
(back to top)
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
(back to top)
## Acknowledgments
* [Best README](https://github.com/othneildrew/Best-README-Template)
(back to top)
[contributors-shield]: https://img.shields.io/github/contributors/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[contributors-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[forks-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/network/members
[stars-shield]: https://img.shields.io/github/stars/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[stars-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/stargazers
[issues-shield]: https://img.shields.io/github/issues/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[issues-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/issues
[license-shield]: https://img.shields.io/github/license/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[license-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/nathaniel-thomas-profile
%package -n python3-trie-nathaniel
Summary: Calls commands to the trie server that can modify its state
Provides: python-trie-nathaniel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-trie-nathaniel
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
Table of Contents
-
-
Getting Started
- Usage
- Contributing
- License
### Built With
* [inquirer.py](https://pypi.org/project/inquirer/)
* [click.py](https://pypi.org/project/click/)
(back to top)
## Getting Started
Install the CLI to get started!. Take a look at the Installation section for the command to install.
### Prerequisites
Requires python>=3.6 and pip
```sh
sudo apt-get update
sudo apt-get install python3.6
```
NOTE: As it currently stands python 3.10 is not supported due to how inquirer's requirements are built in terms of blessed (it is using the wrong version)
### Installation
Run the following to install:
```python
pip install trie-nathaniel
```
(back to top)
## Usage
For clean user interface use:
```
triecli ui
```
For direct cli calls use:
```
triecli {option} {arg}
```
where `{option}` is replaced with the type of operation you would like to perform and `{arg}` is added if the option you are calling requires an argument
Possible options include `add`, `delete`, `deleteall`, `search`, `complete`, `view`, and `viewfast`
For `add`, `delete`, `search`, `complete` an additional `arg` parameter is required that includes the value you would like to add to the trie
LIMITATIONS:
The virtual machine this is running on only has 100GB of disk space and 4GB of memory so if the string is too long or the number of operations is too many there are chances that something will fail on the GCP side. Since this is being hosted using their free tier these are some of the limiations included
_For explanations, please refer to the [Documentation](https://trieclient.readthedocs.io/en/latest/index.html)_
(back to top)
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
(back to top)
## Acknowledgments
* [Best README](https://github.com/othneildrew/Best-README-Template)
(back to top)
[contributors-shield]: https://img.shields.io/github/contributors/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[contributors-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[forks-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/network/members
[stars-shield]: https://img.shields.io/github/stars/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[stars-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/stargazers
[issues-shield]: https://img.shields.io/github/issues/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[issues-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/issues
[license-shield]: https://img.shields.io/github/license/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[license-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/nathaniel-thomas-profile
%package help
Summary: Development documents and examples for trie-nathaniel
Provides: python3-trie-nathaniel-doc
%description help
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
Table of Contents
-
-
Getting Started
- Usage
- Contributing
- License
### Built With
* [inquirer.py](https://pypi.org/project/inquirer/)
* [click.py](https://pypi.org/project/click/)
(back to top)
## Getting Started
Install the CLI to get started!. Take a look at the Installation section for the command to install.
### Prerequisites
Requires python>=3.6 and pip
```sh
sudo apt-get update
sudo apt-get install python3.6
```
NOTE: As it currently stands python 3.10 is not supported due to how inquirer's requirements are built in terms of blessed (it is using the wrong version)
### Installation
Run the following to install:
```python
pip install trie-nathaniel
```
(back to top)
## Usage
For clean user interface use:
```
triecli ui
```
For direct cli calls use:
```
triecli {option} {arg}
```
where `{option}` is replaced with the type of operation you would like to perform and `{arg}` is added if the option you are calling requires an argument
Possible options include `add`, `delete`, `deleteall`, `search`, `complete`, `view`, and `viewfast`
For `add`, `delete`, `search`, `complete` an additional `arg` parameter is required that includes the value you would like to add to the trie
LIMITATIONS:
The virtual machine this is running on only has 100GB of disk space and 4GB of memory so if the string is too long or the number of operations is too many there are chances that something will fail on the GCP side. Since this is being hosted using their free tier these are some of the limiations included
_For explanations, please refer to the [Documentation](https://trieclient.readthedocs.io/en/latest/index.html)_
(back to top)
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
(back to top)
## Acknowledgments
* [Best README](https://github.com/othneildrew/Best-README-Template)
(back to top)
[contributors-shield]: https://img.shields.io/github/contributors/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[contributors-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[forks-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/network/members
[stars-shield]: https://img.shields.io/github/stars/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[stars-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/stargazers
[issues-shield]: https://img.shields.io/github/issues/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[issues-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/issues
[license-shield]: https://img.shields.io/github/license/Nathaniel-github/CombinedServerClientRepo.svg?style=for-the-badge
[license-url]: https://github.com/Nathaniel-github/CombinedServerClientRepo/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/nathaniel-thomas-profile
%prep
%autosetup -n trie-nathaniel-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-trie-nathaniel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.0.0-1
- Package Spec generated