%global _empty_manifest_terminate_build 0
Name:		python-bitlyapi
Version:	0.1.1
Release:	1
Summary:	A thin wrapper for the bit.ly REST API
License:	BSD
URL:		http://github.com/hellp/bitlyapi
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2b/71/ae97330c791cb3c08ad479c64ad65fcb749bde5236dbe8ab86f3176d1d30/bitlyapi-0.1.1.tar.gz
BuildArch:	noarch


%description


%package -n python3-bitlyapi
Summary:	A thin wrapper for the bit.ly REST API
Provides:	python-bitlyapi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bitlyapi


%package help
Summary:	Development documents and examples for bitlyapi
Provides:	python3-bitlyapi-doc
%description help


%prep
%autosetup -n bitlyapi-0.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bitlyapi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
- Package Spec generated