%global _empty_manifest_terminate_build 0
Name:		python-ncem
Version:	0.1.4
Release:	1
Summary:	ncem. Learning cell communication from spatial graphs of cells.
License:	BSD
URL:		https://github.com/theislab/ncem
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/83/82/58551b9ed70e51e31907a5fecd604cb89352bf51f777de4093ce3d6714d3/ncem-0.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-Jinja2
Requires:	python3-PyYAML
Requires:	python3-click
Requires:	python3-diffxpy
Requires:	python3-docrep
Requires:	python3-louvain
Requires:	python3-matplotlib
Requires:	python3-patsy
Requires:	python3-rich
Requires:	python3-scanpy
Requires:	python3-scipy
Requires:	python3-seaborn
Requires:	python3-squidpy
Requires:	python3-tensorflow

%description
|PyPI| |Python Version| |License| |Read the Docs| |Build| |pre-commit| |Black|

%package -n python3-ncem
Summary:	ncem. Learning cell communication from spatial graphs of cells.
Provides:	python-ncem
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ncem
|PyPI| |Python Version| |License| |Read the Docs| |Build| |pre-commit| |Black|

%package help
Summary:	Development documents and examples for ncem
Provides:	python3-ncem-doc
%description help
|PyPI| |Python Version| |License| |Read the Docs| |Build| |pre-commit| |Black|

%prep
%autosetup -n ncem-0.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ncem -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
- Package Spec generated