%global _empty_manifest_terminate_build 0
Name:		python-cleverwrap
Version:	0.3.0.2
Release:	1
Summary:	A wrapper for the official cleverbot.com API
License:	MIT
URL:		https://github.com/snoonetIRC/cleverwrap.py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/02/57/ffb3ffc89b23a6704be9db3b58ce410bc58b0371590f15a31afbb34690e3/cleverwrap-0.3.0.2.tar.gz
BuildArch:	noarch


%description
# CleverWrap.py
[![Build Status](https://travis-ci.com/snoonetIRC/cleverwrap.py.svg?branch=master)](https://travis-ci.com/snoonetIRC/cleverwrap.py)
[![codecov](https://codecov.io/gh/snoonetIRC/cleverwrap.py/branch/master/graph/badge.svg)](https://codecov.io/gh/snoonetIRC/cleverwrap.py)

A simple python wrapper class to interact with the official [CleverBot API](http://www.cleverbot.com/api).

This package was created to run on python3

# Installing

You can install cleverwrap.py from pypi using: `pip install cleverwrap`

You can also clone this repository and import the library directly.

# Usage

```
>>> from cleverwrap import CleverWrap
>>> cw = CleverWrap("API_KEY")
>>> cw.say("Hello CleverBot.")
"Hello Human."
>>> cw.reset() # resets the conversation ID and conversation state.
>>> conv = cw.new_conversation()  # Start a new conversation with CleverBot
>>> conv.say("Hellon there.")
"Hello Human."
>>> conv.reset()  # Reset the conversation state
```

# License

Copyright 2017 Andrew Edwards using the [MIT License](http://opensource.org/licenses/MIT).





%package -n python3-cleverwrap
Summary:	A wrapper for the official cleverbot.com API
Provides:	python-cleverwrap
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cleverwrap
# CleverWrap.py
[![Build Status](https://travis-ci.com/snoonetIRC/cleverwrap.py.svg?branch=master)](https://travis-ci.com/snoonetIRC/cleverwrap.py)
[![codecov](https://codecov.io/gh/snoonetIRC/cleverwrap.py/branch/master/graph/badge.svg)](https://codecov.io/gh/snoonetIRC/cleverwrap.py)

A simple python wrapper class to interact with the official [CleverBot API](http://www.cleverbot.com/api).

This package was created to run on python3

# Installing

You can install cleverwrap.py from pypi using: `pip install cleverwrap`

You can also clone this repository and import the library directly.

# Usage

```
>>> from cleverwrap import CleverWrap
>>> cw = CleverWrap("API_KEY")
>>> cw.say("Hello CleverBot.")
"Hello Human."
>>> cw.reset() # resets the conversation ID and conversation state.
>>> conv = cw.new_conversation()  # Start a new conversation with CleverBot
>>> conv.say("Hellon there.")
"Hello Human."
>>> conv.reset()  # Reset the conversation state
```

# License

Copyright 2017 Andrew Edwards using the [MIT License](http://opensource.org/licenses/MIT).





%package help
Summary:	Development documents and examples for cleverwrap
Provides:	python3-cleverwrap-doc
%description help
# CleverWrap.py
[![Build Status](https://travis-ci.com/snoonetIRC/cleverwrap.py.svg?branch=master)](https://travis-ci.com/snoonetIRC/cleverwrap.py)
[![codecov](https://codecov.io/gh/snoonetIRC/cleverwrap.py/branch/master/graph/badge.svg)](https://codecov.io/gh/snoonetIRC/cleverwrap.py)

A simple python wrapper class to interact with the official [CleverBot API](http://www.cleverbot.com/api).

This package was created to run on python3

# Installing

You can install cleverwrap.py from pypi using: `pip install cleverwrap`

You can also clone this repository and import the library directly.

# Usage

```
>>> from cleverwrap import CleverWrap
>>> cw = CleverWrap("API_KEY")
>>> cw.say("Hello CleverBot.")
"Hello Human."
>>> cw.reset() # resets the conversation ID and conversation state.
>>> conv = cw.new_conversation()  # Start a new conversation with CleverBot
>>> conv.say("Hellon there.")
"Hello Human."
>>> conv.reset()  # Reset the conversation state
```

# License

Copyright 2017 Andrew Edwards using the [MIT License](http://opensource.org/licenses/MIT).





%prep
%autosetup -n cleverwrap-0.3.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cleverwrap -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0.2-1
- Package Spec generated