%global _empty_manifest_terminate_build 0
Name: python-diceware
Version: 0.10
Release: 1
Summary: Passphrases you will remember.
License: GPL 3.0
URL: https://github.com/ulif/diceware/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/7b/2ebe60ee2360170d93f1c3f1e4429353c8445992fc2bc501e98013697c71/diceware-0.10.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-coverage
Requires: python3-pytest
%description
Passphrases to remember...
|bdg-tests| | `documentation `_ | `sources `_ | `issues `_
`diceware` is a passphrase generator following the proposals of
Arnold G. Reinhold on http://diceware.com . It generates passphrases
by concatenating words randomly picked from wordlists. For instance::
$ diceware
MyraPend93rdSixthEagleAid
The passphrase contains by default six words (with first char
capitalized) without any separator chars. Optionally you can let
`diceware` insert special chars into the passphrase.
`diceware` supports several sources of randomness (including real life
dice) and different wordlists (including cryptographically signed
ones).
%package -n python3-diceware
Summary: Passphrases you will remember.
Provides: python-diceware
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-diceware
Passphrases to remember...
|bdg-tests| | `documentation `_ | `sources `_ | `issues `_
`diceware` is a passphrase generator following the proposals of
Arnold G. Reinhold on http://diceware.com . It generates passphrases
by concatenating words randomly picked from wordlists. For instance::
$ diceware
MyraPend93rdSixthEagleAid
The passphrase contains by default six words (with first char
capitalized) without any separator chars. Optionally you can let
`diceware` insert special chars into the passphrase.
`diceware` supports several sources of randomness (including real life
dice) and different wordlists (including cryptographically signed
ones).
%package help
Summary: Development documents and examples for diceware
Provides: python3-diceware-doc
%description help
Passphrases to remember...
|bdg-tests| | `documentation `_ | `sources `_ | `issues `_
`diceware` is a passphrase generator following the proposals of
Arnold G. Reinhold on http://diceware.com . It generates passphrases
by concatenating words randomly picked from wordlists. For instance::
$ diceware
MyraPend93rdSixthEagleAid
The passphrase contains by default six words (with first char
capitalized) without any separator chars. Optionally you can let
`diceware` insert special chars into the passphrase.
`diceware` supports several sources of randomness (including real life
dice) and different wordlists (including cryptographically signed
ones).
%prep
%autosetup -n diceware-0.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-diceware -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.10-1
- Package Spec generated