%global _empty_manifest_terminate_build 0
Name:		python-swh.core
Version:	2.22.0
Release:	1
Summary:	Software Heritage core utilities
License:	GNU General Public License v3 (GPLv3)
URL:		https://forge.softwareheritage.org/diffusion/DCORE/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9e/29/79f4a2d0351637cfc64c2cda6923096cb5ca75ef1b93d4d32c6b5182eff5/swh.core-2.22.0.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-deprecated
Requires:	python3-magic
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-sentry-sdk
Requires:	python3-tenacity
Requires:	python3-psycopg2
Requires:	python3-typing-extensions
Requires:	python3-pytest-postgresql
Requires:	python3-requests
Requires:	python3-tenacity
Requires:	python3-aiohttp
Requires:	python3-aiohttp-utils
Requires:	python3-blinker
Requires:	python3-flask
Requires:	python3-iso8601
Requires:	python3-msgpack
Requires:	python3-requests
Requires:	python3-systemd-python
Requires:	python3-hypothesis
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-pytz
Requires:	python3-requests-mock
Requires:	python3-types-click
Requires:	python3-types-flask
Requires:	python3-types-psycopg2
Requires:	python3-types-pytz
Requires:	python3-types-pyyaml
Requires:	python3-types-requests
Requires:	python3-psycopg2
Requires:	python3-typing-extensions
Requires:	python3-pytest-postgresql
Requires:	python3-aiohttp
Requires:	python3-aiohttp-utils
Requires:	python3-blinker
Requires:	python3-flask
Requires:	python3-iso8601
Requires:	python3-msgpack
Requires:	python3-requests
Requires:	python3-systemd-python
Requires:	python3-hypothesis
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-pytz
Requires:	python3-requests-mock
Requires:	python3-types-click
Requires:	python3-types-flask
Requires:	python3-types-psycopg2
Requires:	python3-types-pytz
Requires:	python3-types-pyyaml
Requires:	python3-types-requests

%description
Low-level utilities and helpers used by almost all other modules in the stack.
core library for swh's modules:
- config parser
- serialization
- logging mechanism
- database connection
- http-based RPC client/server

%package -n python3-swh.core
Summary:	Software Heritage core utilities
Provides:	python-swh.core
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-swh.core
Low-level utilities and helpers used by almost all other modules in the stack.
core library for swh's modules:
- config parser
- serialization
- logging mechanism
- database connection
- http-based RPC client/server

%package help
Summary:	Development documents and examples for swh.core
Provides:	python3-swh.core-doc
%description help
Low-level utilities and helpers used by almost all other modules in the stack.
core library for swh's modules:
- config parser
- serialization
- logging mechanism
- database connection
- http-based RPC client/server

%prep
%autosetup -n swh.core-2.22.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-swh.core -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.22.0-1
- Package Spec generated