%global _empty_manifest_terminate_build 0
Name: python-rapunzel
Version: 0.5.43
Release: 1
Summary: Turns OpenSesame into a Python code editor
License: Apache Software License
URL: https://github.com/smathot/rapunzel
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/de/25/9be859d8a3a1367a5d0a236b6977afe82e34d827e720d0efec823d11af7a/rapunzel-0.5.43.tar.gz
BuildArch: noarch
%description
# Rapunzel
A modern code editor, focused on numerical computing with Python and R
Copyright 2019-2022 Sebastiaan Mathôt (@smathot)
## About
Rapunzel is a set of OpenSesame extensions that turn OpenSesame into an integrated development environment.
For documentation and installation instructions, see:
-
OpenSesame is hosted on GitHub:
-
## List of extensions
- `OpenSesameIDE` is the main extension that contains most of the IDE functionality
- `FindInFiles` implements the find-in-files functionality (`Ctrl+Shift+F`)
- `JupyterConsole` implements the Jupyter Console
- `JupyterNotebook` provides export options to Notebook and other formats
- `QuickSelector` provides the general quick-switching framework, which is used by other extensions
- `WorkspaceExplorer` provides the workspace explorer that allows inspection of variables for supported kernels
- `SymbolSelector` provides the jump-to-symbol (functions, classes, etc.) functionality (`Ctrl+R`)
- `RapunzelWelcome` implements the welcome tab that is shown on startup
- `CommandPalette` provides access to all menu options through a quick switcher
- `WordCount` gives a notification with the number of words, lines, and characters of the current document
- `SpellCheck` implements the spell checker
- `DataViewer` allows supported file types to be imported into the kernel as objects
- `GitGUI` opens Git GUI for the current document
- `RapunzelLocale` handles translations
- `PythonDebugger` implements the Rapunzel debugger for Python, based on the IPython debugger
- `SubprocessManager` keeps track of all subprocess that were launched by Rapunzel
- `ImageAnnotations` captures images and text output inserts them as annotations or code comments into the document
## License
The Rapunzel icon is adapted from "Moka Icons" by Sam Hewitt, licensed under CC-SA-4.0.
-
The rest of Rapunzel is distributed under the terms of the GNU General Public License 3. The full license should be included in the file COPYING, or can be obtained from:
-
%package -n python3-rapunzel
Summary: Turns OpenSesame into a Python code editor
Provides: python-rapunzel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rapunzel
# Rapunzel
A modern code editor, focused on numerical computing with Python and R
Copyright 2019-2022 Sebastiaan Mathôt (@smathot)
## About
Rapunzel is a set of OpenSesame extensions that turn OpenSesame into an integrated development environment.
For documentation and installation instructions, see:
-
OpenSesame is hosted on GitHub:
-
## List of extensions
- `OpenSesameIDE` is the main extension that contains most of the IDE functionality
- `FindInFiles` implements the find-in-files functionality (`Ctrl+Shift+F`)
- `JupyterConsole` implements the Jupyter Console
- `JupyterNotebook` provides export options to Notebook and other formats
- `QuickSelector` provides the general quick-switching framework, which is used by other extensions
- `WorkspaceExplorer` provides the workspace explorer that allows inspection of variables for supported kernels
- `SymbolSelector` provides the jump-to-symbol (functions, classes, etc.) functionality (`Ctrl+R`)
- `RapunzelWelcome` implements the welcome tab that is shown on startup
- `CommandPalette` provides access to all menu options through a quick switcher
- `WordCount` gives a notification with the number of words, lines, and characters of the current document
- `SpellCheck` implements the spell checker
- `DataViewer` allows supported file types to be imported into the kernel as objects
- `GitGUI` opens Git GUI for the current document
- `RapunzelLocale` handles translations
- `PythonDebugger` implements the Rapunzel debugger for Python, based on the IPython debugger
- `SubprocessManager` keeps track of all subprocess that were launched by Rapunzel
- `ImageAnnotations` captures images and text output inserts them as annotations or code comments into the document
## License
The Rapunzel icon is adapted from "Moka Icons" by Sam Hewitt, licensed under CC-SA-4.0.
-
The rest of Rapunzel is distributed under the terms of the GNU General Public License 3. The full license should be included in the file COPYING, or can be obtained from:
-
%package help
Summary: Development documents and examples for rapunzel
Provides: python3-rapunzel-doc
%description help
# Rapunzel
A modern code editor, focused on numerical computing with Python and R
Copyright 2019-2022 Sebastiaan Mathôt (@smathot)
## About
Rapunzel is a set of OpenSesame extensions that turn OpenSesame into an integrated development environment.
For documentation and installation instructions, see:
-
OpenSesame is hosted on GitHub:
-
## List of extensions
- `OpenSesameIDE` is the main extension that contains most of the IDE functionality
- `FindInFiles` implements the find-in-files functionality (`Ctrl+Shift+F`)
- `JupyterConsole` implements the Jupyter Console
- `JupyterNotebook` provides export options to Notebook and other formats
- `QuickSelector` provides the general quick-switching framework, which is used by other extensions
- `WorkspaceExplorer` provides the workspace explorer that allows inspection of variables for supported kernels
- `SymbolSelector` provides the jump-to-symbol (functions, classes, etc.) functionality (`Ctrl+R`)
- `RapunzelWelcome` implements the welcome tab that is shown on startup
- `CommandPalette` provides access to all menu options through a quick switcher
- `WordCount` gives a notification with the number of words, lines, and characters of the current document
- `SpellCheck` implements the spell checker
- `DataViewer` allows supported file types to be imported into the kernel as objects
- `GitGUI` opens Git GUI for the current document
- `RapunzelLocale` handles translations
- `PythonDebugger` implements the Rapunzel debugger for Python, based on the IPython debugger
- `SubprocessManager` keeps track of all subprocess that were launched by Rapunzel
- `ImageAnnotations` captures images and text output inserts them as annotations or code comments into the document
## License
The Rapunzel icon is adapted from "Moka Icons" by Sam Hewitt, licensed under CC-SA-4.0.
-
The rest of Rapunzel is distributed under the terms of the GNU General Public License 3. The full license should be included in the file COPYING, or can be obtained from:
-
%prep
%autosetup -n rapunzel-0.5.43
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rapunzel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.5.43-1
- Package Spec generated