%global _empty_manifest_terminate_build 0
Name: python-business_calendar
Version: 0.2.1
Release: 1
Summary: Simple business days, including custom work week and a holiday list.
License: MIT
URL: https://github.com/antoniobotelho/py-business-calendar/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c6/3e/1f169d876cf8b041607934c8915057c86bdc3e80b499fd79118d9cef005b/business_calendar-0.2.1.zip
BuildArch: noarch
%description
**business_calendar** is a Python package that implements simple business days
calculations. You can use a custom work week and a holiday list.
Documentation
^^^^^^^^^^^^^
You can find the latest documentation `here `_.
Example
^^^^^^^
from business_calendar import Calendar, MO, TU, WE, TH, FR
import datetime
date1 = datetime.datetime(2013,1,10)
# normal calendar, no holidays
cal = Calendar()
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# don't work on Fridays? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# holiday? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH], holidays=['2013-01-17'])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2)
License
^^^^^^^
MIT
%package -n python3-business_calendar
Summary: Simple business days, including custom work week and a holiday list.
Provides: python-business_calendar
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-business_calendar
**business_calendar** is a Python package that implements simple business days
calculations. You can use a custom work week and a holiday list.
Documentation
^^^^^^^^^^^^^
You can find the latest documentation `here `_.
Example
^^^^^^^
from business_calendar import Calendar, MO, TU, WE, TH, FR
import datetime
date1 = datetime.datetime(2013,1,10)
# normal calendar, no holidays
cal = Calendar()
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# don't work on Fridays? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# holiday? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH], holidays=['2013-01-17'])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2)
License
^^^^^^^
MIT
%package help
Summary: Development documents and examples for business_calendar
Provides: python3-business_calendar-doc
%description help
**business_calendar** is a Python package that implements simple business days
calculations. You can use a custom work week and a holiday list.
Documentation
^^^^^^^^^^^^^
You can find the latest documentation `here `_.
Example
^^^^^^^
from business_calendar import Calendar, MO, TU, WE, TH, FR
import datetime
date1 = datetime.datetime(2013,1,10)
# normal calendar, no holidays
cal = Calendar()
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# don't work on Fridays? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2))
# holiday? no problem!
cal = Calendar(workdays=[MO,TU,WE,TH], holidays=['2013-01-17'])
date2 = cal.addbusdays(date1, 25)
print('%s days between %s and %s' % \
(cal.busdaycount(date1, date2), date1, date2)
License
^^^^^^^
MIT
%prep
%autosetup -n business_calendar-0.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-business_calendar -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.2.1-1
- Package Spec generated