%global _empty_manifest_terminate_build 0
Name: python-doorstop
Version: 2.2.post1
Release: 1
Summary: Requirements management using version control.
License: LGPLv3
URL: https://pypi.org/project/Doorstop
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/06/d9/5c4128738516c3948821c7cfcc5fa5e76d115def521d245c3f7d682102b2/doorstop-2.2.post1.tar.gz
BuildArch: noarch
Requires: python3-PyYAML
Requires: python3-Markdown
Requires: python3-bottle
Requires: python3-requests
Requires: python3-markdown-math
Requires: python3-plantuml-markdown
Requires: python3-six
Requires: python3-openpyxl
%description
[![Unix Build Status](https://img.shields.io/travis/com/doorstop-dev/doorstop/develop.svg?label=unix)](https://travis-ci.com/doorstop-dev/doorstop)
[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/doorstop/develop.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/doorstop)
[![Coverage Status](http://img.shields.io/coveralls/doorstop-dev/doorstop/develop.svg)](https://coveralls.io/r/doorstop-dev/doorstop)
[![Scrutinizer Code Quality](http://img.shields.io/scrutinizer/g/doorstop-dev/doorstop.svg)](https://scrutinizer-ci.com/g/doorstop-dev/doorstop/?branch=develop)
[![PyPI Version](http://img.shields.io/pypi/v/Doorstop.svg)](https://pypi.org/project/Doorstop)
[![Gitter](https://badges.gitter.im/doorstop-dev/community.svg)](https://gitter.im/doorstop-dev/community)
[![Google](https://img.shields.io/badge/forum-on_google-387eef)](https://groups.google.com/forum/#!forum/doorstop-dev)
[![Best Practices](https://bestpractices.coreinfrastructure.org/projects/754/badge)](https://bestpractices.coreinfrastructure.org/projects/754)
# Overview
Doorstop is a [requirements management](http://alternativeto.net/software/doorstop/) tool that facilitates the storage of textual requirements alongside source code in version control.
When a project leverages this tool, each linkable item (requirement, test case, etc.) is stored as a YAML file in a designated directory. The items in each directory form a document. The relationship between documents forms a tree hierarchy. Doorstop provides mechanisms for modifying this tree, validating item traceability, and publishing documents in several formats.
Doorstop is under active development and we welcome contributions.
The project is licensed as [LGPLv3](https://github.com/doorstop-dev/doorstop/blob/develop/LICENSE.md).
To report a problem or a security vulnerability please [raise an issue](https://github.com/doorstop-dev/doorstop/issues).
Additional references:
- publication: [JSEA Paper](http://www.scirp.org/journal/PaperInformation.aspx?PaperID=44268#.UzYtfWRdXEZ)
- talks: [GRDevDay](https://speakerdeck.com/jacebrowning/doorstop-requirements-management-using-python-and-version-control), [BarCamp](https://speakerdeck.com/jacebrowning/strip-searched-a-rough-introduction-to-requirements-management)
- sample: [Generated HTML](http://doorstop-dev.github.io/doorstop/)
# Setup
## Requirements
* Python 3.5+
* A version control system for requirements storage
## Installation
Install Doorstop with pip:
```sh
$ pip install doorstop
```
or add it to your [Poetry](https://poetry.eustace.io/) project:
```sh
$ poetry add doorstop
```
After installation, Doorstop is available on the command-line:
```sh
$ doorstop --help
```
And the package is available under the name 'doorstop':
```sh
$ python
>>> import doorstop
>>> doorstop.__version__
```
# Usage
Switch to an existing version control working directory, or create one:
```sh
$ git init .
```
## Create documents
Create a new parent requirements document:
```sh
$ doorstop create SRD ./reqs/srd
```
Add a few items to that document:
```sh
$ doorstop add SRD
$ doorstop add SRD
$ doorstop add SRD
```
## Link items
Create a child document to link to the parent:
```sh
$ doorstop create HLTC ./tests/hl --parent SRD
$ doorstop add HLTC
```
Link items between documents:
```sh
$ doorstop link HLTC001 SRD002
```
## Publish reports
Run integrity checks on the document tree:
```sh
$ doorstop
```
Publish the documents as HTML:
```sh
$ doorstop publish all ./public
```
%package -n python3-doorstop
Summary: Requirements management using version control.
Provides: python-doorstop
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-doorstop
[![Unix Build Status](https://img.shields.io/travis/com/doorstop-dev/doorstop/develop.svg?label=unix)](https://travis-ci.com/doorstop-dev/doorstop)
[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/doorstop/develop.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/doorstop)
[![Coverage Status](http://img.shields.io/coveralls/doorstop-dev/doorstop/develop.svg)](https://coveralls.io/r/doorstop-dev/doorstop)
[![Scrutinizer Code Quality](http://img.shields.io/scrutinizer/g/doorstop-dev/doorstop.svg)](https://scrutinizer-ci.com/g/doorstop-dev/doorstop/?branch=develop)
[![PyPI Version](http://img.shields.io/pypi/v/Doorstop.svg)](https://pypi.org/project/Doorstop)
[![Gitter](https://badges.gitter.im/doorstop-dev/community.svg)](https://gitter.im/doorstop-dev/community)
[![Google](https://img.shields.io/badge/forum-on_google-387eef)](https://groups.google.com/forum/#!forum/doorstop-dev)
[![Best Practices](https://bestpractices.coreinfrastructure.org/projects/754/badge)](https://bestpractices.coreinfrastructure.org/projects/754)
# Overview
Doorstop is a [requirements management](http://alternativeto.net/software/doorstop/) tool that facilitates the storage of textual requirements alongside source code in version control.
When a project leverages this tool, each linkable item (requirement, test case, etc.) is stored as a YAML file in a designated directory. The items in each directory form a document. The relationship between documents forms a tree hierarchy. Doorstop provides mechanisms for modifying this tree, validating item traceability, and publishing documents in several formats.
Doorstop is under active development and we welcome contributions.
The project is licensed as [LGPLv3](https://github.com/doorstop-dev/doorstop/blob/develop/LICENSE.md).
To report a problem or a security vulnerability please [raise an issue](https://github.com/doorstop-dev/doorstop/issues).
Additional references:
- publication: [JSEA Paper](http://www.scirp.org/journal/PaperInformation.aspx?PaperID=44268#.UzYtfWRdXEZ)
- talks: [GRDevDay](https://speakerdeck.com/jacebrowning/doorstop-requirements-management-using-python-and-version-control), [BarCamp](https://speakerdeck.com/jacebrowning/strip-searched-a-rough-introduction-to-requirements-management)
- sample: [Generated HTML](http://doorstop-dev.github.io/doorstop/)
# Setup
## Requirements
* Python 3.5+
* A version control system for requirements storage
## Installation
Install Doorstop with pip:
```sh
$ pip install doorstop
```
or add it to your [Poetry](https://poetry.eustace.io/) project:
```sh
$ poetry add doorstop
```
After installation, Doorstop is available on the command-line:
```sh
$ doorstop --help
```
And the package is available under the name 'doorstop':
```sh
$ python
>>> import doorstop
>>> doorstop.__version__
```
# Usage
Switch to an existing version control working directory, or create one:
```sh
$ git init .
```
## Create documents
Create a new parent requirements document:
```sh
$ doorstop create SRD ./reqs/srd
```
Add a few items to that document:
```sh
$ doorstop add SRD
$ doorstop add SRD
$ doorstop add SRD
```
## Link items
Create a child document to link to the parent:
```sh
$ doorstop create HLTC ./tests/hl --parent SRD
$ doorstop add HLTC
```
Link items between documents:
```sh
$ doorstop link HLTC001 SRD002
```
## Publish reports
Run integrity checks on the document tree:
```sh
$ doorstop
```
Publish the documents as HTML:
```sh
$ doorstop publish all ./public
```
%package help
Summary: Development documents and examples for doorstop
Provides: python3-doorstop-doc
%description help
[![Unix Build Status](https://img.shields.io/travis/com/doorstop-dev/doorstop/develop.svg?label=unix)](https://travis-ci.com/doorstop-dev/doorstop)
[![Windows Build Status](https://img.shields.io/appveyor/ci/jacebrowning/doorstop/develop.svg?label=windows)](https://ci.appveyor.com/project/jacebrowning/doorstop)
[![Coverage Status](http://img.shields.io/coveralls/doorstop-dev/doorstop/develop.svg)](https://coveralls.io/r/doorstop-dev/doorstop)
[![Scrutinizer Code Quality](http://img.shields.io/scrutinizer/g/doorstop-dev/doorstop.svg)](https://scrutinizer-ci.com/g/doorstop-dev/doorstop/?branch=develop)
[![PyPI Version](http://img.shields.io/pypi/v/Doorstop.svg)](https://pypi.org/project/Doorstop)
[![Gitter](https://badges.gitter.im/doorstop-dev/community.svg)](https://gitter.im/doorstop-dev/community)
[![Google](https://img.shields.io/badge/forum-on_google-387eef)](https://groups.google.com/forum/#!forum/doorstop-dev)
[![Best Practices](https://bestpractices.coreinfrastructure.org/projects/754/badge)](https://bestpractices.coreinfrastructure.org/projects/754)
# Overview
Doorstop is a [requirements management](http://alternativeto.net/software/doorstop/) tool that facilitates the storage of textual requirements alongside source code in version control.
When a project leverages this tool, each linkable item (requirement, test case, etc.) is stored as a YAML file in a designated directory. The items in each directory form a document. The relationship between documents forms a tree hierarchy. Doorstop provides mechanisms for modifying this tree, validating item traceability, and publishing documents in several formats.
Doorstop is under active development and we welcome contributions.
The project is licensed as [LGPLv3](https://github.com/doorstop-dev/doorstop/blob/develop/LICENSE.md).
To report a problem or a security vulnerability please [raise an issue](https://github.com/doorstop-dev/doorstop/issues).
Additional references:
- publication: [JSEA Paper](http://www.scirp.org/journal/PaperInformation.aspx?PaperID=44268#.UzYtfWRdXEZ)
- talks: [GRDevDay](https://speakerdeck.com/jacebrowning/doorstop-requirements-management-using-python-and-version-control), [BarCamp](https://speakerdeck.com/jacebrowning/strip-searched-a-rough-introduction-to-requirements-management)
- sample: [Generated HTML](http://doorstop-dev.github.io/doorstop/)
# Setup
## Requirements
* Python 3.5+
* A version control system for requirements storage
## Installation
Install Doorstop with pip:
```sh
$ pip install doorstop
```
or add it to your [Poetry](https://poetry.eustace.io/) project:
```sh
$ poetry add doorstop
```
After installation, Doorstop is available on the command-line:
```sh
$ doorstop --help
```
And the package is available under the name 'doorstop':
```sh
$ python
>>> import doorstop
>>> doorstop.__version__
```
# Usage
Switch to an existing version control working directory, or create one:
```sh
$ git init .
```
## Create documents
Create a new parent requirements document:
```sh
$ doorstop create SRD ./reqs/srd
```
Add a few items to that document:
```sh
$ doorstop add SRD
$ doorstop add SRD
$ doorstop add SRD
```
## Link items
Create a child document to link to the parent:
```sh
$ doorstop create HLTC ./tests/hl --parent SRD
$ doorstop add HLTC
```
Link items between documents:
```sh
$ doorstop link HLTC001 SRD002
```
## Publish reports
Run integrity checks on the document tree:
```sh
$ doorstop
```
Publish the documents as HTML:
```sh
$ doorstop publish all ./public
```
%prep
%autosetup -n doorstop-2.2.post1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-doorstop -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 2.2.post1-1
- Package Spec generated