%global _empty_manifest_terminate_build 0
Name:		python-EasyFileHandling
Version:	1.5.2
Release:	1
Summary:	A simple and useful package for File Handling
License:	MIT License
URL:		https://github.com/ProjectsWithPython/FileHandling
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/76/18/fc0c58c01ed54470f9abcc8e6074210f69a779bd93248968ee33a210791f/EasyFileHandling-1.5.2.tar.gz
BuildArch:	noarch

Requires:	python3-Pillow

%description
### Package for File Handling

**[DOCUMENTATION]**(https://filehandling.netlify.app/docs.html)


**Getting started**
```py
from EasyFileHandling.main import FileHandler

x = FileHandler('test.py', 'py')

print(x.get_file_content()) # This will print file content.

```
**Whats so special about package**


*It lets to handle files easliy, whether is JSON, a image, text file and etc.*


**BETA**

*Howdy all, we have decided to add `AsyncFileHandler` for asynchronous python codes. Now you can do all those `append`, `write` and  `read` asynchronouly.* ***REMEMBER THIS IS A BETA***


*How do I use it?*


*Simply import this and get started.*


```py
from EasyFileHandling.beta.main import AsyncFileHandler
```


**Whats New?**

*Howdy, new version `1.4.0` just dropped. You all be thinking whats new `byte` and `json` support added. We have also added `type` hints. Let me show you a example how json handler works*


**ImageHandler**


```py
from EasyFileHandling.imagehandler import ImageHandler
x = ImageHandler('nice.jpg')
x.filter_image('blur') # it will make a imagehandlerimages folder with this file in it.
x.draw_text(100, 50, "Hello World",50, rgb=(0, 0, 0), font="arial.ttf") # rgb and font are default params.
```


*If you are having any issues let us know [Here](https://github.com/ProjectsWithPython/FileHandling/issues).*







%package -n python3-EasyFileHandling
Summary:	A simple and useful package for File Handling
Provides:	python-EasyFileHandling
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-EasyFileHandling
### Package for File Handling

**[DOCUMENTATION]**(https://filehandling.netlify.app/docs.html)


**Getting started**
```py
from EasyFileHandling.main import FileHandler

x = FileHandler('test.py', 'py')

print(x.get_file_content()) # This will print file content.

```
**Whats so special about package**


*It lets to handle files easliy, whether is JSON, a image, text file and etc.*


**BETA**

*Howdy all, we have decided to add `AsyncFileHandler` for asynchronous python codes. Now you can do all those `append`, `write` and  `read` asynchronouly.* ***REMEMBER THIS IS A BETA***


*How do I use it?*


*Simply import this and get started.*


```py
from EasyFileHandling.beta.main import AsyncFileHandler
```


**Whats New?**

*Howdy, new version `1.4.0` just dropped. You all be thinking whats new `byte` and `json` support added. We have also added `type` hints. Let me show you a example how json handler works*


**ImageHandler**


```py
from EasyFileHandling.imagehandler import ImageHandler
x = ImageHandler('nice.jpg')
x.filter_image('blur') # it will make a imagehandlerimages folder with this file in it.
x.draw_text(100, 50, "Hello World",50, rgb=(0, 0, 0), font="arial.ttf") # rgb and font are default params.
```


*If you are having any issues let us know [Here](https://github.com/ProjectsWithPython/FileHandling/issues).*







%package help
Summary:	Development documents and examples for EasyFileHandling
Provides:	python3-EasyFileHandling-doc
%description help
### Package for File Handling

**[DOCUMENTATION]**(https://filehandling.netlify.app/docs.html)


**Getting started**
```py
from EasyFileHandling.main import FileHandler

x = FileHandler('test.py', 'py')

print(x.get_file_content()) # This will print file content.

```
**Whats so special about package**


*It lets to handle files easliy, whether is JSON, a image, text file and etc.*


**BETA**

*Howdy all, we have decided to add `AsyncFileHandler` for asynchronous python codes. Now you can do all those `append`, `write` and  `read` asynchronouly.* ***REMEMBER THIS IS A BETA***


*How do I use it?*


*Simply import this and get started.*


```py
from EasyFileHandling.beta.main import AsyncFileHandler
```


**Whats New?**

*Howdy, new version `1.4.0` just dropped. You all be thinking whats new `byte` and `json` support added. We have also added `type` hints. Let me show you a example how json handler works*


**ImageHandler**


```py
from EasyFileHandling.imagehandler import ImageHandler
x = ImageHandler('nice.jpg')
x.filter_image('blur') # it will make a imagehandlerimages folder with this file in it.
x.draw_text(100, 50, "Hello World",50, rgb=(0, 0, 0), font="arial.ttf") # rgb and font are default params.
```


*If you are having any issues let us know [Here](https://github.com/ProjectsWithPython/FileHandling/issues).*







%prep
%autosetup -n EasyFileHandling-1.5.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-EasyFileHandling -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.2-1
- Package Spec generated