%global _empty_manifest_terminate_build 0
Name:		python-balena-sdk
Version:	12.6.23
Release:	1
Summary:	please add a summary manually as the author left a blank one
License:	Apache-2.0
URL:		https://pypi.org/project/balena-sdk/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/17/d9/a9cc5268559765b8a911e00f70dae8978d6f62f10ec9d1c7c7ac2ec9bd03/balena_sdk-12.6.23.tar.gz
BuildArch:	noarch

Requires:	python3-PyJWT
Requires:	python3-requests
Requires:	python3-pyotp
Requires:	python3-pyOpenSSL
Requires:	python3-Twisted
Requires:	python3-service-identity
Requires:	python3-semver

%description
The official [balena](https://balena.io/) SDK for python.

%package -n python3-balena-sdk
Summary:	please add a summary manually as the author left a blank one
Provides:	python-balena-sdk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-balena-sdk
The official [balena](https://balena.io/) SDK for python.

%package help
Summary:	Development documents and examples for balena-sdk
Provides:	python3-balena-sdk-doc
%description help
The official [balena](https://balena.io/) SDK for python.

%prep
%autosetup -n balena-sdk-12.6.23

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-balena-sdk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 12.6.23-1
- Package Spec generated