%global _empty_manifest_terminate_build 0
Name: python-blackbelt
Version: 0.16.0
Release: 1
Summary: Project automation the Apiary way
License: MIT
URL: http://github.com/apiaryio/black-belt
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/8b/6145401c0b1e4c30415f3126c440a956348fb37c0cee59f8c426947925e9/blackbelt-0.16.0.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-click
Requires: python3-requests
Requires: python3-PyGithub
Requires: python3-slacker
Requires: python3-pyopenssl
Requires: python3-ndg-httpsclient
Requires: python3-pyasn1
Requires: python3-twine
%description
Integrates useful GitHub workflow with Trello, Hipchat and Circle CI.
Please visit `the Black Belt documentation `_ for more details.
%package -n python3-blackbelt
Summary: Project automation the Apiary way
Provides: python-blackbelt
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-blackbelt
Integrates useful GitHub workflow with Trello, Hipchat and Circle CI.
Please visit `the Black Belt documentation `_ for more details.
%package help
Summary: Development documents and examples for blackbelt
Provides: python3-blackbelt-doc
%description help
Integrates useful GitHub workflow with Trello, Hipchat and Circle CI.
Please visit `the Black Belt documentation `_ for more details.
%prep
%autosetup -n blackbelt-0.16.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-blackbelt -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.16.0-1
- Package Spec generated