%global _empty_manifest_terminate_build 0
Name: python-WorldWeatherPy
Version: 0.0.3
Release: 1
Summary: A Python library which acts as a wrapper for the WorldWeatherOnline API.
License: MIT License
URL: https://github.com/David-Woroniuk/Weather-API
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/12/4e/f55a6341c98eb30f2255fef1197ee9beff61205cd9c617df96788a7633bb/WorldWeatherPy-0.0.3.tar.gz
BuildArch: noarch
Requires: python3-pandas
Requires: python3-requests
%description
# WorldWeatherPy
A Python library for the retrieval of historical weather data.
This library scrapes [WorldWeatherOnline.com][website] to collect historical weather data, returning a Pandas DataFrame.
The DetermineListOfAttributes class returns all weather attributes available for retrieval through the [WorldWeatherOnline.com][website] API, whilst the HistoricalLocationWeather class retrieves an array of typically required weather attributes. The RetrieveByAttribute class can be used to request specific weather attributes, or a list of specific weather attributes, as available through the DetermineListOfAttributes class.
## Installation
From Python:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
from WorldWeatherPy import HistoricalLocationWeather
from WorldWeatherPy import RetrieveByAttribute
```
## Usage
#### If you are unsure of the available weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
attributes = DetermineListOfAttributes(api_key, True).retrieve_list_of_options()
```
Returns a list containing all available weather attributes. If 'verbose' is set to True, this will be printed within the function call.
#### If you would like to retrieve standard weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import HistoricalLocationWeather
dataset = HistoricalLocationWeather(api_key, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains an array of weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
#### If you would like to retrieve specific weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import RetrieveByAttribute
dataset = RetrieveByAttribute(api_key, attribute_list, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains a list of pre-specified weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
## Input Arguments
| Argument | Description |
| ------ | --------- |
| api_key | the API key obtained from [https://www.worldweatheronline.com/developer/][API KEY]. (str) |
| attribute_list | a list of weather attributes to collect. (list) |
| city | a city for which to retrieve data. (str). |
| start_date | a string in the format YYYY-MM-DD (str). |
| end_date | a string in the format YYYY-MM-DD (str). |
| frequency | the frequency of extracted data, measured in hours. (int) |
| verbose | boolean determining printing during data extraction. (bool) [Default = True] |
| csv_directory | an optional file directory to store the output. (os directory) [Default = None] |
[website]:
[API KEY]:
%package -n python3-WorldWeatherPy
Summary: A Python library which acts as a wrapper for the WorldWeatherOnline API.
Provides: python-WorldWeatherPy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-WorldWeatherPy
# WorldWeatherPy
A Python library for the retrieval of historical weather data.
This library scrapes [WorldWeatherOnline.com][website] to collect historical weather data, returning a Pandas DataFrame.
The DetermineListOfAttributes class returns all weather attributes available for retrieval through the [WorldWeatherOnline.com][website] API, whilst the HistoricalLocationWeather class retrieves an array of typically required weather attributes. The RetrieveByAttribute class can be used to request specific weather attributes, or a list of specific weather attributes, as available through the DetermineListOfAttributes class.
## Installation
From Python:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
from WorldWeatherPy import HistoricalLocationWeather
from WorldWeatherPy import RetrieveByAttribute
```
## Usage
#### If you are unsure of the available weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
attributes = DetermineListOfAttributes(api_key, True).retrieve_list_of_options()
```
Returns a list containing all available weather attributes. If 'verbose' is set to True, this will be printed within the function call.
#### If you would like to retrieve standard weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import HistoricalLocationWeather
dataset = HistoricalLocationWeather(api_key, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains an array of weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
#### If you would like to retrieve specific weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import RetrieveByAttribute
dataset = RetrieveByAttribute(api_key, attribute_list, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains a list of pre-specified weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
## Input Arguments
| Argument | Description |
| ------ | --------- |
| api_key | the API key obtained from [https://www.worldweatheronline.com/developer/][API KEY]. (str) |
| attribute_list | a list of weather attributes to collect. (list) |
| city | a city for which to retrieve data. (str). |
| start_date | a string in the format YYYY-MM-DD (str). |
| end_date | a string in the format YYYY-MM-DD (str). |
| frequency | the frequency of extracted data, measured in hours. (int) |
| verbose | boolean determining printing during data extraction. (bool) [Default = True] |
| csv_directory | an optional file directory to store the output. (os directory) [Default = None] |
[website]:
[API KEY]:
%package help
Summary: Development documents and examples for WorldWeatherPy
Provides: python3-WorldWeatherPy-doc
%description help
# WorldWeatherPy
A Python library for the retrieval of historical weather data.
This library scrapes [WorldWeatherOnline.com][website] to collect historical weather data, returning a Pandas DataFrame.
The DetermineListOfAttributes class returns all weather attributes available for retrieval through the [WorldWeatherOnline.com][website] API, whilst the HistoricalLocationWeather class retrieves an array of typically required weather attributes. The RetrieveByAttribute class can be used to request specific weather attributes, or a list of specific weather attributes, as available through the DetermineListOfAttributes class.
## Installation
From Python:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
from WorldWeatherPy import HistoricalLocationWeather
from WorldWeatherPy import RetrieveByAttribute
```
## Usage
#### If you are unsure of the available weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import DetermineListOfAttributes
attributes = DetermineListOfAttributes(api_key, True).retrieve_list_of_options()
```
Returns a list containing all available weather attributes. If 'verbose' is set to True, this will be printed within the function call.
#### If you would like to retrieve standard weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import HistoricalLocationWeather
dataset = HistoricalLocationWeather(api_key, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains an array of weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
#### If you would like to retrieve specific weather attributes:
```python
pip install WorldWeatherPy
from WorldWeatherPy import RetrieveByAttribute
dataset = RetrieveByAttribute(api_key, attribute_list, city, start_date, end_date, frequency).retrieve_hist_data()
```
Returns a Pandas DataFrame 'dataset', which contains a list of pre-specified weather attributes for the given city, between the start and end dates specified, with hourly frequency, indexed by date and time.
## Input Arguments
| Argument | Description |
| ------ | --------- |
| api_key | the API key obtained from [https://www.worldweatheronline.com/developer/][API KEY]. (str) |
| attribute_list | a list of weather attributes to collect. (list) |
| city | a city for which to retrieve data. (str). |
| start_date | a string in the format YYYY-MM-DD (str). |
| end_date | a string in the format YYYY-MM-DD (str). |
| frequency | the frequency of extracted data, measured in hours. (int) |
| verbose | boolean determining printing during data extraction. (bool) [Default = True] |
| csv_directory | an optional file directory to store the output. (os directory) [Default = None] |
[website]:
[API KEY]:
%prep
%autosetup -n WorldWeatherPy-0.0.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-WorldWeatherPy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.0.3-1
- Package Spec generated