%global _empty_manifest_terminate_build 0
Name:		python-yamlfmt
Version:	1.1.1
Release:	1
Summary:	An opinionated yaml formatter based on ruamel.yaml
License:	GPLV3
URL:		https://github.com/mmlb/yamlfmt
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/93/eb/338ba863682a00f1ce89e8160354ce61b403c1e5f538e009baea62f2b53c/yamlfmt-1.1.1.tar.gz
BuildArch:	noarch


%description
# yamlfmt

A simple opionated yaml formatter that keeps your comments!

That is no longer maintained!
Checkout out [yamlfix](https://github.com/lyz-code/yamlfix) for a possible alternative.
I myself just use [prettier](https://github.com/prettier/prettier)


%package -n python3-yamlfmt
Summary:	An opinionated yaml formatter based on ruamel.yaml
Provides:	python-yamlfmt
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-yamlfmt
# yamlfmt

A simple opionated yaml formatter that keeps your comments!

That is no longer maintained!
Checkout out [yamlfix](https://github.com/lyz-code/yamlfix) for a possible alternative.
I myself just use [prettier](https://github.com/prettier/prettier)


%package help
Summary:	Development documents and examples for yamlfmt
Provides:	python3-yamlfmt-doc
%description help
# yamlfmt

A simple opionated yaml formatter that keeps your comments!

That is no longer maintained!
Checkout out [yamlfix](https://github.com/lyz-code/yamlfix) for a possible alternative.
I myself just use [prettier](https://github.com/prettier/prettier)


%prep
%autosetup -n yamlfmt-1.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-yamlfmt -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
- Package Spec generated