%global _empty_manifest_terminate_build 0
Name: python-pygti
Version: 0.9.4
Release: 1
Summary: access public transport information in hamburg, germany.
License: Apache-2.0
URL: https://github.com/vigonotion/pygti
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/e9/3f11bff4bb9b48be80d65868edc0c1d5461c13b8234d42e8368090a65ec6/pygti-0.9.4.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-voluptuous
Requires: python3-pytz
%description
HVV Geofox Python Library
## About
This library is a python wrapper for accessing the geofox api. This api is used to get information about the public transport in Hamburg, Germany.
## How to get the api credentials
You have to apply for credentials via the HVV website. You can see their official guide [here](https://www.hvv.de/de/fahrplaene/abruf-fahrplaninfos/datenabruf) (the page is only available in German).
They will send you a contract you will have to sign and send back. After about a week, you will receive your api credentials.
## Documentation
This library uses the same data types and parameters as specified in the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp). It features client side validation of the parameters.
## Installation
Install the [package from pypi](https://pypi.org/project/pygti/).
```python
pip install pygti
```
## Usage
See the examples on how to use the library at [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py), and see the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp) for in-depth explanation of parameters.
There is also a [Glitch example](https://pygti-examples.glitch.me/) available. Try it out and if you want to see how it's done, just [remix the app](https://glitch.com/edit/#!/pygti-examples).
A minimal working example is shown below:
```python
from pygti.gti import GTI, Auth
import asyncio
import aiohttp
GTI_USER = "" # your api username
GTI_PASS = "" # your api password
async def main():
async with aiohttp.ClientSession() as session:
auth = Auth(session, GTI_USER, GTI_PASS)
gti = GTI(auth)
ir = await gti.init()
# see the examples.py file for more functionality and use of the payloads
asyncio.run(main())
```
> :exclamation: **If using Python 3.8**: Version 3.6.2 of aiohttp uses a different EventLoopPolicy so running this MWE will currently result in an error displayed in the console! It should not affect the functionality. This should be fixed with a newer version of aiohttp. For a workaround look into the [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py) file. For more information see this [Issue](https://github.com/aio-libs/aiohttp/issues/4324).
## Progress
- [x] 1. init
- [x] 2. checkName
- [x] 3. getRoute
- [x] 4. departureList
- [x] 5. getTariff
- [x] 6. departureCourse
- [x] 7. listStations
- [x] 8. listLines
- [x] 9. getAnnouncements
- [x] 10. getIndividualRoute
- [x] 11a. getVehicleMap
- [x] 11b. getTrackCoordinates
- [x] 12. checkPostalCode
- [x] 13. getStationInformation
- [x] 14. tariffZoneNeighbours
- [x] 15. tariffMetaData
- [x] 16. singleTicketOptimizer
- [x] 17. ticketList
## Developing
Some files in this project are generated based on the WADL and XSD schema files from GTI.
To generate them, install the dev dependencies and run the script:
```sh
pip install -r requirements_dev.txt
python script/generate.py
```
## Contributions are welcome!
If you want to contribute to this, please read the [Contribution guidelines](CONTRIBUTING.md)
%package -n python3-pygti
Summary: access public transport information in hamburg, germany.
Provides: python-pygti
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pygti
HVV Geofox Python Library
## About
This library is a python wrapper for accessing the geofox api. This api is used to get information about the public transport in Hamburg, Germany.
## How to get the api credentials
You have to apply for credentials via the HVV website. You can see their official guide [here](https://www.hvv.de/de/fahrplaene/abruf-fahrplaninfos/datenabruf) (the page is only available in German).
They will send you a contract you will have to sign and send back. After about a week, you will receive your api credentials.
## Documentation
This library uses the same data types and parameters as specified in the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp). It features client side validation of the parameters.
## Installation
Install the [package from pypi](https://pypi.org/project/pygti/).
```python
pip install pygti
```
## Usage
See the examples on how to use the library at [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py), and see the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp) for in-depth explanation of parameters.
There is also a [Glitch example](https://pygti-examples.glitch.me/) available. Try it out and if you want to see how it's done, just [remix the app](https://glitch.com/edit/#!/pygti-examples).
A minimal working example is shown below:
```python
from pygti.gti import GTI, Auth
import asyncio
import aiohttp
GTI_USER = "" # your api username
GTI_PASS = "" # your api password
async def main():
async with aiohttp.ClientSession() as session:
auth = Auth(session, GTI_USER, GTI_PASS)
gti = GTI(auth)
ir = await gti.init()
# see the examples.py file for more functionality and use of the payloads
asyncio.run(main())
```
> :exclamation: **If using Python 3.8**: Version 3.6.2 of aiohttp uses a different EventLoopPolicy so running this MWE will currently result in an error displayed in the console! It should not affect the functionality. This should be fixed with a newer version of aiohttp. For a workaround look into the [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py) file. For more information see this [Issue](https://github.com/aio-libs/aiohttp/issues/4324).
## Progress
- [x] 1. init
- [x] 2. checkName
- [x] 3. getRoute
- [x] 4. departureList
- [x] 5. getTariff
- [x] 6. departureCourse
- [x] 7. listStations
- [x] 8. listLines
- [x] 9. getAnnouncements
- [x] 10. getIndividualRoute
- [x] 11a. getVehicleMap
- [x] 11b. getTrackCoordinates
- [x] 12. checkPostalCode
- [x] 13. getStationInformation
- [x] 14. tariffZoneNeighbours
- [x] 15. tariffMetaData
- [x] 16. singleTicketOptimizer
- [x] 17. ticketList
## Developing
Some files in this project are generated based on the WADL and XSD schema files from GTI.
To generate them, install the dev dependencies and run the script:
```sh
pip install -r requirements_dev.txt
python script/generate.py
```
## Contributions are welcome!
If you want to contribute to this, please read the [Contribution guidelines](CONTRIBUTING.md)
%package help
Summary: Development documents and examples for pygti
Provides: python3-pygti-doc
%description help
HVV Geofox Python Library
## About
This library is a python wrapper for accessing the geofox api. This api is used to get information about the public transport in Hamburg, Germany.
## How to get the api credentials
You have to apply for credentials via the HVV website. You can see their official guide [here](https://www.hvv.de/de/fahrplaene/abruf-fahrplaninfos/datenabruf) (the page is only available in German).
They will send you a contract you will have to sign and send back. After about a week, you will receive your api credentials.
## Documentation
This library uses the same data types and parameters as specified in the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp). It features client side validation of the parameters.
## Installation
Install the [package from pypi](https://pypi.org/project/pygti/).
```python
pip install pygti
```
## Usage
See the examples on how to use the library at [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py), and see the [GTI documentation](https://api-test.geofox.de/gti/doc/index.jsp) for in-depth explanation of parameters.
There is also a [Glitch example](https://pygti-examples.glitch.me/) available. Try it out and if you want to see how it's done, just [remix the app](https://glitch.com/edit/#!/pygti-examples).
A minimal working example is shown below:
```python
from pygti.gti import GTI, Auth
import asyncio
import aiohttp
GTI_USER = "" # your api username
GTI_PASS = "" # your api password
async def main():
async with aiohttp.ClientSession() as session:
auth = Auth(session, GTI_USER, GTI_PASS)
gti = GTI(auth)
ir = await gti.init()
# see the examples.py file for more functionality and use of the payloads
asyncio.run(main())
```
> :exclamation: **If using Python 3.8**: Version 3.6.2 of aiohttp uses a different EventLoopPolicy so running this MWE will currently result in an error displayed in the console! It should not affect the functionality. This should be fixed with a newer version of aiohttp. For a workaround look into the [examples.py](https://github.com/vigonotion/pygti/blob/master/examples.py) file. For more information see this [Issue](https://github.com/aio-libs/aiohttp/issues/4324).
## Progress
- [x] 1. init
- [x] 2. checkName
- [x] 3. getRoute
- [x] 4. departureList
- [x] 5. getTariff
- [x] 6. departureCourse
- [x] 7. listStations
- [x] 8. listLines
- [x] 9. getAnnouncements
- [x] 10. getIndividualRoute
- [x] 11a. getVehicleMap
- [x] 11b. getTrackCoordinates
- [x] 12. checkPostalCode
- [x] 13. getStationInformation
- [x] 14. tariffZoneNeighbours
- [x] 15. tariffMetaData
- [x] 16. singleTicketOptimizer
- [x] 17. ticketList
## Developing
Some files in this project are generated based on the WADL and XSD schema files from GTI.
To generate them, install the dev dependencies and run the script:
```sh
pip install -r requirements_dev.txt
python script/generate.py
```
## Contributions are welcome!
If you want to contribute to this, please read the [Contribution guidelines](CONTRIBUTING.md)
%prep
%autosetup -n pygti-0.9.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pygti -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.9.4-1
- Package Spec generated