%global _empty_manifest_terminate_build 0
Name:		python-bincrafters-conventions
Version:	1.1.1
Release:	1
Summary:	Bincrafters script to apply Conan conventions and update CI jobs
License:	MIT
URL:		https://github.com/bincrafters/bincrafters-conventions
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/42/f3/acf94a5ca6a5d8a28f5ef2e2c0f8c97cff10aa7818d4553f948c038ac3bf/bincrafters_conventions-1.1.1.tar.gz
BuildArch:	noarch


%description
![Build status](https://github.com/bincrafters/bincrafters-conventions/workflows/conventions/badge.svg)
[![Codecov](https://codecov.io/gh/bincrafters/bincrafters-conventions/branch/main/graph/badge.svg)](https://codecov.io/gh/bincrafters/bincrafters-conventions)
[![Pypi Download](https://img.shields.io/badge/download-pypi-blue.svg)](https://pypi.python.org/pypi/bincrafters-conventions)

# Bincrafters Conventions

## A Script to update Conan projects following Conan conventions

This project contains scripts to update CI files, to
update Conan conventions in general and to perform some linting.

### INSTALL

You can install `bincrafters-conventions` via `pip` like this:

    $ pip install bincrafters_conventions

### RUN

> 💡 Bincrafters Conventions is a command line tool.
> 
> Execute `bincrafters-conventions --help` to see all options.
> 
> `bincrafters-conventions` has also the alias `bcon` for convince.


#### EXAMPLES

To update **ALL** Conan projects on GitHub for https://github.com/bincrafters

    $ bcon --remote=bincrafters

To update **ONLY** one project on GitHub https://github.com/bincrafters/conan-conversion

    $ bcon --remote=bincrafters/conan-double-conversion

To **AVOID** to execute push command after to update

    $ bcon --remote=bincrafters/conan-libusb --dry-run

To filter **PROJECTS** by pattern

    $ bcon --remote=bincrafters --project-pattern bincrafters/conan-*

To filter **BRANCHES** by pattern

    $ bcon --remote=bincrafters --branch-pattern stable/*

or

    $ bcon --remote=bincrafters/conan-libzip --branch-pattern stable/*

To update and check **LOCAL** everything

    $ bcon
    
To check **LOCAL** everything

    $ bcon --check

To apply Conan conventions in a local file:

    $ bcon --conanfile=conanfile.py

To update AppVeyor file:

    $ bcon --appveryorfile=appveyor.yml


### Testing and Development

If you want to install `bincrafters-conventions` via a local git clone

    pip install --user -U .

To install extra packages required to test

    pip install .[test]

To run all unit test + code coverage, execute:

    cd tests
    pytest -v --cov=bincrafters_conventions


### LICENSE

[MIT](LICENSE.md)

%package -n python3-bincrafters-conventions
Summary:	Bincrafters script to apply Conan conventions and update CI jobs
Provides:	python-bincrafters-conventions
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bincrafters-conventions
![Build status](https://github.com/bincrafters/bincrafters-conventions/workflows/conventions/badge.svg)
[![Codecov](https://codecov.io/gh/bincrafters/bincrafters-conventions/branch/main/graph/badge.svg)](https://codecov.io/gh/bincrafters/bincrafters-conventions)
[![Pypi Download](https://img.shields.io/badge/download-pypi-blue.svg)](https://pypi.python.org/pypi/bincrafters-conventions)

# Bincrafters Conventions

## A Script to update Conan projects following Conan conventions

This project contains scripts to update CI files, to
update Conan conventions in general and to perform some linting.

### INSTALL

You can install `bincrafters-conventions` via `pip` like this:

    $ pip install bincrafters_conventions

### RUN

> 💡 Bincrafters Conventions is a command line tool.
> 
> Execute `bincrafters-conventions --help` to see all options.
> 
> `bincrafters-conventions` has also the alias `bcon` for convince.


#### EXAMPLES

To update **ALL** Conan projects on GitHub for https://github.com/bincrafters

    $ bcon --remote=bincrafters

To update **ONLY** one project on GitHub https://github.com/bincrafters/conan-conversion

    $ bcon --remote=bincrafters/conan-double-conversion

To **AVOID** to execute push command after to update

    $ bcon --remote=bincrafters/conan-libusb --dry-run

To filter **PROJECTS** by pattern

    $ bcon --remote=bincrafters --project-pattern bincrafters/conan-*

To filter **BRANCHES** by pattern

    $ bcon --remote=bincrafters --branch-pattern stable/*

or

    $ bcon --remote=bincrafters/conan-libzip --branch-pattern stable/*

To update and check **LOCAL** everything

    $ bcon
    
To check **LOCAL** everything

    $ bcon --check

To apply Conan conventions in a local file:

    $ bcon --conanfile=conanfile.py

To update AppVeyor file:

    $ bcon --appveryorfile=appveyor.yml


### Testing and Development

If you want to install `bincrafters-conventions` via a local git clone

    pip install --user -U .

To install extra packages required to test

    pip install .[test]

To run all unit test + code coverage, execute:

    cd tests
    pytest -v --cov=bincrafters_conventions


### LICENSE

[MIT](LICENSE.md)

%package help
Summary:	Development documents and examples for bincrafters-conventions
Provides:	python3-bincrafters-conventions-doc
%description help
![Build status](https://github.com/bincrafters/bincrafters-conventions/workflows/conventions/badge.svg)
[![Codecov](https://codecov.io/gh/bincrafters/bincrafters-conventions/branch/main/graph/badge.svg)](https://codecov.io/gh/bincrafters/bincrafters-conventions)
[![Pypi Download](https://img.shields.io/badge/download-pypi-blue.svg)](https://pypi.python.org/pypi/bincrafters-conventions)

# Bincrafters Conventions

## A Script to update Conan projects following Conan conventions

This project contains scripts to update CI files, to
update Conan conventions in general and to perform some linting.

### INSTALL

You can install `bincrafters-conventions` via `pip` like this:

    $ pip install bincrafters_conventions

### RUN

> 💡 Bincrafters Conventions is a command line tool.
> 
> Execute `bincrafters-conventions --help` to see all options.
> 
> `bincrafters-conventions` has also the alias `bcon` for convince.


#### EXAMPLES

To update **ALL** Conan projects on GitHub for https://github.com/bincrafters

    $ bcon --remote=bincrafters

To update **ONLY** one project on GitHub https://github.com/bincrafters/conan-conversion

    $ bcon --remote=bincrafters/conan-double-conversion

To **AVOID** to execute push command after to update

    $ bcon --remote=bincrafters/conan-libusb --dry-run

To filter **PROJECTS** by pattern

    $ bcon --remote=bincrafters --project-pattern bincrafters/conan-*

To filter **BRANCHES** by pattern

    $ bcon --remote=bincrafters --branch-pattern stable/*

or

    $ bcon --remote=bincrafters/conan-libzip --branch-pattern stable/*

To update and check **LOCAL** everything

    $ bcon
    
To check **LOCAL** everything

    $ bcon --check

To apply Conan conventions in a local file:

    $ bcon --conanfile=conanfile.py

To update AppVeyor file:

    $ bcon --appveryorfile=appveyor.yml


### Testing and Development

If you want to install `bincrafters-conventions` via a local git clone

    pip install --user -U .

To install extra packages required to test

    pip install .[test]

To run all unit test + code coverage, execute:

    cd tests
    pytest -v --cov=bincrafters_conventions


### LICENSE

[MIT](LICENSE.md)

%prep
%autosetup -n bincrafters-conventions-1.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bincrafters-conventions -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
- Package Spec generated