%global _empty_manifest_terminate_build 0
Name:		python-pytest-extra-durations
Version:	0.1.3
Release:	1
Summary:	A pytest plugin to get durations on a per-function basis and per module basis.
License:	MIT
URL:		https://github.com/gabrieldemarmiesse/pytest-extra-durations
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/9e/9c/9f42b36184b5cbb4ea8e4a8c6402fe9772afba8fa3d22bb488d8886cdcf0/pytest-extra-durations-0.1.3.tar.gz
BuildArch:	noarch

Requires:	python3-pytest

%description
1.95s
```
This will be displayed all the time and can't be turned off unless you 
uninstall this plugin.
#### The sum of all the tests durations of a module
This will tell you how much time it took to execute all the tests in a given file.
The API is similar to the one of `--durations` in the Pytest CLI.
```bash
pytest --modules-durations=4 ./path/to/test/directory
```
gives:

%package -n python3-pytest-extra-durations
Summary:	A pytest plugin to get durations on a per-function basis and per module basis.
Provides:	python-pytest-extra-durations
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-extra-durations
1.95s
```
This will be displayed all the time and can't be turned off unless you 
uninstall this plugin.
#### The sum of all the tests durations of a module
This will tell you how much time it took to execute all the tests in a given file.
The API is similar to the one of `--durations` in the Pytest CLI.
```bash
pytest --modules-durations=4 ./path/to/test/directory
```
gives:

%package help
Summary:	Development documents and examples for pytest-extra-durations
Provides:	python3-pytest-extra-durations-doc
%description help
1.95s
```
This will be displayed all the time and can't be turned off unless you 
uninstall this plugin.
#### The sum of all the tests durations of a module
This will tell you how much time it took to execute all the tests in a given file.
The API is similar to the one of `--durations` in the Pytest CLI.
```bash
pytest --modules-durations=4 ./path/to/test/directory
```
gives:

%prep
%autosetup -n pytest-extra-durations-0.1.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-extra-durations -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3-1
- Package Spec generated