%global _empty_manifest_terminate_build 0
Name: python-formulae
Version: 0.3.4
Release: 1
Summary: Formulas for mixed-effects models in Python
License: MIT
URL: https://github.com/bambinos/formulae
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/a7/4a3043b24f76d318eb6f12464aca4daef39c23630803eeb6acbae8a78fc3/formulae-0.3.4.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scipy
%description
[](https://badge.fury.io/py/formulae)
[](https://codecov.io/gh/bambinos/formulae)
[](https://github.com/ambv/black)
# formulae
formulae is a Python library that implements Wilkinson's formulas for mixed-effects models. The main difference with other implementations like [Patsy](https://github.com/pydata/patsy) or [formulaic](https://github.com/matthewwardrop/formulaic) is that formulae can work with formulas describing a model with both common and group specific effects (a.k.a. fixed and random effects, respectively).
This package has been written to make it easier to specify models with group effects in [Bambi](https://github.com/bambinos/bambi), a package that makes it easy to work with Bayesian GLMMs in Python, but it could be used independently as a backend for another library. The approach in this library is to extend classical statistical formulas in a similar way than in R package [lme4](https://CRAN.R-project.org/package=lme4).
## Installation
formulae requires a working Python interpreter (3.7+) and the libraries numpy, scipy and pandas with versions specified in the [requirements.txt](https://github.com/bambinos/formulae/blob/master/requirements.txt) file.
Assuming a standard Python environment is installed on your machine (including pip), the latest release of formulae can be installed in one line using pip:
`pip install formulae`
Alternatively, if you want the development version of the package you can install from GitHub:
`pip install git+https://github.com/bambinos/formulae.git`
## Documentation
The official documentation can be found [here](https://bambinos.github.io/formulae)
## Notes
- The `data` argument only accepts objects of class `pandas.DataFrame`.
- `y ~ .` is not implemented and won't be implemented in a first version. However, it is planned to be included in the future.
%package -n python3-formulae
Summary: Formulas for mixed-effects models in Python
Provides: python-formulae
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-formulae
[](https://badge.fury.io/py/formulae)
[](https://codecov.io/gh/bambinos/formulae)
[](https://github.com/ambv/black)
# formulae
formulae is a Python library that implements Wilkinson's formulas for mixed-effects models. The main difference with other implementations like [Patsy](https://github.com/pydata/patsy) or [formulaic](https://github.com/matthewwardrop/formulaic) is that formulae can work with formulas describing a model with both common and group specific effects (a.k.a. fixed and random effects, respectively).
This package has been written to make it easier to specify models with group effects in [Bambi](https://github.com/bambinos/bambi), a package that makes it easy to work with Bayesian GLMMs in Python, but it could be used independently as a backend for another library. The approach in this library is to extend classical statistical formulas in a similar way than in R package [lme4](https://CRAN.R-project.org/package=lme4).
## Installation
formulae requires a working Python interpreter (3.7+) and the libraries numpy, scipy and pandas with versions specified in the [requirements.txt](https://github.com/bambinos/formulae/blob/master/requirements.txt) file.
Assuming a standard Python environment is installed on your machine (including pip), the latest release of formulae can be installed in one line using pip:
`pip install formulae`
Alternatively, if you want the development version of the package you can install from GitHub:
`pip install git+https://github.com/bambinos/formulae.git`
## Documentation
The official documentation can be found [here](https://bambinos.github.io/formulae)
## Notes
- The `data` argument only accepts objects of class `pandas.DataFrame`.
- `y ~ .` is not implemented and won't be implemented in a first version. However, it is planned to be included in the future.
%package help
Summary: Development documents and examples for formulae
Provides: python3-formulae-doc
%description help
[](https://badge.fury.io/py/formulae)
[](https://codecov.io/gh/bambinos/formulae)
[](https://github.com/ambv/black)
# formulae
formulae is a Python library that implements Wilkinson's formulas for mixed-effects models. The main difference with other implementations like [Patsy](https://github.com/pydata/patsy) or [formulaic](https://github.com/matthewwardrop/formulaic) is that formulae can work with formulas describing a model with both common and group specific effects (a.k.a. fixed and random effects, respectively).
This package has been written to make it easier to specify models with group effects in [Bambi](https://github.com/bambinos/bambi), a package that makes it easy to work with Bayesian GLMMs in Python, but it could be used independently as a backend for another library. The approach in this library is to extend classical statistical formulas in a similar way than in R package [lme4](https://CRAN.R-project.org/package=lme4).
## Installation
formulae requires a working Python interpreter (3.7+) and the libraries numpy, scipy and pandas with versions specified in the [requirements.txt](https://github.com/bambinos/formulae/blob/master/requirements.txt) file.
Assuming a standard Python environment is installed on your machine (including pip), the latest release of formulae can be installed in one line using pip:
`pip install formulae`
Alternatively, if you want the development version of the package you can install from GitHub:
`pip install git+https://github.com/bambinos/formulae.git`
## Documentation
The official documentation can be found [here](https://bambinos.github.io/formulae)
## Notes
- The `data` argument only accepts objects of class `pandas.DataFrame`.
- `y ~ .` is not implemented and won't be implemented in a first version. However, it is planned to be included in the future.
%prep
%autosetup -n formulae-0.3.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-formulae -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.3.4-1
- Package Spec generated