%global _empty_manifest_terminate_build 0
Name: python-locopy
Version: 0.5.1
Release: 1
Summary: Loading/Unloading to Amazon Redshift using Python
License: Apache Software License
URL: https://github.com/capitalone/locopy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/8f/92bea84349268b5229630987153da31473236812683d5760c7453456e6b3/locopy-0.5.1.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-PyYAML
Requires: python3-pandas
Requires: python3-numpy
Requires: python3-build
Requires: python3-twine
Requires: python3-wheel
Requires: python3-hypothesis
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-pre-commit
Requires: python3-black
Requires: python3-isort
Requires: python3-build
Requires: python3-twine
Requires: python3-wheel
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-edgetest
Requires: python3-edgetest-conda
Requires: python3-pg8000
Requires: python3-psycopg2-binary
Requires: python3-pre-commit
Requires: python3-black
Requires: python3-isort
Requires: python3-snowflake-connector-python[pandas]
Requires: python3-hypothesis
Requires: python3-pytest
Requires: python3-pytest-cov
%description
A Python library to assist with ETL processing for:
- Amazon Redshift (``COPY``, ``UNLOAD``)
- Snowflake (``COPY INTO
``, ``COPY INTO ``)
In addition:
- The library supports Python 3.8 to 3.10
- DB Driver (Adapter) agnostic. Use your favourite driver that complies with
`DB-API 2.0 `_
- It provides functionality to download and upload data to S3 buckets, and internal stages (Snowflake)
%package -n python3-locopy
Summary: Loading/Unloading to Amazon Redshift using Python
Provides: python-locopy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-locopy
A Python library to assist with ETL processing for:
- Amazon Redshift (``COPY``, ``UNLOAD``)
- Snowflake (``COPY INTO ``, ``COPY INTO ``)
In addition:
- The library supports Python 3.8 to 3.10
- DB Driver (Adapter) agnostic. Use your favourite driver that complies with
`DB-API 2.0 `_
- It provides functionality to download and upload data to S3 buckets, and internal stages (Snowflake)
%package help
Summary: Development documents and examples for locopy
Provides: python3-locopy-doc
%description help
A Python library to assist with ETL processing for:
- Amazon Redshift (``COPY``, ``UNLOAD``)
- Snowflake (``COPY INTO ``, ``COPY INTO ``)
In addition:
- The library supports Python 3.8 to 3.10
- DB Driver (Adapter) agnostic. Use your favourite driver that complies with
`DB-API 2.0 `_
- It provides functionality to download and upload data to S3 buckets, and internal stages (Snowflake)
%prep
%autosetup -n locopy-0.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-locopy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 0.5.1-1
- Package Spec generated