%global _empty_manifest_terminate_build 0
Name: python-strongtyping
Version: 3.10.7
Release: 1
Summary: Decorator which checks whether the function is called with the correct type of parameters
License: MIT
URL: https://strongtyping.readthedocs.io/en/latest/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/fa/0e29a3519f8cd7c0c10962375670e1fde97fa3733ec298e2ebd6b7bedd0d/strongtyping-3.10.7.tar.gz
BuildArch: noarch
%description
[](https://www.python.org/downloads/release/python-3100/)
[](https://www.python.org/downloads/release/python-3110/)
[](https://badge.fury.io/py/strongtyping)



[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/strongtyping/)
# Strong Typing
Decorator which checks at Runtime whether the function is called with the correct type of parameters.
And raises TypeMisMatch if the used parameters in a function call where invalid.
# This is the release for Python-3.10 and above
- If you need a different version please checkout the release Tags 2.\*.*
## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
%package -n python3-strongtyping
Summary: Decorator which checks whether the function is called with the correct type of parameters
Provides: python-strongtyping
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-strongtyping
[](https://www.python.org/downloads/release/python-3100/)
[](https://www.python.org/downloads/release/python-3110/)
[](https://badge.fury.io/py/strongtyping)



[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/strongtyping/)
# Strong Typing
Decorator which checks at Runtime whether the function is called with the correct type of parameters.
And raises TypeMisMatch if the used parameters in a function call where invalid.
# This is the release for Python-3.10 and above
- If you need a different version please checkout the release Tags 2.\*.*
## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
%package help
Summary: Development documents and examples for strongtyping
Provides: python3-strongtyping-doc
%description help
[](https://www.python.org/downloads/release/python-3100/)
[](https://www.python.org/downloads/release/python-3110/)
[](https://badge.fury.io/py/strongtyping)



[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
[](https://pypi.org/project/strongtyping/)
# Strong Typing
Decorator which checks at Runtime whether the function is called with the correct type of parameters.
And raises TypeMisMatch if the used parameters in a function call where invalid.
# This is the release for Python-3.10 and above
- If you need a different version please checkout the release Tags 2.\*.*
## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
%prep
%autosetup -n strongtyping-3.10.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-strongtyping -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 3.10.7-1
- Package Spec generated