%global _empty_manifest_terminate_build 0
Name: python-remoto
Version: 1.2.1
Release: 1
Summary: Execute remote commands or processes.
License: MIT
URL: http://github.com/alfredodeza/remoto
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/02/a9e5b25538bd12d98c7ea6d277c33e472d1d1d4ec50a4d42be3ca73f6023/remoto-1.2.1.tar.gz
BuildArch: noarch
%description
A very simplistic remote-command-executor using connections to hosts (``ssh``,
local, containers, and several others are supported) and Python in the remote
end.
All the heavy lifting is done by execnet, while this minimal API provides the
bare minimum to handle easy logging and connections from the remote end.
``remoto`` is a bit opinionated as it was conceived to replace helpers and
remote utilities for ``ceph-deploy``, a tool to run remote commands to configure
and setup the distributed file system Ceph. `ceph-medic
`_ uses remoto as well to inspect Ceph
clusters.
%package -n python3-remoto
Summary: Execute remote commands or processes.
Provides: python-remoto
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-remoto
A very simplistic remote-command-executor using connections to hosts (``ssh``,
local, containers, and several others are supported) and Python in the remote
end.
All the heavy lifting is done by execnet, while this minimal API provides the
bare minimum to handle easy logging and connections from the remote end.
``remoto`` is a bit opinionated as it was conceived to replace helpers and
remote utilities for ``ceph-deploy``, a tool to run remote commands to configure
and setup the distributed file system Ceph. `ceph-medic
`_ uses remoto as well to inspect Ceph
clusters.
%package help
Summary: Development documents and examples for remoto
Provides: python3-remoto-doc
%description help
A very simplistic remote-command-executor using connections to hosts (``ssh``,
local, containers, and several others are supported) and Python in the remote
end.
All the heavy lifting is done by execnet, while this minimal API provides the
bare minimum to handle easy logging and connections from the remote end.
``remoto`` is a bit opinionated as it was conceived to replace helpers and
remote utilities for ``ceph-deploy``, a tool to run remote commands to configure
and setup the distributed file system Ceph. `ceph-medic
`_ uses remoto as well to inspect Ceph
clusters.
%prep
%autosetup -n remoto-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-remoto -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 10 2023 Python_Bot - 1.2.1-1
- Package Spec generated