%global _empty_manifest_terminate_build 0
Name: python-ocean-lib
Version: 2.2.3
Release: 1
Summary: 🐳 Ocean protocol library.
License: Apache Software License 2.0
URL: https://github.com/oceanprotocol/ocean.py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2f/67/7dc3c1b425d08091e34afee14f8c7b47fa452102b104687a99cfd48d71c3/ocean-lib-2.2.3.tar.gz
BuildArch: noarch
Requires: python3-ocean-contracts
Requires: python3-coloredlogs
Requires: python3-requests
Requires: python3-pytz
Requires: python3-enforce-typing
Requires: python3-eciespy
Requires: python3-eth-brownie
Requires: python3-cryptography
Requires: python3-yarl
Requires: python3-bitarray
Requires: python3-bumpversion
Requires: python3-pkginfo
Requires: python3-twine
Requires: python3-watchdog
Requires: python3-isort
Requires: python3-flake8
Requires: python3-black
Requires: python3-pre-commit
Requires: python3-licenseheaders
Requires: python3-codacy-coverage
Requires: python3-coverage
Requires: python3-mccabe
Requires: python3-pytest
Requires: python3-pytest-watch
Requires: python3-pytest-env
Requires: python3-matplotlib
Requires: python3-mkcodes
Requires: python3-pytest-sugar
Requires: python3-codacy-coverage
Requires: python3-coverage
Requires: python3-mccabe
Requires: python3-pytest
Requires: python3-pytest-watch
Requires: python3-pytest-env
Requires: python3-matplotlib
Requires: python3-mkcodes
Requires: python3-pytest-sugar
%description
> ocean.py: a Python library to privately & securely publish, exchange, and consume data.
[![Maintainability](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/maintainability)](https://codeclimate.com/github/oceanprotocol/ocean.py/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/test_coverage)](https://codeclimate.com/github/oceanprotocol/ocean.py/test_coverage)
With ocean.py, you can:
- **Publish** data services: downloadable files or compute-to-data. Create an ERC721 **data NFT** for each service, and ERC20 **datatoken** for access (1.0 datatokens to access).
- **Sell** datatokens via for a fixed price. Sell data NFTs.
- **Transfer** data NFTs & datatokens to another owner, and **all other ERC721 & ERC20 actions** using [web3.py](https://web3py.readthedocs.io) or [Brownie](https://eth-brownie.readthedocs.io/en/latest/).
ocean.py is part of the [Ocean Protocol](https://www.oceanprotocol.com) toolset.
This is in beta state. If you run into problems, please open up a [new issue](/issues).
- [🏄 Quickstart](#-quickstart)
- [🦑 Development](#-development)
- [🏛 License](#-license)
## 🏄 Quickstart
Follow these steps in sequence to ramp into Ocean.
1. **[Install Ocean](READMEs/install.md)**
2. **Setup:**
- **[Remote](READMEs/setup-remote.md)** (Win, MacOS, Linux)
- *or* **[Local](READMEs/setup-local.md)** (Linux only)
3. **[Walk through main flow](READMEs/main-flow.md)**: publish asset, post for free / for sale, dispense it / buy it, and consume it
### Tools
- [Define gas strategy](READMEs/gas-strategy-remote.md) - auto-determine gas fee for remote networks
- [Search & filter data](READMEs/search-and-filter-assets.md) - find assets by tag
- [Custody-light flow](READMEs/custody-light-flow.md) - consume a free & a priced asset without custody
### Use-case flows
- [Predict ETH](https://github.com/oceanprotocol/predict-eth) - data challenges with prize $$ to predict future ETH price
- [Data Farming](READMEs/df.md) - curate data assets, earn rewards
### On-chain key-value store via data NFTs
- [Sharing public data on-chain](READMEs/key-value-public.md) - e.g. public AI models
- [Sharing private data on-chain](READMEs/key-value-private.md) - e.g. private AI models
### More types of data assets
Each of the following shows how to publish & consume a particular type of data.
- [C2D](READMEs/c2d-flow.md) - tokenize & monetize AI algorithms via Compute-to-Data
- [REST API](READMEs/publish-flow-restapi.md) - Example on Binance ETH price feed
- [GraphQL](READMEs/publish-flow-graphql.md) - Example on Ocean Data NFTs
- [On-chain data](READMEs/publish-flow-onchain.md) - Example on Ocean swap fees
### Learn more
- [Understand config parameters](READMEs/parameters.md) - envvars vs files
- [Learn about off-chain services](READMEs/services.md) - Ocean Provider for data services, Aquarius metadata store
## 🦑 Development
- **[Developers flow](READMEs/developers.md)** - to further develop ocean.py
- [Release process](READMEs/release-process.md) - to do a new release of ocean.py
## 🏛 License
Copyright ((C)) 2022 Ocean Protocol Foundation
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%package -n python3-ocean-lib
Summary: 🐳 Ocean protocol library.
Provides: python-ocean-lib
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ocean-lib
> ocean.py: a Python library to privately & securely publish, exchange, and consume data.
[![Maintainability](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/maintainability)](https://codeclimate.com/github/oceanprotocol/ocean.py/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/test_coverage)](https://codeclimate.com/github/oceanprotocol/ocean.py/test_coverage)
With ocean.py, you can:
- **Publish** data services: downloadable files or compute-to-data. Create an ERC721 **data NFT** for each service, and ERC20 **datatoken** for access (1.0 datatokens to access).
- **Sell** datatokens via for a fixed price. Sell data NFTs.
- **Transfer** data NFTs & datatokens to another owner, and **all other ERC721 & ERC20 actions** using [web3.py](https://web3py.readthedocs.io) or [Brownie](https://eth-brownie.readthedocs.io/en/latest/).
ocean.py is part of the [Ocean Protocol](https://www.oceanprotocol.com) toolset.
This is in beta state. If you run into problems, please open up a [new issue](/issues).
- [🏄 Quickstart](#-quickstart)
- [🦑 Development](#-development)
- [🏛 License](#-license)
## 🏄 Quickstart
Follow these steps in sequence to ramp into Ocean.
1. **[Install Ocean](READMEs/install.md)**
2. **Setup:**
- **[Remote](READMEs/setup-remote.md)** (Win, MacOS, Linux)
- *or* **[Local](READMEs/setup-local.md)** (Linux only)
3. **[Walk through main flow](READMEs/main-flow.md)**: publish asset, post for free / for sale, dispense it / buy it, and consume it
### Tools
- [Define gas strategy](READMEs/gas-strategy-remote.md) - auto-determine gas fee for remote networks
- [Search & filter data](READMEs/search-and-filter-assets.md) - find assets by tag
- [Custody-light flow](READMEs/custody-light-flow.md) - consume a free & a priced asset without custody
### Use-case flows
- [Predict ETH](https://github.com/oceanprotocol/predict-eth) - data challenges with prize $$ to predict future ETH price
- [Data Farming](READMEs/df.md) - curate data assets, earn rewards
### On-chain key-value store via data NFTs
- [Sharing public data on-chain](READMEs/key-value-public.md) - e.g. public AI models
- [Sharing private data on-chain](READMEs/key-value-private.md) - e.g. private AI models
### More types of data assets
Each of the following shows how to publish & consume a particular type of data.
- [C2D](READMEs/c2d-flow.md) - tokenize & monetize AI algorithms via Compute-to-Data
- [REST API](READMEs/publish-flow-restapi.md) - Example on Binance ETH price feed
- [GraphQL](READMEs/publish-flow-graphql.md) - Example on Ocean Data NFTs
- [On-chain data](READMEs/publish-flow-onchain.md) - Example on Ocean swap fees
### Learn more
- [Understand config parameters](READMEs/parameters.md) - envvars vs files
- [Learn about off-chain services](READMEs/services.md) - Ocean Provider for data services, Aquarius metadata store
## 🦑 Development
- **[Developers flow](READMEs/developers.md)** - to further develop ocean.py
- [Release process](READMEs/release-process.md) - to do a new release of ocean.py
## 🏛 License
Copyright ((C)) 2022 Ocean Protocol Foundation
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%package help
Summary: Development documents and examples for ocean-lib
Provides: python3-ocean-lib-doc
%description help
> ocean.py: a Python library to privately & securely publish, exchange, and consume data.
[![Maintainability](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/maintainability)](https://codeclimate.com/github/oceanprotocol/ocean.py/maintainability)
[![Test Coverage](https://api.codeclimate.com/v1/badges/a0be65f412a35440c63e/test_coverage)](https://codeclimate.com/github/oceanprotocol/ocean.py/test_coverage)
With ocean.py, you can:
- **Publish** data services: downloadable files or compute-to-data. Create an ERC721 **data NFT** for each service, and ERC20 **datatoken** for access (1.0 datatokens to access).
- **Sell** datatokens via for a fixed price. Sell data NFTs.
- **Transfer** data NFTs & datatokens to another owner, and **all other ERC721 & ERC20 actions** using [web3.py](https://web3py.readthedocs.io) or [Brownie](https://eth-brownie.readthedocs.io/en/latest/).
ocean.py is part of the [Ocean Protocol](https://www.oceanprotocol.com) toolset.
This is in beta state. If you run into problems, please open up a [new issue](/issues).
- [🏄 Quickstart](#-quickstart)
- [🦑 Development](#-development)
- [🏛 License](#-license)
## 🏄 Quickstart
Follow these steps in sequence to ramp into Ocean.
1. **[Install Ocean](READMEs/install.md)**
2. **Setup:**
- **[Remote](READMEs/setup-remote.md)** (Win, MacOS, Linux)
- *or* **[Local](READMEs/setup-local.md)** (Linux only)
3. **[Walk through main flow](READMEs/main-flow.md)**: publish asset, post for free / for sale, dispense it / buy it, and consume it
### Tools
- [Define gas strategy](READMEs/gas-strategy-remote.md) - auto-determine gas fee for remote networks
- [Search & filter data](READMEs/search-and-filter-assets.md) - find assets by tag
- [Custody-light flow](READMEs/custody-light-flow.md) - consume a free & a priced asset without custody
### Use-case flows
- [Predict ETH](https://github.com/oceanprotocol/predict-eth) - data challenges with prize $$ to predict future ETH price
- [Data Farming](READMEs/df.md) - curate data assets, earn rewards
### On-chain key-value store via data NFTs
- [Sharing public data on-chain](READMEs/key-value-public.md) - e.g. public AI models
- [Sharing private data on-chain](READMEs/key-value-private.md) - e.g. private AI models
### More types of data assets
Each of the following shows how to publish & consume a particular type of data.
- [C2D](READMEs/c2d-flow.md) - tokenize & monetize AI algorithms via Compute-to-Data
- [REST API](READMEs/publish-flow-restapi.md) - Example on Binance ETH price feed
- [GraphQL](READMEs/publish-flow-graphql.md) - Example on Ocean Data NFTs
- [On-chain data](READMEs/publish-flow-onchain.md) - Example on Ocean swap fees
### Learn more
- [Understand config parameters](READMEs/parameters.md) - envvars vs files
- [Learn about off-chain services](READMEs/services.md) - Ocean Provider for data services, Aquarius metadata store
## 🦑 Development
- **[Developers flow](READMEs/developers.md)** - to further develop ocean.py
- [Release process](READMEs/release-process.md) - to do a new release of ocean.py
## 🏛 License
Copyright ((C)) 2022 Ocean Protocol Foundation
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%prep
%autosetup -n ocean-lib-2.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ocean-lib -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 2.2.3-1
- Package Spec generated